Bug 139724 - Linux hangs after reboot at "Configuring kernel parameters"
Linux hangs after reboot at "Configuring kernel parameters"
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-11-17 14:03 EST by orondo jones
Modified: 2015-01-04 17:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-10-02 20:19:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description orondo jones 2004-11-17 14:03:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
linux checks for hardware and returns OK then it says, "Configuring 
Kernel parameters" and does nothing else

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.reboot the machine

Actual Results:  linux checks for hardware and returns OK then it 
says, "Configuring Kernel parameters" and does nothing else

Additional info:
Comment 1 Larry Menten 2004-11-17 15:33:37 EST
I have experienced the same bug:
HP Kayak XA i440BX, 500 MHz Pentium III, 128M RAM, Rev. HU.11.11US
PhoenixBIOS 4.0 Release 6.0.6

Hangs at "Configuring kernel parameters:"
Comment 2 Darin 2004-11-17 23:15:08 EST
I'm seeing the same thing:
AOpen AX6BC Motherboard, Celeron 433, 64M RAM, latest BIOS (2.59).

If I <CTRL-C> the hung step, the initialization continues but has a
great deal of problems.  Also, when the system actually 'is ready',
the filesystem appears to be read-only.
Comment 3 Anthony Stevens 2004-11-18 10:52:55 EST
I am seeing the same problem. Just installed FC3 on an older shuttle
small form factor machine, with a pentium 4 1.2Ghz. 2 network cards (1
builtin to motherboard, one e100 pci card). 1 voodoo 3 video card, and
an onboard video card. 

I ended up doing the install twice, once with the onboard video card
enabled, once with it disabled  (pci video card is primary output).

 After the install, during firstboot, machine stopped at Configuring
Kernel Parameters. Hitting ^C allowed it continue, but filesystem was
readonly. X never started. 

I finished install last night, so didn't get a chance to hack on it to
resolve the problem. 

Machine was running Suse 9.1 Pro before, and the install process for
that went smoothly. 
Comment 4 Darin 2004-11-18 10:59:57 EST
More information:

I totally reinstalled the system with two (major) changes...  #1. I
accepted Fedora's suggested partitioning.  The first install I ran I
did some custom partitioning and remove the logical volumes, etc.  #2.
I did a "minimal" install rather than installing all the packages I
wanted at install time. 

It now boots up without problems.  I guess I am going to gradually
start installing additional packages and see when it breaks.
Comment 5 Michael Setzer II 2004-11-21 09:57:40 EST
I have a similar problem. First problem involved bug 138419 dealing
with the partition settings and drive geometry. The solution there got
the install to go thru, but the system upgrade then locks at this
point. A clean install that deletes the existing linux partitions does
go thru and works fine, but then I lose all the configuration info. My
machines are setup to boot 98/XP/Linux. 98 is on the first partition,
then XP is the first logical partition, and then the three Linux
Comment 6 Anthony Stevens 2004-11-22 09:58:34 EST
removing rhbg from the grub boot option fixed the problem. After that,
it was a matter of correctly configuring X. I have not yet configured
dual head support. 
Comment 7 Larry Menten 2004-11-22 12:28:09 EST
HP Kayak XA i440BX, 500 MHz Pentium III, 128M RAM, Rev. HU.11.11US
PhoenixBIOS 4.0 Release 6.0.6

My problem was resolved by removing the second video controller card
from the system.  Once this was done, the system booted normally.  I
removed an ATI Mach64 card, leaving the original Matrox Millenium G200
in place.  Kudzu ran upon first boot to recommend removing the ATI
card from the configuration, which I did.  System boots perfectly now.

BTW, I am running in graphical mode with 128M of memory which is below
the recommended 192M.
Comment 8 Michael Setzer II 2004-11-28 06:43:21 EST
Seemed to be a problem with the NVIDIA driver in xorg.conf. I changed
to  the vesa driver after doing a kernel update on FC2, and then tried
the FC3 install, and it went thru with no problems. Must not have like
the nvidia driver, or atleast it hung on it. 
Comment 9 Don Smith 2004-12-07 10:13:24 EST
Seeing the same thing on my IBM Intellistation Z Pro w/NVIDIA Quadro
FX 1300. Things work fine for me as well until I install the NVIDIA
binary driver, at which point it comes up in text mode and just sits
there on "Configuring kernel paraeters". A control-C gets past that
but as mentioned before the filesystem is mounted read-only. 

Removing "rhgb" from the kernel boot parameters allows the system to
get past that, but then X can't come up, complaining that it "Failed
to initialize the NVIDIA kernel module!" Of course, doing an lsmod
reveals the nvidia module is not loaded. However, even after loading
the module, X cannot start, giving the same error message.

I ran the NVIDIA driver installer again at this point. X was able to
start again... until I rebooted, at which point I had to re-install
the driver again to make X work. Could something in system startup be
messing with the driver somehow?
Comment 10 Dave Jones 2005-02-13 00:05:58 EST
orondo, are you still seeing problems with the latest updates, or can this be
closed?    Were you too using nvidia's driver ?

Comment 11 Dave Jones 2005-07-15 15:37:51 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 12 Dave Jones 2005-10-02 20:19:11 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.