Bug 139725 - xchat tab completion hits first match
Summary: xchat tab completion hits first match
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Reed
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-17 19:19 UTC by Matthew Galgoci
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-03 23:15:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Galgoci 2004-11-17 19:19:52 UTC
Description of problem:

xchat username autocompletion completes on first match.

Version-Release number of selected component (if applicable):

2.4.x

How reproducible:

Very

Steps to Reproduce:
1.try and tab complete a nic where there is more than one match.
  
Actual results:

I would like to see the xchat 1.8.x behaviour returned. ie, tab
completion similar to how bash completes for binaries in your path.

Comment 2 Daniel Reed 2005-01-30 19:53:43 UTC
From upstream:
Date: 2005-01-26 18:31
Sender: nobody
Logged In: NO 

This is not a bug. You can get the old behavior by:

/set completion_amount 1

Greets - mm_freak

Comment 3 Dario Landazuri 2006-09-12 02:31:14 UTC
fwiw, you can also set old_nickcompletion = 1 in ~/.xchat/xchat.conf which will
make it so you don't have to always do the /set completion_amount 1 bit.


Note You need to log in before you can comment on or make changes to this bug.