Bug 1397354 - "systemctl is-enabled" inside chroot returns 0 on non-existing unit
Summary: "systemctl is-enabled" inside chroot returns 0 on non-existing unit
Keywords:
Status: CLOSED DUPLICATE of bug 1413964
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-22 11:12 UTC by Denis Silakov
Modified: 2017-01-24 14:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-24 14:54:57 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Denis Silakov 2016-11-22 11:12:25 UTC
Description of problem:

When launched inside chroot, "systemctl is-enabled" returns 0 when it fails to find requested unit. If launch in a real system (not in chroot), it returns 1.  In RHEL 7.2 it always returned 1 and this seemed to be correct behavior.

Version-Release number of selected component (if applicable):
systemd-219-30

How reproducible:
Always

Steps to Reproduce:
1. Install RHEL 7.3
2. Boot from some LiveCD, mount RHEL 7.3 root, bind mount /proc inside it and chroot into it
3. Launch "systemctl is-enabled foo.bar" (provide it with any non-existing unit name)

Actual results:
systemctl prints "no such file or directory" but returns 0.

Expected results:
systemctl exits with non-zero status.

Additional info:
Setting "SYSTEMD_IGNORE_CHROOT" variable makes systemctl return 1, but this seems to be an ugly workaround, not a real solution.

Comment 2 Denis Silakov 2016-11-22 13:18:11 UTC
This behavior is likely caused by "0296-install-follow-unit-file-symlinks-in-usr-but-not-etc.patch" and goes away if I disable this patch (together with several others which fails to apply without it). Can't point to particular reason, that patch introduces quite a few changes.

Comment 3 Jan Synacek 2017-01-24 14:54:57 UTC

*** This bug has been marked as a duplicate of bug 1413964 ***


Note You need to log in before you can comment on or make changes to this bug.