Bug 1397390 - Add support for new Fedora packaging macros
Summary: Add support for new Fedora packaging macros
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ruby
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Vít Ondruch
QA Contact: Miroslav Hradílek
Lenka Špačková
URL:
Whiteboard:
Keywords: FutureFeature
Depends On: 1428369
Blocks: 1393868
TreeView+ depends on / blocked
 
Reported: 2016-11-22 12:36 UTC by Vít Ondruch
Modified: 2018-11-21 12:53 UTC (History)
6 users (show)

(edit)
Support for `%gemspec_add_dep` and `%gemspec_remove_dep` has been added 

This update adds support for the `%gemspec_add_dep` and `%gemspec_remove_dep` macros. These macros allow easier adjustment of _rubygem-*_ package dependencies. In addition, all current macros have been extended to improve support for pre-release version of packages.
Clone Of:
(edit)
Last Closed: 2017-08-01 20:56:55 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2037 normal SHIPPED_LIVE ruby bug fix and enhancement update 2017-08-01 18:35:11 UTC

Description Vít Ondruch 2016-11-22 12:36:31 UTC
Description of problem:
For better compatibility with recent Fedora and easier packaging, it would be nice if RHEL supported %gemspec_add_dep and %gemspec_remove_dep macros.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
%gemspec_add_dep and %gemspec_remove_dep are not supported


Expected results:
%gemspec_add_dep and %gemspec_remove_dep are supported


Additional info:


[1]: http://pkgs.fedoraproject.org/cgit/rpms/ruby.git/tree/macros.rubygems#n49

Comment 8 errata-xmlrpc 2017-08-01 20:56:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2037


Note You need to log in before you can comment on or make changes to this bug.