Bug 1397479 - Bad Supplements: pulseaudio
Summary: Bad Supplements: pulseaudio
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mpg123
Version: 25
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL: https://fedoraproject.org/wiki/Packag...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-22 15:54 UTC by Kevin Kofler
Modified: 2017-01-06 07:51 UTC (History)
2 users (show)

Fixed In Version: mpg123-1.23.8-4.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-06 07:51:39 UTC


Attachments (Terms of Use)

Description Kevin Kofler 2016-11-22 15:54:36 UTC
Description of problem:
mpg123-plugins-pulseaudio now has a:
Supplements:    pulseaudio%{?_isa}

This is bad in 2 ways:
1. It will drag in mpg123 (the main package, i.e., the command-line player), and with it mpg123-libs even if nothing else on the system uses them (in particular, if the GStreamer1 plugin is NOT installed).
2. Installing mpg123 (the main package) on an existing system without mpg123 will NOT trigger the Supplements because it is not related to mpg123 in any way.

Please use:
Supplements:    (pulseaudio%{?_isa} and mpg123%{?_isa})
on Fedora instead. (This is not supported in RHEL/EPEL, unfortunately.)

Version-Release number of selected component (if applicable):
mpg123-1.23.8-3.fc25

How reproducible:
Always

Steps to Reproduce:
1. Try to compose a F25 kickstart with updates enabled
2. Check the packages it includes.

Actual results:
Includes mpg123, mpg123-libs and mpg123-plugins-pulseaudio.

Expected results:
Does not include mpg123 and mpg123-plugins-pulseaudio. Either does not include mpg123-libs either, or includes gstreamer1-plugins-mpg123 and mpg123-libs, depending on whether gstreamer1-plugins-mpg123 gets added to comps or not.

Additional info:
https://fedoraproject.org/wiki/Packaging:Guidelines#Rich.2FBoolean_dependencies

Comment 1 Kevin Kofler 2016-12-30 00:40:30 UTC
It's been over a month now, and this keeps dragging in unwanted packages into the installation of unrelated packages, so I'm just applying this trivial fix.

Comment 2 Fedora Update System 2016-12-30 01:23:08 UTC
mpg123-1.23.8-4.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-4dd00b8c66

Comment 3 Fedora Update System 2016-12-31 09:27:28 UTC
mpg123-1.23.8-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-4dd00b8c66

Comment 4 Fedora Update System 2017-01-06 07:51:39 UTC
mpg123-1.23.8-4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.