Bug 1397555 - [RFE] The output of katello-service should be machine readable
Summary: [RFE] The output of katello-service should be machine readable
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Usability
Version: 6.2.4
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
: 1366691 (view as bug list)
Depends On:
Blocks: 260381
TreeView+ depends on / blocked
 
Reported: 2016-11-22 19:29 UTC by sthirugn@redhat.com
Modified: 2020-04-15 14:53 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 19:06:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
sample output (23.19 KB, application/octet-stream)
2016-11-22 19:29 UTC, sthirugn@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 22410 None None None 2018-01-24 13:53:53 UTC
Red Hat Bugzilla 1367795 None CLOSED katello-service status output when stopped is sub-optimal 2019-05-01 18:11:24 UTC

Internal Links: 1367795

Description sthirugn@redhat.com 2016-11-22 19:29:01 UTC
Created attachment 1222830 [details]
sample output

Description of problem:
The output of katello-service should be machine readable

Version-Release number of selected component (if applicable):
Satellite-6.2.4

How reproducible:
Always

Steps to Reproduce:
1. Run `katello-service status` in Satellite 6.2.4 - a sample output is attached to the bugzilla

Actual results:
The output of `katello-service status` is not machine readable and this prevents automation of tasks using this command.

Expected results:
The output of `katello-service status` should be machine readable and be easily used for automation process.

Additional info:

Comment 5 Ondřej Pražák 2018-01-24 13:53:49 UTC
Created redmine issue http://projects.theforeman.org/issues/22410 from this bug

Comment 6 sthirugn@redhat.com 2018-07-18 12:32:47 UTC
*** Bug 1366691 has been marked as a duplicate of this bug. ***

Comment 7 Bryan Kearney 2018-09-04 18:56:01 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Comment 8 Bryan Kearney 2018-09-04 19:06:22 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Comment 9 sthirugn@redhat.com 2019-05-01 18:12:20 UTC
You can do this now in Satellite 6.4:

# foreman-maintain service status -b
Running Status Services
================================================================================
Get status of applicable services: 
Displaying the following service(s):

rh-mongodb34-mongod, postgresql, qdrouterd, qpidd, squid, pulp_celerybeat, pulp_resource_manager, pulp_streamer, pulp_workers, smart_proxy_dynflow_core, tomcat, dynflowd, goferd, httpd, puppetserver, foreman-proxy
\ displaying rh-mongodb34-mongod                   [OK]                         
\ displaying postgresql                            [OK]                         
\ displaying qdrouterd                             [OK]                         
\ displaying qpidd                                 [OK]                         
\ displaying squid                                 [OK]                         
| displaying pulp_celerybeat                       [OK]                         
| displaying pulp_resource_manager                 [OK]                         
| displaying pulp_streamer                         [OK]                         
| displaying pulp_workers                          [OK]                         
| displaying smart_proxy_dynflow_core              [OK]                         
| displaying tomcat                                [OK]                         
| displaying dynflowd                              [OK]                         
| displaying goferd                                [OK]                         
| displaying httpd                                 [OK]                         
| displaying puppetserver                          [OK]                         
| displaying foreman-proxy                         [OK]                         
| All services are running                                            [OK]      
--------------------------------------------------------------------------------


Note You need to log in before you can comment on or make changes to this bug.