Bug 1397570 - Customising roles overwrites unrelated parameters, causing deployments to fail
Summary: Customising roles overwrites unrelated parameters, causing deployments to fail
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ga
: 10.0 (Newton)
Assignee: Julie Pichon
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-22 20:34 UTC by Julie Pichon
Modified: 2016-12-14 16:34 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-5.1.0-6.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:34:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 401359 None None None 2016-11-23 17:22:34 UTC
Launchpad 1643670 None None None 2016-11-22 20:34:03 UTC

Description Julie Pichon 2016-11-22 20:34:03 UTC
Description of problem:
Issues such as bug 1395810 means the user has to go update parameters for the different roles. This causes an extra parameter (CloudDomain) to be silently modified and saved to an empty string, causing FQDN to become unresolvable and leading every deployment to fail on galera/mariadb related errors.

Version-Release number of selected component (if applicable):
openstack-tripleo-ui-1.0.4-4.el7ost

How reproducible:
100%

Steps to Reproduce:
1. Click on the pencil for editing a role, e.g. Compute
2. Change any parameter (e.g. OvercloudComputeFlavor: compute), save the changes

Actual results:
3. The mistral environment shows another parameter was updated in addition to OvercloudComputeFlavor: 
CloudDomain:""

Expected results:
3. Only the parameters changed by the user are updated

Additional info:
This is happening because the default in the tripleo-heat-templates are not set per role, but only once in overcloud.j2.yaml where the UI cannot get at (see comments on upstream bugs for further information).

Workaround:
Make sure to manually set CloudDomain to the default indicated in the doc string - localdomain - before hitting Save.

Comment 1 Julie Pichon 2016-11-23 17:22:34 UTC
Fix landed on master, backport proposed.

Comment 2 Julie Pichon 2016-11-23 18:05:07 UTC
The fix is located in tripleo-heat-templates so, moving the bug. (The verification will likely still need to be done using the UI though.)

Comment 5 Udi 2016-12-08 09:26:26 UTC
Verified in:
openstack-tripleo-ui-1.0.5-2.el7ost.noarch
openstack-tripleo-common-5.4.0-3.el7ost.noarch
openstack-tripleo-heat-templates-5.1.0-7.el7ost.noarch

Comment 7 errata-xmlrpc 2016-12-14 16:34:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.