Bug 139762 - Fails to upgrade eth0:1
Fails to upgrade eth0:1
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 16:37 EST by Emerson House
Modified: 2014-03-16 22:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-23 17:21:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
eth0:1 script with DEVICE string fixed. (209 bytes, text/plain)
2004-11-18 19:50 EST, Emerson House
no flags Details
eth0 script unmodified (206 bytes, text/plain)
2004-11-18 19:50 EST, Emerson House
no flags Details
wlan0 script unmodified (199 bytes, text/plain)
2004-11-18 19:52 EST, Emerson House
no flags Details

  None (edit)
Description Emerson House 2004-11-17 16:37:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Upgrade of FC2 with eth0:1 configured fails after upgrade to FC3.

Eth0:1 fails to start and attempt to run system-config-network results
in a system error.

Examination of /etc/sysconfig/networking/devices/ifcfg-eth0:1 reveals
that the DEVICE string in the file is eth0:1:1.  Correcting this
string to eth0:1 results in ability to start eth0:1 and to run
system-config-network.

Version-Release number of selected component (if applicable):
system-config-network-1.3.22-1

How reproducible:
Always

Steps to Reproduce:
1.Upgrade FC2 with FC3
2.Boot system
3.
    

Actual Results:  eth0:1 interface does not start. 
System-config-network fails.

Expected Results:  eth0:1 interface starts.  System-config-network runs.

Additional info:
Comment 1 Harald Hoyer 2004-11-18 05:47:23 EST
well, the question is: how did the string eth0:1:1 come in the config
file the first place??
Comment 2 Emerson House 2004-11-18 08:44:01 EST
Gosh, I'm reporting the bug because it appears to have occured during
the upgrade process.  The problem manifested itself immediately after
the upgrade although it worked immediately before the upgrade.
Comment 3 Harald Hoyer 2004-11-18 08:57:20 EST
this is very, very strange... how did you upgrade? with anaconda,
which means, you booted from the FC3 install CD, or with yum/rpm/up2date??
Comment 4 Emerson House 2004-11-18 10:08:54 EST
Using anaconda, I booted the rescue iso, chose linux and then did a
FTP install from mirrors.kernel.org.  I have eth0:1 configured because
I am running multiple subnets on the same interface.  I assume this is
the typical reason people enable additional interfaces on the same
hardware.  But most people don't do this.  The eth0 interface worked
fine and upgraded without problem.  I thought there would be a
significant minority of users who might face the same problem.  But if
this affects only me and not other users that have multiple interfaces
configured then it is not important.
Comment 5 Harald Hoyer 2004-11-18 12:23:01 EST
maybe anaconda touched the ifcfg-eth0:1 file??
Comment 6 Bill Nottingham 2004-11-18 15:24:54 EST
Not sure why this was assigned to kudzu; it doesn't rewrite DEVICE= lines.

Can you attach your current ifcfg files? Do you have the old one/can
you reproduce this at will?
Comment 7 Emerson House 2004-11-18 19:50:11 EST
Created attachment 107019 [details]
eth0:1 script with DEVICE string fixed.
Comment 8 Emerson House 2004-11-18 19:50:48 EST
Created attachment 107020 [details]
eth0 script unmodified
Comment 9 Emerson House 2004-11-18 19:52:11 EST
Created attachment 107021 [details]
wlan0 script unmodified

I haven't tried this yet as I have to compile a prism2_usb module to get it
working.
Comment 10 Emerson House 2004-11-18 19:58:02 EST
Attached ifcfg-eth0:1, ifcfg-eth0 and ifcfg-wlan0.  Only ifcfg-eth0:1
was modified manually.  However I saved after running
system-config-network to make sure it worked and that seems to have
updated the timestamp on all files.  The problem is reproducible with
the eth0:1:1 DEVICE string.  I have not tried making a clean install
of FC2, configuring eth0:1 and then doing an upgrade to FC3.  You
might want to wait to see if anyone else encounters this first.  You
could try running system-config-network with the eth0:1:1 DEVICE
string as that produces a system error.
Comment 11 Bill Nottingham 2005-09-23 17:21:17 EDT
Apologies for the lack of response. kudzu doesn't have any code to write
ifcfg-XXX files, and certainly none that runs on upgrade.

I haven't seen any other reports of this, so I'm not sure what could be causing
it. If it still happens on a stock install, please file a new bug. In the
meantime, I'm closing this due to local unreproducibility.

Note You need to log in before you can comment on or make changes to this bug.