Bug 139767 - kernel-debuginfo is not shipped (was: kernel rpm doesn't include vmlinux)
kernel-debuginfo is not shipped (was: kernel rpm doesn't include vmlinux)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
RHN Devel
i686 Linux
high Severity high
: ---
: ---
Assigned To: rhn-dev-list
Red Hat Network Quality Assurance
= 23817
: Reopened
: 223879 (view as bug list)
Depends On: 162260
Blocks: 128294 157421
  Show dependency treegraph
 
Reported: 2004-11-17 17:12 EST by Matthew Booth
Modified: 2010-11-19 14:34 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-19 14:34:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2004-11-17 17:12:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
The kernel rpm includes vmlinuz, but not vmlinux. The latter is needed
by oprofile.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.648_EL
Comment 1 Dave Jones 2004-11-17 17:24:32 EST
its in the debuginfo package
Comment 2 Matthew Booth 2004-11-17 18:02:21 EST
I'm prepared to believe you, but kernel-debuginfo isn't available from
RHN. Is this a packaging/similar bug?
Comment 4 Rik van Riel 2005-05-09 16:22:13 EDT
This bug needs to be fixed somehow.  There are users who need oprofile to work.
Comment 18 Frank Ch. Eigler 2005-07-01 19:38:26 EDT
An element of the solution would be to *not* strip debug information from the
kernel image and .ko modules.  These unstripped binaries would have to make
their way into the main kernel RPMs.  Then, the -debuginfo parts would be only
needed for source-level debugging.
Comment 21 wdc 2005-07-08 18:42:56 EDT
Gee now that RHEL 4 update is out, and this re-packaging still has not happened,
MIT's ability to do kernel debugging and to contribute to a more reliable Red
Hat Linux is still impaired.

It would be REALLY good if someone could pick this issue up, and fix it.  The
kernel fixes you might have received since November 2004 might have been valuable.
Comment 25 John Levon 2005-09-28 08:57:03 EDT
The problem as I (OProfile maintainer) see it is simple: we only really need
the (relatively small) vmlinux; installing an RPM that approaches 1Gb in size
just to get kernel-level application profiles is a real problem (in fact, I've
run out of disk space and can't even do it myself!).

Frank's suggestion in comment 18 (assuming he meant "not strip the symbol
table") seems very reasonable to me. In fact, this is a wider issue: I'm not
sure why the symbol tables were ever stripped from system libraries and the kernel.
Comment 26 Frank Ch. Eigler 2005-09-28 18:04:47 EDT
John, oprofile users would probably also need the kernel-object symbol tables,
not just that of vmlinux.  I meant keeping more than just the symbol table,
rather up to and including all the .debug* sections, since that is what
systemtap would need.  Other tools may have less sophisticated needs. :-)
Comment 34 Red Hat Bugzilla 2007-02-05 14:06:12 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 36 Larry Troan 2007-07-15 17:02:32 EDT
This is an RHN requirement as RHN is eventualy supposed to make the debug models
available. Changing product to RHN.

Currently, debug modules are on a Red Hat ftp site.
Comment 37 Larry Troan 2007-08-30 19:11:48 EDT
Ping, this request was made on 09-03-2004.

Can we get some action here please!
Comment 38 Larry Troan 2007-10-08 13:31:29 EDT
ping -f.

This request was made on 09-03-2004.

Can we get some action here please!
Comment 39 Larry Troan 2007-10-08 13:33:14 EDT
Changing ASSIGNEE from Todd Sanders to Bret McMillan.
Comment 42 Todd Sanders 2008-06-02 12:58:38 EDT
Resetting product to RHN Hosted.  This bug deals with hosting debuginfo packages
in RHN Hosted.  Until such time, we will not be able to provide support to sync
to Satellite.  I believe this content is currently available via ftp.redhat.com.

-Todd
Comment 43 Larry Troan 2008-08-15 09:20:52 EDT
kdump requires the kernel debuginfo package to process dumps; SystemTap requires debuginfo packages. Both are fully supported in RHEL.

RHN did fix the RHN package links to the ftp.redhat.com site that were broken since RHEL5 GA (thank you) but this is still a cumbersome mechanism for customers to obtain these packages and subject to human error since updating a kernel or other package requires manual intervention to refresh any debuginfo packages currently on the system. I believe this deficiency will cause customer dissatisfaction and generate support calls. It needs to be fixed 
1) temporarily by making the debuginfo packages on the ftp site available
   as a yum repository 
and 
2) permanently by having RHN Hosted and Satellite support distribution
   and refreshing of the debuginfo packages. 

Raising severity to HIGH.
Comment 44 Larry Troan 2008-08-15 09:25:33 EDT
Comment #42 satisfied the NEEDINFO.
Comment 46 Amanda Carter 2009-03-24 17:38:08 EDT
*** Bug 223879 has been marked as a duplicate of this bug. ***
Comment 49 Larry Troan 2010-10-07 15:46:42 EDT
All debuginfo packages in RHEL5 and earlier are in the ftp.redhat.com site.

Beginning with RHEL6, all debuginfo packages will be available on RHN (no longer on ftp.redhat.com).

This information should be sufficient to close this bug as CURRENTRELEASE once RHEL6 ships.

Regardless of the release, the kernel-debuginfo packages are available and have been for several years.
Comment 50 Grant Gainey 2010-11-19 14:34:50 EST
Closing per #49

Note You need to log in before you can comment on or make changes to this bug.