Bug 1397684 - Temporarily visible on the wrong monitor
Summary: Temporarily visible on the wrong monitor
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: guake
Version: 25
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Pierre-YvesChibon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-23 07:48 UTC by robert
Modified: 2017-01-24 23:19 UTC (History)
2 users (show)

Fixed In Version: guake-0.8.8-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-24 23:19:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github Guake guake pull 844 None None None 2016-11-23 07:51:54 UTC

Description robert 2016-11-23 07:48:08 UTC
Description of problem: When you open the guake terminal, it temporarily appears on my left monitor and you can visually see it scoot its way over to the right monitor.

Version-Release number of selected component (if applicable):


How reproducible: 100% on Wayland. Can't reproduce on X.


Steps to Reproduce:
1. You need two monitors
2. Press F12 to open the guake terminal while mouse is on the right monitor
3. Slight delay while you see it appear on left then move

Actual results: Opens on left

Expected results: Opens on right (where my mouse was located)


Additional info: I've attempted to fix this issue myself, but I don't really know gtk or python for that matter, so maybe it helps maybe it doesn't. Works for me using Gnome with Wayland and X.

https://github.com/Guake/guake/pull/844

Comment 1 Fedora Update System 2016-12-26 11:21:57 UTC
guake-0.8.8-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-f082cc8c34

Comment 2 Fedora Update System 2016-12-26 11:22:04 UTC
guake-0.8.8-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-507abea4f1

Comment 3 Fedora Update System 2016-12-26 11:22:09 UTC
guake-0.8.8-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-68d5b1a125

Comment 4 Fedora Update System 2016-12-27 05:47:50 UTC
guake-0.8.8-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-f082cc8c34

Comment 5 Fedora Update System 2016-12-27 06:18:00 UTC
guake-0.8.8-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-68d5b1a125

Comment 6 Fedora Update System 2016-12-27 06:20:18 UTC
guake-0.8.8-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-507abea4f1

Comment 7 Fedora Update System 2017-01-24 23:19:42 UTC
guake-0.8.8-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.