Bug 1397691 - [scale] UI grids queries all fields while ~10% is actually needed
Summary: [scale] UI grids queries all fields while ~10% is actually needed
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Backend.Core
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high with 1 vote vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Roy Golan
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-23 08:07 UTC by Roy Golan
Modified: 2017-08-21 09:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-21 09:07:47 UTC
oVirt Team: Infra
rule-engine: ovirt-4.2+


Attachments (Terms of Use)

Description Roy Golan 2016-11-23 08:07:18 UTC
Description of problem:
All our UI grids uses under the hood 'select * from VIEW' to populate the grid items.

VMs grid has 14 columns is shows while the column count of the vms view is 161.
i.e it uses than 10% of what the view provides.

Grid name | Grid column count | table(view) column count | 

Vms tab   | 14                | 161
Hosts tab | 11                | 137
Disks     | 9                 | 58

Obviously this is a waste of resources through the entire stack. Working with just the data we need will improve dramatically the system behaviour through all the stack.

This of course is nothing specific to the UI, the dal layer is encouraging us to do get, and getAll on our view entities(vms, vds etc...) all the time for the sake of simplicity and ease of development. We must design the code in a way that it will be compeling to perform more percise queries and compeling to use partial objects to support that.

Version: all
Reproducible: 100%
Expected: Query only the columns we need instead of the whole table.
Effect: Expected to be substantial on io/cpu and overall responsiveness, will publish a comparison
Risk: Since it will require code change and to work with partial data, all code path in the UI that work with that will be affected.

Comment 7 Yaniv Kaul 2017-08-21 08:26:57 UTC
Roy - I think we've decided not to pursue this?

Comment 8 Roy Golan 2017-08-21 09:07:47 UTC
Yes, I'm closing this effort for now.


Note You need to log in before you can comment on or make changes to this bug.