This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 139784 - Installer doesn't create serial terminal entries on kernel boot line
Installer doesn't create serial terminal entries on kernel boot line
Status: CLOSED DUPLICATE of bug 137971
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-17 20:02 EST by erik nguyen
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description erik nguyen 2004-11-17 20:02:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925

Description of problem:
After network installation, the installer should create the serial
terminal entries (extracted from the pxelinux.cfg/default file) and
appending them to the kernel boot line in /boot/grub/grub.conf i.e.,
adding "console=ttyS1,9600". If this is not accomplished then the
system after reboot will hang indefinitely in a blank window of the
serial console or will not display any boot messages to the serial
console until the login prompt appear by running /sbin/agetty in
/etc/inittab.

The default entry I used:

label lr4b2
  kernel r4b2/images/pxeboot/vmlinuz
  append acpi=off ksdevice=eth0 console=ttyS1,9600n8 load_ramdisk=1
network ks=nfs:10.1.162.7:/home/pxeboot/sqa/r4b2/ks1.cfg
initrd=r4b2/images/pxeboot/initrd.img

The ks1.cfg I used:

install
langsupport en_US
lang en_US
keyboard us
mouse generic3ps/2 --device psaux
timezone --utc America/Los_Angeles
rootpw abc123
zerombr yes
bootloader --location=mbr
nfs --server 10.1.162.7 --dir /home/pxeboot/sqa/r4b2
clearpart --linux
                                                                     
       
part /boot --fstype ext3 --size 64
part  swap --size 1024
part / --fstype ext3 --size 1 --grow
                                                                     
       
network --bootproto dhcp --device eth0
auth --useshadow --enablemd5
firewall --disabled
text
skipx
reboot
                                                                     
       
%packages
@ Everything
%pre
%post



Version-Release number of selected component (if applicable):
anaconda-10.1.1.3-1

How reproducible:
Always

Steps to Reproduce:
1. proceed to do a pxe-install using provided 'default' entry and
ks1.cfg file.

2. after installation, system will reboot

3. telnet to the serial terminal: either nothing will be displayed or
no boot messages will be displayed until the login prompt appear.
    

Actual Results:  no display of serial console outputs

Expected Results:  display of serial console outputs

Additional info:

The workaround is to boot the system in rescue mode then chroot
/mnt/sysimage, then edit the /boot/grub/grub.conf file to add
"console=ttyS1,9600" to the kernel boot line.
Comment 1 Jeremy Katz 2004-11-17 22:18:42 EST

*** This bug has been marked as a duplicate of 137971 ***
Comment 2 erik nguyen 2004-11-17 23:46:34 EST
adding 'serial' to the /pxeboot.cfg/default file solved the problem !
e.g., 

label lr4b2
  kernel r4b2/images/pxeboot/vmlinuz
  append acpi=off ksdevice=eth0 serial console=ttyS1,9600n8 ...
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.