Bug 1397848 - UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf3 in position 1: invalid continuation byte
Summary: UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf3 in position 1: inval...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 24
Hardware: armhfp
OS: Linux
medium
low
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened, Triaged
: 1467412 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-23 13:10 UTC by Patrick Laimbock
Modified: 2017-07-25 16:56 UTC (History)
9 users (show)

Fixed In Version: dnf-2.5.1-1.fc26 dnf-2.6.2-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-25 16:56:38 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Patrick Laimbock 2016-11-23 13:10:31 UTC
Description of problem:
Running dnf update results in the error: UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf3 in position 1: invalid continuation byte
and updating fails.

Version-Release number of selected component (if applicable):
dnf-1.1.10-1.fc24.noarch
dnf-conf-1.1.10-1.fc24.noarch
dnf-langpacks-0.15.1-4.fc24.noarch
dnf-langpacks-conf-0.15.1-4.fc24.noarch
dnf-plugins-core-0.1.21-3.fc24.noarch
dnf-yum-1.1.10-1.fc24.noarch

How reproducible:
# dnf -y update

Steps to Reproduce:
1. # dnf -y update
2. all ok up to "Running transaction" and then
3. error: UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf3 in position 1: invalid continuation byte (full output below)

Actual results:
# dnf -y update fails with an error (full output below): UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf3 in position 1: invalid continuation byte

Expected results:
Updating succeeds

Additional info:

Full output:

Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Traceback (most recent call last):
  File "/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.5/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.5/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.5/site-packages/dnf/cli/main.py", line 120, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python3.5/site-packages/dnf/cli/main.py", line 149, in resolving
    base.do_transaction(display=displays)
  File "/usr/lib/python3.5/site-packages/dnf/cli/cli.py", line 228, in do_transaction
    super(BaseCli, self).do_transaction(display)
  File "/usr/lib/python3.5/site-packages/dnf/base.py", line 607, in do_transaction
    self._run_transaction(cb=cb)
  File "/usr/lib/python3.5/site-packages/dnf/base.py", line 650, in _run_transaction
    rpmdbv = self.sack.rpmdb_version(self._yumdb)
  File "/usr/lib/python3.5/site-packages/dnf/sack.py", line 76, in rpmdb_version
    if 'checksum_type' in ydbi and 'checksum_data' in ydbi:
  File "/usr/lib/python3.5/site-packages/dnf/yum/rpmsack.py", line 323, in __contains__
    x = self.get(attr)
  File "/usr/lib/python3.5/site-packages/dnf/yum/rpmsack.py", line 350, in get
    res = self._read(attr)
  File "/usr/lib/python3.5/site-packages/dnf/yum/rpmsack.py", line 280, in _read
    value = fo.read()
  File "/usr/lib/python3.5/codecs.py", line 321, in decode
    (result, consumed) = self._buffer_decode(data, self.errors, final)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf3 in position 1: invalid continuation byte

Comment 1 Patrick Laimbock 2016-11-23 13:16:26 UTC
This box running F24 is a Cubietruck (armv7hl)

# locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=nl_NL.UTF-8
LC_TIME=nl_NL.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=nl_NL.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=nl_NL.UTF-8
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT=nl_NL.UTF-8
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

The following commands also failed with the same error: 
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf3 in position 1: invalid continuation byte

# LC_ALL=C dnf update

# LC_ALL=C LANG=C LANGUAGE=C dnf update

# LC_ALL=C dnf --disableplugin=protected_packages update


Python versions:

abrt-addon-python3-2.8.2-1.fc24.armv7hl
abrt-python3-2.8.2-1.fc24.armv7hl
audit-libs-python3-2.6.7-1.fc24.armv7hl
dbus-python-1.2.4-1.fc24.armv7hl
langtable-python3-0.0.35-1.fc24.noarch
libreport-python3-2.7.2-1.fc24.armv7hl
libselinux-python-2.5-9.fc24.armv7hl
libselinux-python3-2.5-9.fc24.armv7hl
libsemanage-python3-2.5-5.fc24.armv7hl
newt-python3-0.52.18-5.fc24.armv7hl
policycoreutils-python3-2.5-13.fc24.armv7hl
policycoreutils-python-utils-2.5-13.fc24.armv7hl
python-2.7.12-6.fc24.armv7hl
python2-cffi-1.5.2-1.fc24.armv7hl
python2-crypto-2.6.1-10.fc24.armv7hl
python2-cryptography-1.3.1-1.fc24.armv7hl
python2-dateutil-2.5.2-2.fc24.noarch
python2-decorator-4.0.10-3.fc24.noarch
python2-dnf-1.1.10-1.fc24.noarch
python2-dns-1.15.0-1.fc24.noarch
python2-hawkey-0.6.3-6.fc24.armv7hl
python2-iniparse-0.4-19.fc24.noarch
python2-ipaclient-4.3.2-2.fc24.noarch
python2-ipalib-4.3.2-2.fc24.noarch
python2-libcomps-0.1.7-4.fc24.armv7hl
python2-libipa_hbac-1.14.2-1.fc24.armv7hl
python2-librepo-1.7.18-2.fc24.armv7hl
python2-ply-3.8-1.fc24.noarch
python2-pyasn1-0.1.9-6.fc24.1.noarch
python2-pyasn1-modules-0.1.9-6.fc24.1.noarch
python2-pygpgme-0.3-18.fc24.armv7hl
python2-setuptools-20.1.1-1.fc24.noarch
python2-sssdconfig-1.14.2-1.fc24.noarch
python2-sss-murmur-1.14.2-1.fc24.armv7hl
python3-3.5.2-3.fc24.armv7hl
python3-augeas-0.5.0-5.fc24.noarch
python3-blivet-1.20.3-1.fc24.noarch
python3-blockdev-1.6-1.fc24.armv7hl
python3-chardet-2.2.1-5.fc24.noarch
python3-coverage-4.2-1.fc24.armv7hl
python3-dbus-1.2.4-1.fc24.armv7hl
python3-decorator-4.0.10-3.fc24.noarch
python3-dmidecode-3.12.2-3.fc24.armv7hl
python3-dnf-1.1.10-1.fc24.noarch
python3-dnf-langpacks-0.15.1-4.fc24.noarch
python3-dnf-plugins-core-0.1.21-3.fc24.noarch
python3-firewall-0.4.4.1-1.fc24.noarch
python3-gobject-base-3.20.1-1.fc24.armv7hl
python3-hawkey-0.6.3-6.fc24.armv7hl
python3-iniparse-0.4-19.fc24.noarch
python3-iscsi-initiator-utils-6.2.0.873-33.git4c1f2d9.fc24.armv7hl
python3-kickstart-2.25-4.fc24.noarch
python3-libcomps-0.1.7-4.fc24.armv7hl
python3-librepo-1.7.18-2.fc24.armv7hl
python3-libs-3.5.2-3.fc24.armv7hl
python3-libxml2-2.9.3-3.fc24.armv7hl
python3-meh-0.44-1.fc24.noarch
python3-ntplib-0.3.3-3.fc24.noarch
python3-ordered-set-2.0.0-3.fc24.noarch
python3-pid-2.0.1-4.fc24.noarch
python3-pip-8.0.2-1.fc24.noarch
python3-pwquality-1.3.0-4.fc24.armv7hl
python3-pygpgme-0.3-18.fc24.armv7hl
python3-pyparted-3.10.7-3.fc24.armv7hl
python3-pysocks-1.5.6-4.fc24.noarch
python3-pytz-2016.6.1-1.fc24.noarch
python3-pyudev-0.21.0-1.fc24.noarch
python3-requests-2.10.0-2.fc24.noarch
python3-requests-file-1.4-3.fc24.noarch
python3-requests-ftp-0.3.1-3.fc24.noarch
python3-setuptools-20.1.1-1.fc24.noarch
python3-six-1.10.0-2.fc24.noarch
python3-slip-0.6.4-3.fc24.noarch
python3-slip-dbus-0.6.4-3.fc24.noarch
python3-sssdconfig-1.14.2-1.fc24.noarch
python3-systemd-232-1.fc24.armv7hl
python3-urllib3-1.15.1-3.fc24.noarch
python-cssselect-0.9.1-9.fc24.noarch
python-enum34-1.0.4-5.fc24.noarch
python-firewall-0.4.4.1-1.fc24.noarch
python-gobject-base-3.20.1-1.fc24.armv7hl
python-gssapi-1.2.0-1.fc24.armv7hl
python-idna-2.0-3.fc24.noarch
python-ipaddress-1.0.16-2.fc24.noarch
python-IPy-python3-0.81-15.fc24.noarch
python-jwcrypto-0.3.2-1.fc24.noarch
python-ldap-2.4.25-1.fc24.armv7hl
python-libs-2.7.12-6.fc24.armv7hl
python-lxml-3.4.4-4.fc24.armv7hl
python-netaddr-0.7.18-6.fc24.noarch
python-nss-1.0.0-beta1.2.fc24.1.armv7hl
python-pip-8.0.2-1.fc24.noarch
python-pycparser-2.14-6.fc24.noarch
python-qrcode-core-5.1-3.fc24.noarch
python-six-1.10.0-2.fc24.noarch
python-slip-0.6.4-3.fc24.noarch
python-slip-dbus-0.6.4-3.fc24.noarch
python-systemd-doc-232-1.fc24.armv7hl
python-talloc-2.1.6-1.fc24.armv7hl
python-yubico-1.2.3-6.fc24.noarch
rpm-python3-4.13.0-0.rc1.27.fc24.armv7hl
rpm-python-4.13.0-0.rc1.27.fc24.armv7hl
system-python-3.5.2-3.fc24.armv7hl
system-python-libs-3.5.2-3.fc24.armv7hl

Please let me know if you need additional information. Thanks.

Comment 2 tcassaert 2017-05-07 13:43:41 UTC
I'm having the exact same error right now. Last week system updates failed on rebooting my laptop. I was left with an emergency shell in which I performed a fsck on /dev/mapper/fedora-root. When I wanted to do some system updates again, in the terminal this time, I got the same errors as mentioned above. 

The only difference is that I'm running F25 instead of F24. 

Updating my system with yum-deprecated works, updating with the Software utility works as well.

Comment 3 Jaroslav Mracek 2017-05-19 09:42:49 UTC
Please are you able to reproduce it for commands like "dnf upgrade"?

Comment 4 Jaroslav Mracek 2017-05-19 09:50:10 UTC
The problem was solved by https://github.com/rpm-software-management/dnf/commit/352e391c4529d4e019148a91fc2e3e2b761b145c . The commit is part of dnf-2.4 that is available for rawhide and Fedora 26 or from our test repository (dnf copr enable rpmsoftwaremanagement/dnf-nightly). If problem reappears, please don't hesitate to reopen the bug report.

Comment 5 tcassaert 2017-05-19 10:37:13 UTC
Thanks for getting back to me.

I don't know if I've done it correct, but I've done the following:

First I enable the test repository, with:

dnf copr enable rpmsoftwaremanagement/dnf-nightly

After that was done, I tried to update my dnf. Ofcourse that was not working, as dnf itself is broken. Luckily, yum-deprecated still works. So I executed the following command:

sudo yum-deprecated update dnf

Which gives me dnf version 2.4.1

$ dnf --version                                                           
2.4.1
  Installed: dnf-0:2.5.0-0.12g54b800a.fc25.noarch at 2017-05-19 10:27
  Built    :  at 2017-05-19 01:54

  Installed: rpm-0:4.13.0.1-1.fc25.x86_64 at 2017-03-31 15:16
  Built    : Fedora Project at 2017-02-24 12:48

The next thing I did was trying to update my system once again.

$ sudo dnf upgrade

I still get the an error. Where it previously gave an output with lots of python, it now only shows:

UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf3 in position 1: invalid continuation byte

---
Any idea how I can keep tracking this down?

Comment 6 Jaroslav Mracek 2017-05-19 11:47:12 UTC
Please can you provide full output of that crashing command?

Comment 7 tcassaert 2017-05-19 12:30:30 UTC
$ sudo dnf upgrade

Last metadata expiration check: 2:01:05 ago on Fri May 19 12:27:47 2017 CEST.
Dependencies resolved.
================================================================================================
 Package            Arch    Version                    Repository                          Size
================================================================================================
Upgrading:
 createrepo_c       x86_64  0.10.0-47g5f5365e.fc25     rpmsoftwaremanagement-dnf-nightly   57 k
 createrepo_c-libs  x86_64  0.10.0-47g5f5365e.fc25     rpmsoftwaremanagement-dnf-nightly   83 k
 libsolv            x86_64  0.6.27-2gd947474.fc25      rpmsoftwaremanagement-dnf-nightly  356 k

Transaction Summary
================================================================================================
Upgrade  3 Packages

Total size: 497 k
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] createrepo_c-0.10.0-47g5f5365e.fc25.x86_64.rpm: Already downloaded                   
[SKIPPED] createrepo_c-libs-0.10.0-47g5f5365e.fc25.x86_64.rpm: Already downloaded              
[SKIPPED] libsolv-0.6.27-2gd947474.fc25.x86_64.rpm: Already downloaded                         
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf3 in position 1: invalid continuation byte

That's the full output, as requested.

Comment 8 Jaroslav Mracek 2017-05-19 15:14:56 UTC
Thanks. Please install dnf from copr repository (dnf copr enable rpmsoftwaremanagement/rpm-gitoverlay-1495199978.985077) and then:

1. sudo dnf upgrade -v # please provide output as attachment.

2. sudo dnf clean packages

3. sudo dnf upgrade -v

Thanks a lot

Comment 9 Jaroslav Mracek 2017-05-19 16:11:37 UTC
I guess that you have something incorrect in checksum_type or checksum_data file.

Probably it can be uncovered by:


cat $(find /var/lib/dnf/yumdb/ -name checksum_type)

cat $(find /var/lib/dnf/yumdb/ -name checksum_data)

Comment 10 Jaroslav Mracek 2017-05-19 16:17:32 UTC
Also installing python2-dnf and then run of command "sudo dnf-2 upgrade" can be workaround. 

Please can you provide output from 

1. "rpm -q dnf libdnf"
2. locale

Thanks a lot

Comment 11 Jaroslav Mracek 2017-05-19 17:04:01 UTC
I created a pull request that could help with your problem (https://github.com/rpm-software-management/dnf/pull/821). DNF with patch can be downloaded from copr repo (dnf copr enable rpmsoftwaremanagement/rpm-gitoverlay-1495213037.838696). Please can you try it and confirm that the patch solved your problem? Thanks a lot.

Comment 12 tcassaert 2017-05-19 17:17:39 UTC
$ sudo dnf upgrade -v

Loaded plugins: builddep, config-manager, copr, debug, debuginfo-install, download, gen[72/1848]
pletion_cache, needs-restarting, playground, repoclosure, repograph, repomanage, reposync
DNF version: 2.4.1
cachedir: /var/cache/dnf
repo: using cache for: fedora
not found updateinfo for: Fedora 25 - x86_64
fedora: using metadata from Tue Nov 15 20:49:18 2016 CET.
repo: using cache for: region51-chrome-gnome-shell
not found deltainfo for: Copr repo for chrome-gnome-shell owned by region51
not found updateinfo for: Copr repo for chrome-gnome-shell owned by region51
region51-chrome-gnome-shell: using metadata from Fri May 12 08:06:24 2017 CEST.
repo: using cache for: google-chrome
not found deltainfo for: google-chrome
not found updateinfo for: google-chrome
google-chrome: using metadata from Wed May 17 21:32:23 2017 CEST.
repo: using cache for: updates
updates: using metadata from Fri May 19 07:36:54 2017 CEST.
repo: using cache for: rpmfusion-free
not found deltainfo for: RPM Fusion for Fedora 25 - Free
not found updateinfo for: RPM Fusion for Fedora 25 - Free
rpmfusion-free: using metadata from Sat Nov 19 00:41:21 2016 CET.
Copr repo for rpm-gitoverlay-1495199978.985077 owned by rpmsoft  48 kB/s |  36 kB     00:00    
not found deltainfo for: Copr repo for rpm-gitoverlay-1495199978.985077 owned by rpmsoftwaremana
gement
not found updateinfo for: Copr repo for rpm-gitoverlay-1495199978.985077 owned by rpmsoftwareman
agement
rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077: using metadata from Fri May 19 15:56:47 
2017 CEST.
repo: using cache for: skype-stable
not found deltainfo for: skype (stable)
not found updateinfo for: skype (stable)
skype-stable: using metadata from Thu May 11 14:35:05 2017 CEST.
repo: using cache for: rpmsoftwaremanagement-dnf-nightly
not found deltainfo for: Copr repo for dnf-nightly owned by rpmsoftwaremanagement
not found updateinfo for: Copr repo for dnf-nightly owned by rpmsoftwaremanagement
rpmsoftwaremanagement-dnf-nightly: using metadata from Fri May 19 04:01:09 2017 CEST.
repo: using cache for: isv_ownCloud_desktop
not found deltainfo for: The ownCloud Desktop Client (Fedora_25)
not found updateinfo for: The ownCloud Desktop Client (Fedora_25)
isv_ownCloud_desktop: using metadata from Mon May 08 16:26:36 2017 CEST.
repo: using cache for: rpmfusion-free-updates
not found deltainfo for: RPM Fusion for Fedora 25 - Free - Updates
not found updateinfo for: RPM Fusion for Fedora 25 - Free - Updates
rpmfusion-free-updates: using metadata from Wed May 17 09:06:50 2017 CEST.
Last metadata expiration check: 0:00:00 ago on Fri May 19 19:01:25 2017 CEST.
Completion plugin: Generating completion cache...
--> Starting dependency resolution
---> Package createrepo_c.x86_64 0.10.0-6.fc25 will be upgraded
---> Package createrepo_c.x86_64 0.10.0-47g5f5365e.fc25 will be an upgrade
---> Package createrepo_c-libs.x86_64 0.10.0-6.fc25 will be upgraded
---> Package createrepo_c-libs.x86_64 0.10.0-47g5f5365e.fc25 will be an upgrade
---> Package dnf.noarch 2.5.0-0.12g54b800a.fc25 will be upgraded
---> Package dnf.noarch 2.5.0-0.14g9c2f698.fc25 will be an upgrade
---> Package python3-dnf.noarch 2.5.0-0.12g54b800a.fc25 will be upgraded
---> Package python3-dnf.noarch 2.5.0-0.14g9c2f698.fc25 will be an upgrade
---> Package dnf-conf.noarch 2.5.0-0.12g54b800a.fc25 will be upgraded
---> Package dnf-conf.noarch 2.5.0-0.14g9c2f698.fc25 will be an upgrade
---> Package dnf-yum.noarch 2.5.0-0.12g54b800a.fc25 will be upgraded
---> Package dnf-yum.noarch 2.5.0-0.14g9c2f698.fc25 will be an upgrade
---> Package less.x86_64 481-6.fc25 will be upgraded
---> Package less.x86_64 481-7.fc25 will be an upgrade
---> Package libsolv.x86_64 0.6.27-1.fc25 will be upgraded
---> Package libsolv.x86_64 0.6.27-6gac0c19a.fc25 will be an upgrade
--> Finished dependency resolution
Dependencies resolved.
================================================================================================
 Package       Arch   Version      Repository                                              Size
================================================================================================
Upgrading:
 createrepo_c  x86_64 0.10.0-47g5f5365e.fc25
                                   rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077  57 k
 createrepo_c-libs
               x86_64 0.10.0-47g5f5365e.fc25
                                   rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077  83 k
 dnf           noarch 2.5.0-0.14g9c2f698.fc25
                                   rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077 292 k
 dnf-conf      noarch 2.5.0-0.14g9c2f698.fc25
                                   rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077  27 k
 dnf-yum       noarch 2.5.0-0.14g9c2f698.fc25
                                   rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077 9.3 k
 less          x86_64 481-7.fc25   updates                                                156 k
 libsolv       x86_64 0.6.27-6gac0c19a.fc25
                                   rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077 356 k
 python3-dnf   noarch 2.5.0-0.14g9c2f698.fc25
                                   rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077 419 k

Transaction Summary
================================================================================================
Upgrade  8 Packages

Total download size: 1.4 M
Is this ok [y/N]: y
Downloading Packages:
(1/8): less-481-6.fc25_481-7.fc25.x86_64.drpm                   398 kB/s | 102 kB     00:00    
(2/8): createrepo_c-libs-0.10.0-47g5f5365e.fc25.x86_64.rpm       88 kB/s |  83 kB     00:00    
(3/8): createrepo_c-0.10.0-47g5f5365e.fc25.x86_64.rpm            56 kB/s |  57 kB     00:01    
(4/8): dnf-conf-2.5.0-0.14g9c2f698.fc25.noarch.rpm              140 kB/s |  27 kB     00:00    
(5/8): dnf-yum-2.5.0-0.14g9c2f698.fc25.noarch.rpm                42 kB/s | 9.3 kB     00:00    
(6/8): python3-dnf-2.5.0-0.14g9c2f698.fc25.noarch.rpm           661 kB/s | 419 kB     00:00    
(7/8): dnf-2.5.0-0.14g9c2f698.fc25.noarch.rpm                   213 kB/s | 292 kB     00:01    
(8/8): libsolv-0.6.27-6gac0c19a.fc25.x86_64.rpm                 609 kB/s | 356 kB     00:00    
[DRPM] less-481-6.fc25_481-7.fc25.x86_64.drpm: done                                            
------------------------------------------------------------------------------------------------
Total                                                           468 kB/s | 1.3 MB     00:02     
Delta RPMs reduced 1.4 MB of updates to 1.3 MB (3.1% saved)
warning: /var/cache/dnf/rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077-8fee0f35ac1c1dd3/
packages/createrepo_c-0.10.0-47g5f5365e.fc25.x86_64.rpm: Header V3 RSA/SHA1 Signature, key ID 2d8db463: NOKEY
Importing GPG key 0x2D8DB463:
 Userid     : "rpmsoftwaremanagement_rpm-gitoverlay-1495199978.985077 (None) <rpmsoftwaremanagem
ent#rpm-gitoverlay-1495199978.985077@copr.fedorahosted.org>"
 Fingerprint: EA83 5720 514B 347F EBB3 42DD 6F0C 0B01 2D8D B463
 From       : https://copr-be.cloud.fedoraproject.org/results/rpmsoftwaremanagement/rpm-gitoverl
ay-1495199978.985077/pubkey.gpg
Is this ok [y/N]: y
Key imported successfully
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf3 in position 1: invalid continuation byte

---
$ sudo dnf clean packages

154 files removed

---
$ sudo dnf upgrade -v

Loaded plugins: builddep, config-manager, copr, debug, debuginfo-install, download, gen[60/1964]
pletion_cache, needs-restarting, playground, repoclosure, repograph, repomanage, reposync
DNF version: 2.4.1
cachedir: /var/cache/dnf
repo: using cache for: isv_ownCloud_desktop
not found deltainfo for: The ownCloud Desktop Client (Fedora_25)
not found updateinfo for: The ownCloud Desktop Client (Fedora_25)
isv_ownCloud_desktop: using metadata from Mon May 08 16:26:36 2017 CEST.
repo: using cache for: google-chrome
not found deltainfo for: google-chrome
not found updateinfo for: google-chrome
google-chrome: using metadata from Wed May 17 21:32:23 2017 CEST.
repo: using cache for: updates
updates: using metadata from Fri May 19 07:36:54 2017 CEST.
repo: using cache for: rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077
not found deltainfo for: Copr repo for rpm-gitoverlay-1495199978.985077 owned by rpmsoftwaremana
gement
not found updateinfo for: Copr repo for rpm-gitoverlay-1495199978.985077 owned by rpmsoftwareman
agement
rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077: using metadata from Fri May 19 15:56:47 
2017 CEST.
repo: using cache for: rpmsoftwaremanagement-dnf-nightly
not found deltainfo for: Copr repo for dnf-nightly owned by rpmsoftwaremanagement
not found updateinfo for: Copr repo for dnf-nightly owned by rpmsoftwaremanagement
rpmsoftwaremanagement-dnf-nightly: using metadata from Fri May 19 04:01:09 2017 CEST.
repo: using cache for: region51-chrome-gnome-shell
not found deltainfo for: Copr repo for chrome-gnome-shell owned by region51
not found updateinfo for: Copr repo for chrome-gnome-shell owned by region51
region51-chrome-gnome-shell: using metadata from Fri May 12 08:06:24 2017 CEST.
repo: using cache for: skype-stable
not found deltainfo for: skype (stable)
not found updateinfo for: skype (stable)
skype-stable: using metadata from Thu May 11 14:35:05 2017 CEST.
repo: using cache for: rpmfusion-free
not found deltainfo for: RPM Fusion for Fedora 25 - Free
not found updateinfo for: RPM Fusion for Fedora 25 - Free
rpmfusion-free: using metadata from Sat Nov 19 00:41:21 2016 CET.
repo: using cache for: fedora
not found updateinfo for: Fedora 25 - x86_64
fedora: using metadata from Tue Nov 15 20:49:18 2016 CET.
repo: using cache for: rpmfusion-free-updates
not found deltainfo for: RPM Fusion for Fedora 25 - Free - Updates
not found updateinfo for: RPM Fusion for Fedora 25 - Free - Updates
rpmfusion-free-updates: using metadata from Wed May 17 09:06:50 2017 CEST.
Last metadata expiration check: 0:04:20 ago on Fri May 19 19:01:25 2017 CEST.
--> Starting dependency resolution
---> Package createrepo_c.x86_64 0.10.0-6.fc25 will be upgraded
---> Package createrepo_c.x86_64 0.10.0-47g5f5365e.fc25 will be an upgrade
---> Package createrepo_c-libs.x86_64 0.10.0-6.fc25 will be upgraded
---> Package createrepo_c-libs.x86_64 0.10.0-47g5f5365e.fc25 will be an upgrade
---> Package dnf.noarch 2.5.0-0.12g54b800a.fc25 will be upgraded
---> Package dnf.noarch 2.5.0-0.14g9c2f698.fc25 will be an upgrade
---> Package python3-dnf.noarch 2.5.0-0.12g54b800a.fc25 will be upgraded
---> Package python3-dnf.noarch 2.5.0-0.14g9c2f698.fc25 will be an upgrade
---> Package dnf-conf.noarch 2.5.0-0.12g54b800a.fc25 will be upgraded                   [6/1964]
---> Package dnf-conf.noarch 2.5.0-0.14g9c2f698.fc25 will be an upgrade
---> Package dnf-yum.noarch 2.5.0-0.12g54b800a.fc25 will be upgraded
---> Package dnf-yum.noarch 2.5.0-0.14g9c2f698.fc25 will be an upgrade
---> Package less.x86_64 481-6.fc25 will be upgraded
---> Package less.x86_64 481-7.fc25 will be an upgrade
---> Package libsolv.x86_64 0.6.27-1.fc25 will be upgraded
---> Package libsolv.x86_64 0.6.27-6gac0c19a.fc25 will be an upgrade
--> Finished dependency resolution
Dependencies resolved.
================================================================================================
 Package       Arch   Version      Repository                                              Size
================================================================================================
Upgrading:
 createrepo_c  x86_64 0.10.0-47g5f5365e.fc25
                                   rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077  57 k
 createrepo_c-libs
               x86_64 0.10.0-47g5f5365e.fc25
                                   rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077  83 k
 dnf           noarch 2.5.0-0.14g9c2f698.fc25
                                   rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077 292 k
 dnf-conf      noarch 2.5.0-0.14g9c2f698.fc25
                                   rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077  27 k
 dnf-yum       noarch 2.5.0-0.14g9c2f698.fc25
                                   rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077 9.3 k
 less          x86_64 481-7.fc25   updates                                                156 k
 libsolv       x86_64 0.6.27-6gac0c19a.fc25
                                   rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077 356 k
 python3-dnf   noarch 2.5.0-0.14g9c2f698.fc25
                                   rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077 419 k

Transaction Summary
================================================================================================
Upgrade  8 Packages

Total download size: 1.4 M
Is this ok [y/N]: y
Downloading Packages:
(1/8): less-481-6.fc25_481-7.fc25.x86_64.drpm                   520 kB/s | 102 kB     00:00    
(2/8): createrepo_c-0.10.0-47g5f5365e.fc25.x86_64.rpm            52 kB/s |  57 kB     00:01    
(3/8): createrepo_c-libs-0.10.0-47g5f5365e.fc25.x86_64.rpm       58 kB/s |  83 kB     00:01    
(4/8): dnf-2.5.0-0.14g9c2f698.fc25.noarch.rpm                   207 kB/s | 292 kB     00:01    
(5/8): dnf-conf-2.5.0-0.14g9c2f698.fc25.noarch.rpm              141 kB/s |  27 kB     00:00    
(6/8): dnf-yum-2.5.0-0.14g9c2f698.fc25.noarch.rpm                53 kB/s | 9.3 kB     00:00    
(7/8): python3-dnf-2.5.0-0.14g9c2f698.fc25.noarch.rpm           477 kB/s | 419 kB     00:00    
(8/8): libsolv-0.6.27-6gac0c19a.fc25.x86_64.rpm                 660 kB/s | 356 kB     00:00    
[DRPM] less-481-6.fc25_481-7.fc25.x86_64.drpm: done                                            
------------------------------------------------------------------------------------------------
Total                                                           450 kB/s | 1.3 MB     00:02     
Delta RPMs reduced 1.4 MB of updates to 1.3 MB (3.1% saved)
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf3 in position 1: invalid continuation byte

---

$ cat $(find /var/lib/dnf/yumdb/ -name checksum_type)

Gives over 200 lines with just sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256sha256

---

$ cat $(find /var/lib/dnf/yumdb/ -name checksum_data)

Gives too many lines to count with random letters and numbers. Do you need the output? 

---

$ sudo yum-deprecated install python2-dnf

This installed without errors.

---

$ sudo dnf-2 upgrade

This this the upgrades without any problem. 

---

$ rpm -q dnf libdnf
dnf-2.5.0-0.14g9c2f698.fc25.noarch
libdnf-0.9.0-0.14g73f8d0d.fc25.x86_64

---

$ locale

LANG=en_GB.UTF-8
LC_CTYPE=en_GB.UTF-8
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=

Thanks for all your time!

Comment 13 tcassaert 2017-05-19 17:27:42 UTC
(In reply to Jaroslav Mracek from comment #11)
> I created a pull request that could help with your problem
> (https://github.com/rpm-software-management/dnf/pull/821). DNF with patch
> can be downloaded from copr repo (dnf copr enable
> rpmsoftwaremanagement/rpm-gitoverlay-1495213037.838696). Please can you try
> it and confirm that the patch solved your problem? Thanks a lot.

I have enabled the copr repo you provided. After doing that, I tried:

$ sudo dnf upgrade
Copr repo for rpm-gitoverlay-1495213037.838696 owned by rpmsoft  42 kB/s |  30 kB     00:00    
Last metadata expiration check: 0:00:00 ago on Fri May 19 19:22:57 2017 CEST.
Dependencies resolved.
Nothing to do.
Complete!

---

When trying to install a package now, I'm still getting the same error:

UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf3 in position 1: invalid continuation byte

Comment 14 Jaroslav Mracek 2017-05-19 18:03:47 UTC
Please try:

sudo yum-deprecated --disablerepo=* --enablerepo=rpmsoftwaremanagement-rpm-gitoverlay-1495213037.838696 install dnf-0:2.5.0-0.13g47784cd.fc25.noarch

After installing dnf please try again "dnf upgrade -v"

Comment 15 tcassaert 2017-05-19 20:03:24 UTC
Dear sir,

$ sudo yum-deprecated --disablerepo=* --enablerepo=rpmsoftwaremanagement-rpm-gitoverlay-1495213037.838696 install dnf-0:2.5.0-0.13g47784cd.fc25.noarch
Yum command has been deprecated, use dnf instead.
See 'man dnf' and 'man yum2dnf' for more information.

Package matching dnf-2.5.0-0.13g47784cd.fc25.noarch already installed. Checking for update.
Nothing to do

---

$ sudo dnf upgrade -v
oaded plugins: builddep, config-manager, copr, debug, debuginfo-install, download, gene[10/499]
pletion_cache, needs-restarting, playground, repoclosure, repograph, repomanage, reposync
DNF version: 2.4.1
cachedir: /var/cache/dnf

repo: using cache for: isv_ownCloud_desktop
not found deltainfo for: The ownCloud Desktop Client (Fedora_25)
not found updateinfo for: The ownCloud Desktop Client (Fedora_25)
isv_ownCloud_desktop: using metadata from Mon May 08 16:26:36 2017 CEST.
repo: using cache for: rpmfusion-free-updates
not found deltainfo for: RPM Fusion for Fedora 25 - Free - Updates
not found updateinfo for: RPM Fusion for Fedora 25 - Free - Updates
rpmfusion-free-updates: using metadata from Fri May 19 16:16:01 2017 CEST.
repo: using cache for: rpmsoftwaremanagement-dnf-nightly
not found deltainfo for: Copr repo for dnf-nightly owned by rpmsoftwaremanagement
not found updateinfo for: Copr repo for dnf-nightly owned by rpmsoftwaremanagement
rpmsoftwaremanagement-dnf-nightly: using metadata from Fri May 19 04:01:09 2017 CEST.
repo: using cache for: fedora
not found updateinfo for: Fedora  25 – x86_64
fedora: using metadata from Tue Nov 15 20:49:18 2016 CET.
repo: using cache for: region51-chrome-gnome-shell
not found deltainfo for: Copr repo for chrome-gnome-shell owned by region51
not found updateinfo for: Copr repo for chrome-gnome-shell owned by region51
region51-chrome-gnome-shell: using metadata from Fri May 12 08:06:24 2017 CEST.
repo: using cache for: google-chrome
not found deltainfo for: google-chrome - x86_64
not found updateinfo for: google-chrome - x86_64
google-chrome: using metadata from Wed May 17 21:32:23 2017 CEST.
repo: using cache for: skype-stable
not found deltainfo for: Skypeforlinux - stable
not found updateinfo for: Skypeforlinux - stable
skype-stable: using metadata from Thu May 11 14:35:05 2017 CEST.
repo: using cache for: rpmsoftwaremanagement-rpm-gitoverlay-1495213037.838696
not found deltainfo for: Copr repo for rpm-gitoverlay-1495213037.838696 owned by rpmsoftwaremanagement
not found updateinfo for: Copr repo for rpm-gitoverlay-1495213037.838696 owned by rpmsoftwaremanagement
rpmsoftwaremanagement-rpm-gitoverlay-1495213037.838696: using metadata from Fri May 19 19:23:18 2017 CEST.
repo: using cache for: rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077
not found deltainfo for: Copr repo for rpm-gitoverlay-1495199978.985077 owned by rpmsoftwaremanagement
not found updateinfo for: Copr repo for rpm-gitoverlay-1495199978.985077 owned by rpmsoftwaremanagement
rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077: using metadata from Fri May 19 15:56:47 2017 CEST.
repo: using cache for: rpmfusion-free
not found deltainfo for: RPM Fusion for Fedora 25 - Free
not found updateinfo for: RPM Fusion for Fedora 25 - Free
rpmfusion-free: using metadata from Sat Nov 19 00:41:21 2016 CET.
repo: using cache for: updates
updates: using metadata from Fri May 19 07:36:54 2017 CEST.
repo: using cache for: virtualbox
not found deltainfo for: Fedora 25 - x86_64 - VirtualBox
not found updateinfo for: Fedora 25 - x86_64 - VirtualBox
virtualbox: using metadata from Fri Apr 28 22:11:13 2017 CEST.
Last metadata expiration check: 0:03:07 ago on Fri May 19 21:58:14 2017 CEST.
--> Starting dependency resolution
--> Finished dependency resolution
Dependencies resolved.
Nothing to do.
Complete!

---
When trying to install a package, still the same error. 

Sorry for how long I keep you busy.

Comment 16 Jaroslav Mracek 2017-05-19 20:30:00 UTC
I merged two pull request and hope that it will help to get full traceback (https://github.com/rpm-software-management/dnf/pull/820). The new rpms can be downloaded from copr repo rpmsoftwaremanagement/rpm-gitoverlay-1495225603.887334 . Please wait about 1 our till repo is ready.

Comment 17 Jaroslav Mracek 2017-05-19 21:26:11 UTC
I forget to explain what you should expect from patch. 

If problem solved on your system
- commands without -v will not show any problems and they will do what is expected
- commands with -v should show problem that you previously experience but they will do what is expected

If problem was not solved
- without -v you will see some error
- with -v you will see error + traceback.

Please can you provide any additional information?

Comment 18 tcassaert 2017-05-20 07:58:12 UTC
Dear sir,

I've done the following: 

$ sudo yum-deprecated --disablerepo=* --enablerepo=rpmsoftwaremanagement-rpm-gitoverlay-1495225603.887334 upgrade dnf

This worked, so dnf has been upgraded.

---

Then I did

$ sudo dnf upgrade

And this also worked!

--- 
Finally I installed a package to see if it worked

$ sudo dnf install -v httpie

Loaded plugins: builddep, config-manager, copr, debug, debuginfo-install, download, generate_com
pletion_cache, needs-restarting, playground, repoclosure, repograph, repomanage, reposync
DNF version: 2.4.1
cachedir: /var/cache/dnf
repo: using cache for: rpmsoftwaremanagement-rpm-gitoverlay-1495213037.838696
not found deltainfo for: Copr repo for rpm-gitoverlay-1495213037.838696 owned by rpmsoftwaremana
gement
not found updateinfo for: Copr repo for rpm-gitoverlay-1495213037.838696 owned by rpmsoftwareman
agement
rpmsoftwaremanagement-rpm-gitoverlay-1495213037.838696: using metadata from Fri May 19 19:23:18 
2017 CEST.
repo: using cache for: rpmfusion-free-updates
not found deltainfo for: RPM Fusion for Fedora 25 - Free - Updates
not found updateinfo for: RPM Fusion for Fedora 25 - Free - Updates
rpmfusion-free-updates: using metadata from Fri May 19 16:16:01 2017 CEST.
repo: using cache for: fedora
not found updateinfo for: Fedora  25 – x86_64
fedora: using metadata from Tue Nov 15 20:49:18 2016 CET.
repo: using cache for: rpmsoftwaremanagement-dnf-nightly
not found deltainfo for: Copr repo for dnf-nightly owned by rpmsoftwaremanagement
not found updateinfo for: Copr repo for dnf-nightly owned by rpmsoftwaremanagement
rpmsoftwaremanagement-dnf-nightly: using metadata from Fri May 19 04:01:09 2017 CEST.
repo: using cache for: google-chrome
not found deltainfo for: google-chrome - x86_64
not found updateinfo for: google-chrome - x86_64
google-chrome: using metadata from Wed May 17 21:32:23 2017 CEST.
repo: using cache for: region51-chrome-gnome-shell
not found deltainfo for: Copr repo for chrome-gnome-shell owned by region51
not found updateinfo for: Copr repo for chrome-gnome-shell owned by region51
region51-chrome-gnome-shell: using metadata from Fri May 12 08:06:24 2017 CEST.
repo: using cache for: virtualbox
not found deltainfo for: Fedora 25 - x86_64 - VirtualBox
not found updateinfo for: Fedora 25 - x86_64 - VirtualBox
virtualbox: using metadata from Fri Apr 28 22:11:13 2017 CEST.
repo: using cache for: rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077
not found deltainfo for: Copr repo for rpm-gitoverlay-1495199978.985077 owned by rpmsoftwaremana
gement
not found updateinfo for: Copr repo for rpm-gitoverlay-1495199978.985077 owned by rpmsoftwareman
agement
rpmsoftwaremanagement-rpm-gitoverlay-1495199978.985077: using metadata from Fri May 19 15:56:47 
2017 CEST.
repo: using cache for: isv_ownCloud_desktop
not found deltainfo for: The ownCloud Desktop Client (Fedora_25)
not found updateinfo for: The ownCloud Desktop Client (Fedora_25)
isv_ownCloud_desktop: using metadata from Mon May 08 16:26:36 2017 CEST.
repo: using cache for: updates
updates: using metadata from Fri May 19 23:40:31 2017 CEST.
repo: using cache for: rpmsoftwaremanagement-rpm-gitoverlay-1495225603.887334
not found deltainfo for: Copr repo for rpm-gitoverlay-1495225603.887334 owned by rpmsoftwaremana
gement
not found updateinfo for: Copr repo for rpm-gitoverlay-1495225603.887334 owned by rpmsoftwareman
agement
rpmsoftwaremanagement-rpm-gitoverlay-1495225603.887334: using metadata from Fri May 19 23:05:46
2017 CEST.
repo: using cache for: skype-stable
not found deltainfo for: Skypeforlinux - stable
not found updateinfo for: Skypeforlinux - stable
skype-stable: using metadata from Thu May 11 14:35:05 2017 CEST.
repo: using cache for: rpmfusion-free
not found deltainfo for: RPM Fusion for Fedora 25 - Free
not found updateinfo for: RPM Fusion for Fedora 25 - Free
rpmfusion-free: using metadata from Sat Nov 19 00:41:21 2016 CET.
Last metadata expiration check: 0:07:06 ago on Sat May 20 09:46:26 2017 CEST.
--> Starting dependency resolution
---> Package httpie.noarch 0.9.4-8.fc25 will be installed
---> Package python3-pygments.noarch 2.2.0-7.fc25 will be installed
--> Finished dependency resolution
Dependencies resolved.
================================================================================================
 Package                     Arch              Version                 Repository          Size
================================================================================================
Installing:
 httpie                      noarch            0.9.4-8.fc25            updates            111 k
Installing dependencies:
 python3-pygments            noarch            2.2.0-7.fc25            updates            1.9 M

Transaction Summary
================================================================================================
Install  2 Packages

Total download size: 2.0 M
Installed size: 10 M
Is this ok [y/N]: y
Downloading Packages:
(1/2): httpie-0.9.4-8.fc25.noarch.rpm                           219 kB/s | 111 kB     00:00    
(2/2): python3-pygments-2.2.0-7.fc25.noarch.rpm                 900 kB/s | 1.9 MB     00:02    
------------------------------------------------------------------------------------------------
Total                                                           617 kB/s | 2.0 MB     00:03     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
For <dnf.yum.rpmsack.RPMDBAdditionalDataPackage object at 0x7f75d49de630> cannot open attribute 
checksum_data due to UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf3 in position 1: inv
alid continuation byte
For <dnf.yum.rpmsack.RPMDBAdditionalDataPackage object at 0x7f75d49de6d8> cannot open attribute 
checksum_data due to IsADirectoryError: [Errno 21] Is a directory: '/var/lib/dnf/yumdb/o/7645830
0d9712217ddd62fa83229af1e556a065c-orc-0.4.26-1.fc25-x86_64/checksum_data'
  Preparing        :                                                                        1/1 
  Installing       : python3-pygments-2.2.0-7.fc25.noarch                                   1/2 
  Installing       : httpie-0.9.4-8.fc25.noarch                                             2/2 
  Running scriptlet: httpie-0.9.4-8.fc25.noarch                                             2/2 
  Verifying        : httpie-0.9.4-8.fc25.noarch                                             1/2 
  Verifying        : python3-pygments-2.2.0-7.fc25.noarch                                   2/2 
For <dnf.yum.rpmsack.RPMDBAdditionalDataPackage object at 0x7f75c9b2b128> cannot open attribute
checksum_data due to UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf3 in position 1: inv
alid continuation byte
For <dnf.yum.rpmsack.RPMDBAdditionalDataPackage object at 0x7f75c9b2b1d0> cannot open attribute 
checksum_data due to IsADirectoryError: [Errno 21] Is a directory: '/var/lib/dnf/yumdb/o/7645830
0d9712217ddd62fa83229af1e556a065c-orc-0.4.26-1.fc25-x86_64/checksum_data'
Completion plugin: Generating completion cache...

Installed:
  httpie.noarch 0.9.4-8.fc25                python3-pygments.noarch 2.2.0-7.fc25               

Complete!

---
So as you expected, the installation succeeded, but the error show when using the verbose option. 

Thank you very much for your time! First time I used this bugzilla system, but it was a very good experience. 

Is there anything else I need to do or provide?

Comment 19 Jaroslav Mracek 2017-05-20 11:01:02 UTC
I created updated version of the patch. Please can you try it and report if it also helps. It is in copr repository rpmsoftwaremanagement/rpm-gitoverlay-1495275289.593708 .

When we finish with testing you can remove problematic part:

It reports that /dnf/yumdb/o/76458300d9712217ddd62fa83229af1e556a065c-orc-0.4.26-1.fc25-x86_64/checksum_data is a directory. If it is true, deletion of that directory should help.

Comment 20 tcassaert 2017-05-21 13:39:08 UTC
Dear Sir,

I don't know if I'm doing it wrong, but the provided repository could not be found.

$ sudo yum-deprecated --disablerepo=* --enablerepo=rpmsoftwaremanagement/rpm-gitoverlay-1495275289.593708 upgrade dnf
Yum command has been deprecated, use dnf instead.
See 'man dnf' and 'man yum2dnf' for more information.



Error getting repository data for rpmsoftwaremanagement/rpm-gitoverlay-1495275289.593708, repository not found

---
$ sudo dnf --disablerepo=* --enablerepo=rpmsoftwaremanagement/rpm-gitoverlay-1495275289.593708 upgrade dnf                                  
Error: Unknown repo: 'rpmsoftwaremanagement/rpm-gitoverlay-1495275289.593708'

Comment 21 Jaroslav Mracek 2017-05-21 16:11:09 UTC
I am sorry, repo has to be enabled first (dnf copr enable rpmsoftwaremanagement/rpm-gitoverlay-1495275289.593708).

Comment 22 Jaroslav Mracek 2017-05-21 17:47:29 UTC
Command "dnf copr enable" creates new .repo file in /etc/yum.repos.d/ (this is dir where all repos definition is stored)
To remove copr repos you can remove corresponding .repo files to copr repository.

Comment 23 tcassaert 2017-05-21 19:42:09 UTC
Yes, I did that, but it didn't work. However, now I just did 

$ sudo dnf upgrade dnf
Last metadata expiration check: 0:00:00 ago on Sun May 21 21:31:35 2017 CEST.
Dependencies resolved.
==========================================================================================================
 Package     Arch   Version                  Repository                                              Size
==========================================================================================================
Upgrading:
 dnf         noarch 2.5.0-0.16g22caa83.fc25  rpmsoftwaremanagement-rpm-gitoverlay-1495275289.593708 292 k
 dnf-conf    noarch 2.5.0-0.16g22caa83.fc25  rpmsoftwaremanagement-rpm-gitoverlay-1495275289.593708  27 k
 dnf-yum     noarch 2.5.0-0.16g22caa83.fc25  rpmsoftwaremanagement-rpm-gitoverlay-1495275289.593708 9.3 k
 python2-dnf noarch 2.5.0-0.16g22caa83.fc25  rpmsoftwaremanagement-rpm-gitoverlay-1495275289.593708 413 k
 python3-dnf noarch 2.5.0-0.16g22caa83.fc25  rpmsoftwaremanagement-rpm-gitoverlay-1495275289.593708 419 k


And that did work. The output shows the updates come from the most recent added repo. 

---

After this upgrade, I executed a normal 

$ sudo dnf upgrade

Which worked as expected. So I guess the problem is solved. 

You said in comment 19 the following:

It reports that /dnf/yumdb/o/76458300d9712217ddd62fa83229af1e556a065c-orc-0.4.26-1.fc25-x86_64/checksum_data is a directory. If it is true, deletion of that directory should help.

---

$ ls /var/lib/dnf/yumdb/o/76458300d9712217ddd62fa83229af1e556a065c-orc-0.4.26-1.fc25-x86_64
checksum_data  checksum_type  from_repo  installed_by  reason  releasever

---
So it's indeed a directory. I can remove this one?

Comment 24 Jaroslav Mracek 2017-05-23 10:02:22 UTC
With patch it will inform you about problem in verbose mode and after upgrade the problem for particular package should be solved automatically, because the corresponding data should be removed from yumdb. Probably it will be better to keep it like it is and let it solve automatically during time and upgrades.

Comment 25 Fedora Update System 2017-06-12 15:30:06 UTC
dnf-plugins-core-2.1.1-1.fc26 libdnf-0.9.1-1.fc26 dnf-2.5.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c87c47dccb

Comment 26 Fedora Update System 2017-06-14 01:35:50 UTC
dnf-2.5.1-1.fc26, dnf-plugins-core-2.1.1-1.fc26, libdnf-0.9.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c87c47dccb

Comment 27 Fedora Update System 2017-06-14 05:34:02 UTC
dnf-2.5.1-1.fc26 dnf-plugins-core-2.1.1-1.fc26 dnfdaemon-0.3.18-3.fc26 libdnf-0.9.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c87c47dccb

Comment 28 Fedora Update System 2017-06-15 13:56:00 UTC
dnf-2.5.1-1.fc26, dnf-plugins-core-2.1.1-1.fc26, dnfdaemon-0.3.18-3.fc26, libdnf-0.9.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c87c47dccb

Comment 29 Fedora Update System 2017-06-16 13:18:49 UTC
dnf-2.5.1-1.fc26, dnf-plugins-core-2.1.1-1.fc26, dnfdaemon-0.3.18-3.fc26, libdnf-0.9.1-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 30 umagical 2017-06-27 09:27:09 UTC
After upgrading to F26beta I also got this bug. I found that  when upgrading a package runs into this problem it is still possible to first download the rpm package directly from the repository and then do a local install:
   dnf install ./<package.rpm>

I also found another *emergency* workaround:  In file
/usr/lib/python3.6/site-packages/dnf/rpm/miscutils.py
change line 50 from
 siginfo = hdr.sprintf(string)
into for example
 siginfo = ' ' # hdr.sprintf(string)

This worked for me but possibly disrupts the keychecks, be careful.

Maybe the problem is not in dnf but in the packages: the string variable above contains some invalid token it seems.

Comment 31 Jaroslav Mracek 2017-06-27 20:12:13 UTC
It looks like as a problem of the package header. Or there could be a another problem, like that your system is somehow damaged, therefore it behaves differently. Please can you prove that the issue can be reproduce on another machine or can you provide steps to reproduce? Like dnf, libdnf, librepo, libsolv versions, attach package that was failing, and exact steps how you get into trouble, tracebacks ... I can help :-) .

Comment 32 umagical 2017-06-28 09:35:28 UTC
I have the same problem on different computers, but I run fc26beta on all of them. When I take away the emergency fix above I get for example:

[root@abele tmp]# dnf clean all
74 files removed                                                                                           
[root@abele tmp]# dnf list dnf                                                                             
Adobe Systems Incorporated                                                 4.4 kB/s | 1.9 kB     00:00     
Fedora 26 - x86_64 - Test Updates                                          2.5 MB/s |  25 MB     00:09     
Fedora 26 - x86_64 - Updates                                               4.3 kB/s | 257  B     00:00     
Fedora 26 - x86_64                                                         2.6 MB/s |  53 MB     00:20     
google-chrome                                                               52 kB/s | 3.7 kB     00:00     
RPM Fusion for Fedora 26 - Free - Test Updates                              54 kB/s | 5.6 kB     00:00     
RPM Fusion for Fedora 26 - Free                                            770 kB/s | 520 kB     00:00     
RPM Fusion for Fedora 26 - Nonfree - Test Updates                           20 kB/s | 2.2 kB     00:00     
RPM Fusion for Fedora 26 - Nonfree                                         360 kB/s | 158 kB     00:00     
Last metadata expiration check: 0:00:00 ago on ons 28 jun 2017 11:33:06.
Installed Packages
dnf.noarch                                  2.5.1-1.fc26                                   @updates-testing
[root@abele tmp]# dnf list gtkmm30   
Last metadata expiration check: 0:00:09 ago on ons 28 jun 2017 11:33:06.
Installed Packages
gtkmm30.x86_64                                3.22.0-2.fc26                                 @@commandline  
Available Packages
gtkmm30.i686                                  3.22.1-1.fc26                                 updates-testing
gtkmm30.x86_64                                3.22.1-1.fc26                                 updates-testing
[root@abele tmp]# dnf upgrade gtkmm30
Last metadata expiration check: 0:00:15 ago on ons 28 jun 2017 11:33:06.
Dependencies resolved.
===========================================================================================================
 Package              Arch                Version                       Repository                    Size
===========================================================================================================
Upgrading:
 gtkmm30              x86_64              3.22.1-1.fc26                 updates-testing              916 k

Transaction Summary
===========================================================================================================
Upgrade  1 Package

Total download size: 916 k
Is this ok [y/N]: y
Downloading Packages:
gtkmm30-3.22.0-2.fc26_3.22.1-1.fc26.x86_64.drpm                            764 kB/s | 118 kB     00:00    
[DRPM] gtkmm30-3.22.0-2.fc26_3.22.1-1.fc26.x86_64.drpm: done                                              
-----------------------------------------------------------------------------------------------------------
Total                                                                       48 kB/s | 118 kB     00:02     
Delta RPMs reduced 0.9 MB of updates to 0.1 MB (87.1% saved)
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Traceback (most recent call last):
  File "/bin/dnf", line 58, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 179, in user_main
    errcode = main(args)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args, cli_class, option_parser_class)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 99, in _main
    return cli_run(cli, base)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 123, in cli_run
    ret = resolving(cli, base)
  File "/usr/lib/python3.6/site-packages/dnf/cli/main.py", line 154, in resolving
    base.do_transaction(display=displays)
  File "/usr/lib/python3.6/site-packages/dnf/cli/cli.py", line 227, in do_transaction
    self.gpgsigcheck(install_pkgs)
  File "/usr/lib/python3.6/site-packages/dnf/cli/cli.py", line 253, in gpgsigcheck
    result, errmsg = self._sig_check_pkg(po)
  File "/usr/lib/python3.6/site-packages/dnf/base.py", line 1114, in _sig_check_pkg
    sigresult = dnf.rpm.miscutils.checkSig(ts, po.localPkg())
  File "/usr/lib/python3.6/site-packages/dnf/rpm/miscutils.py", line 50, in checkSig
    siginfo = hdr.sprintf(string)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xf6 in position 13: invalid start byte

Comment 33 Jaroslav Rohel 2017-06-28 21:27:38 UTC
What is your locale?
1. Please send output of "locale" command.

2. Try "LANG=C dnf upgrade gtkmm30"

Comment 34 umagical 2017-06-29 08:03:05 UTC
[root@abele ljh]# locale
LANG=en_US.iso-8859-15
LC_CTYPE="en_US.iso-8859-15"
LC_NUMERIC=sv_SE.ISO-8859-15
LC_TIME=sv_SE.ISO-8859-15
LC_COLLATE="en_US.iso-8859-15"
LC_MONETARY="en_US.iso-8859-15"
LC_MESSAGES="en_US.iso-8859-15"
LC_PAPER="en_US.iso-8859-15"
LC_NAME="en_US.iso-8859-15"
LC_ADDRESS="en_US.iso-8859-15"
LC_TELEPHONE="en_US.iso-8859-15"
LC_MEASUREMENT=sv_SE.ISO-8859-15
LC_IDENTIFICATION="en_US.iso-8859-15"
LC_ALL=
[root@abele ljh]# 

I also tried  ( LANG=C ;  dnf upgrade gtkmm30 )  which produces exactly  the same error as before.

Comment 35 Jaroslav Rohel 2017-06-29 09:19:32 UTC
There is PR: https://github.com/rpm-software-management/dnf/pull/853

Problem is in time encoding.
If you try "LC_TIME=C dnf upgrade gtkmm30" it will work.

BTW:
Why You use combination of en_US, sv_SE and iso-8859-15? Why you do not use UTF-8 encoding?
Try use en_US.UTF-8 and sv_SE.UTF-8. I think that it will be working without my patch.

Comment 36 umagical 2017-06-29 19:45:10 UTC
Thanks, your patch works. I want to use iso-8859-15 because it is a simple and small encoding that extends ascii with swedish and other european letters. However I don't want (like) the english paperformats (printers in Europe use A4). American time and date formats also are extremely confusing from a european perspective. That is the reason for the mixed settings.
Thanks again for solving the problem.

Comment 37 Jaroslav Rohel 2017-07-11 06:13:42 UTC
*** Bug 1467412 has been marked as a duplicate of this bug. ***

Comment 38 Fedora Update System 2017-07-24 14:52:48 UTC
libdnf-0.9.3-1.fc26 dnf-plugins-core-2.1.3-1.fc26 dnf-2.6.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6f4c06b2d7

Comment 39 Fedora Update System 2017-07-25 04:27:36 UTC
dnf-2.6.2-1.fc26, dnf-plugins-core-2.1.3-1.fc26, libdnf-0.9.3-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6f4c06b2d7

Comment 40 Fedora Update System 2017-07-25 16:56:38 UTC
dnf-2.6.2-1.fc26, dnf-plugins-core-2.1.3-1.fc26, libdnf-0.9.3-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.