Bug 1397864 - Embedded Intel Graphics not working on kernels newer than 4.8.4 - Nonexistent display is detected and used as primary display
Summary: Embedded Intel Graphics not working on kernels newer than 4.8.4 - Nonexistent...
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-23 13:29 UTC by Charles Dennett
Modified: 2019-01-09 12:54 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-12 10:24:58 UTC


Attachments (Terms of Use)

Description Charles Dennett 2016-11-23 13:29:59 UTC
Description of problem: Running on kernel 4.8.4 and all is ok.  Updated to 4.8.7 kernel and desktop (KDE in this case) no longer appears.   All I get is a blank screen.  Details below.  Kernel rev 4.8.8 has same problem


Version-Release number of selected component (if applicable): 4.8.7 and 4.8.8


How reproducible: Happens every time


Steps to Reproduce:
1. Update to something newer than kernel 4.8.4
2. Reboot
3. Attempt to bring up desktop

Actual results: For KDE desktop, blank screen. No Panel, no icons.  Konsole window which starts upon desktop start is off screen.


Expected results: Complete desktop including panel, icons and initial konsole window.


Additional info:

System is a relatively new server with Intel Skylake i5-6400 with embedded graphics (no separate video card).  I was running kernel 4.8.4 and all was fine.  After updating to a the newer 4.8.7, I ran into issues upon starting the desktop.  An even newer 4.8.8 exhibits the exact same behavior.

Upon rebooting after the update, I got the sddm login screen as
usual.  I entered my name and password as usual.  The KDE starting
splash screen appeared as usual.

After that is when the unusual happened.  I got a blank screen.  No
panels (I have one along the bottom), no icons, no initial konsole
window.  Using Alt-Tab showed the konsole window but I could not bring
it to the current screen.  The mouse was active.  I noticed a faint
white line at the left edge.  Clicking on it with my mouse and dragging
it to the right expanded what was my konsole window.  Apparently it was
off screen to the left.

Reboot to the older 4.8.4 kernel and all was well again.

I've tried the following without success:

 - Created new user with new and empty home directory to see if it might be anything in my home directly.  Logged on as that user.  Same issues.
- Removed the xorg-x11-drv-intel package so that X would use the modeset drivers (as suggested by someone on the fedora-kde list).  Same issues.

I examined the changelog for the newest kernel and found this which might be related:

--------------------------------------------------------------------------------
* Thu Oct 27 2016 Justin M. Forbes <jforbes@fedoraproject.org>
- CVE-2016-9083 CVE-2016-9084 vfio multiple flaws (rhbz 1389258 1389259 1389285)
- Skylake i915 fixes from 4.9
- Fix MS input devices identified as joysticks (rhbz 1325354)

* Mon Oct 24 2016 Justin M. Forbes <jforbes@fedoraproject.org> - 4.8.4-200
- Linux v4.8.4 rebase
--------------------------------------------------------------------------------

Recall that all was well on kernel 4.8.4 and older.

The system uses the i915 drivers:

# lsmod | grep i915
i915                 1302528  21
i2c_algo_bit           16384  1 i915
drm_kms_helper        151552  1 i915
drm                   344064  11 i915,drm_kms_helper
video                  40960  2 asus_wmi,i915

All other packages for Fedora 24 are up to date as of 3 days ago.  Here is a lis tof the repositories used:

# dnf repolist
Last metadata expiration check: 0:19:03 ago on Wed Nov 23 08:08:17 2016.
repo id                              repo name                                                status
*fedora                              Fedora 24 - x86_64                                       49,722
google-chrome                        google-chrome                                                 3
google-musicmanager                  google-musicmanager                                           1
rpmfusion-free                       RPM Fusion for Fedora 24 - Free                             352
rpmfusion-free-updates               RPM Fusion for Fedora 24 - Free - Updates                   362
rpmfusion-nonfree                    RPM Fusion for Fedora 24 - Nonfree                           89
rpmfusion-nonfree-updates            RPM Fusion for Fedora 24 - Nonfree - Updates                148
*updates                             Fedora 24 - x86_64 - Updates                             12,635

Additional info and log files will be supplied upon request.

Comment 1 Charles Dennett 2016-12-02 17:00:04 UTC
Apparently, kernels newer than 4.8.4 think my system has 2 monitors attached to it.  It only has one.  It has never had two.  I'm using the embedded graphics for my one and only monitor. I have never added a second video card.  When I run the KDE system settings app and use the display applet, it sees my main monitor and second monitor it describes as a laptop monitor.  This system is not a laptop.  It is a desk-side system.  Only kernels newer than 4.8.4 (ie, 4.8.8.and 4.8.10) show this.  The 4.8.4 kernel correctly determines I only have one monitor.

Comment 2 Charles Dennett 2016-12-06 22:47:08 UTC
Found a workaround.  When up brought up system settings (/usr/bin/systemsettings5) and went to the display applet, it showed the 2 montitors.  I noticed the real monitor was labeled DP-1.  The fake laptop screen was labeled eDP-1.  I had been googling around for how to disable monitors at boot time and had come across the kernel parameter "video=DISPLAYNAME:d.  I had been trying video=LVDS-1:d since everything I had found mentioned that as the laptop display.  This time I tried adding "video=eDP-1:d" to the line for the kernel and it worked.  I have since added it to the line in /boot/grub/grub.cfg.

So, I've got a workaround but I think this is still a bug worth investigating since it only appeared on kernels newer than 4.8.4

I'll be glad to supply any other information if asked.

Comment 3 Christopher 2016-12-07 04:46:48 UTC
See Bug #1402066

I'm seeing similar behavior with my F23 XFCE installation on my Thinkpad W541 system that began with the 4.8.8-100 kernel update.

Comment 4 Charles Dennett 2017-01-15 12:44:34 UTC
Just updated kernel to 4.9.3-200.  First of the 4.9 series that's been available from the Fedora repository.  The problem persists.  I even started up the KDE system settings application and looked at the monitor and display section.  It still see two displays.  One is my actual Asus monitor and the other is labeled as Laptop Screen eDP-1.  This might be the first time I've seen it actually labeled as a Laptop Screen.  Recall this system is not a laptop.

Comment 5 Justin M. Forbes 2017-04-11 14:40:49 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 24 kernel bugs.

Fedora 25 has now been rebased to 4.10.9-100.fc24.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.

If you experience different issues, please open a new bug report for those.

Comment 6 Charles Dennett 2017-04-12 21:25:54 UTC
I had upgraded to Fedora 25 around the first of the year and the problem persisted.   Forgot to update this report to reflect that.  Anyway, I just updated to 4.10.8-200.fc25.x86_64, the latest kernel available in the standard repository.  The problem persists.  I remove the video=eDP-1:d from the kernel line at boot.  It still thinks it has two displays - a Laptop screen labeled eDP-1 and my normal monitor screen labeled DP-1.  Recall this is a desktop system with just one monitor.

I'll update this bug to reflect Fedora 25.

Comment 7 Charles Dennett 2017-04-17 20:54:41 UTC
Updated to kernel 4.10.9-200.fc25.x86_64.  The problem still exists.

Comment 8 Charles Dennett 2017-04-23 19:03:40 UTC
Updated to kernel 4.10.10-200.fc25.x86_64.  The problem still exists.

Comment 9 Charles Dennett 2017-06-24 13:10:49 UTC
This may be fixed. I just updated the kernel from 4.10.14-200 where the issue still existed to 4.11.6-201. I temporarily removed the "video=eDP-1:d" from the kernel command line at reboot. I verified the parameter was not present by noting the command line in /var/log/messages after reboot. The phantom display is no longer present. I was a bit behind in kernel updates. There were several releases between what I was running and what I updated to, so I can't tell which particular release fixed it. I looked at the changelog embedded in the kernel rpm file but did not see anything obvious. 

Since no updates have been made to this report, was this perhaps a side effect to fixing a different bug?  If so, which one?  When I updated the kernel, I did not update any other package.  I only updated the kernel package.

Comment 10 Fedora End Of Life 2017-11-16 19:45:08 UTC
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 11 Fedora End Of Life 2017-12-12 10:24:58 UTC
Fedora 25 changed to end-of-life (EOL) status on 2017-12-12. Fedora 25 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.