Bug 1397939 - [abrt] libreoffice-core: (anonymous namespace)::signalHandlerFunction(int)(): soffice.bin killed by SIGABRT
Summary: [abrt] libreoffice-core: (anonymous namespace)::signalHandlerFunction(int)():...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:df2ebbf39ce72266819e1b4877f...
: 1418113 1454494 1454500 1456000 1489388 1490101 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-23 15:46 UTC by Gwendal
Modified: 2017-10-31 10:29 UTC (History)
16 users (show)

Fixed In Version: libreoffice-5.2.4.1-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-23 10:18:34 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (69.68 KB, text/plain)
2016-11-23 15:46 UTC, Gwendal
no flags Details
File: cgroup (259 bytes, text/plain)
2016-11-23 15:46 UTC, Gwendal
no flags Details
File: core_backtrace (10.09 KB, text/plain)
2016-11-23 15:46 UTC, Gwendal
no flags Details
File: dso_list (31.25 KB, text/plain)
2016-11-23 15:46 UTC, Gwendal
no flags Details
File: environ (1.43 KB, text/plain)
2016-11-23 15:46 UTC, Gwendal
no flags Details
File: limits (1.29 KB, text/plain)
2016-11-23 15:46 UTC, Gwendal
no flags Details
File: maps (142.53 KB, text/plain)
2016-11-23 15:46 UTC, Gwendal
no flags Details
File: mountinfo (3.58 KB, text/plain)
2016-11-23 15:46 UTC, Gwendal
no flags Details
File: namespaces (102 bytes, text/plain)
2016-11-23 15:46 UTC, Gwendal
no flags Details
File: open_fds (3.76 KB, text/plain)
2016-11-23 15:46 UTC, Gwendal
no flags Details
File: proc_pid_status (1.12 KB, text/plain)
2016-11-23 15:46 UTC, Gwendal
no flags Details
File: var_log_messages (344 bytes, text/plain)
2016-11-23 15:46 UTC, Gwendal
no flags Details

Description Gwendal 2016-11-23 15:46:19 UTC
Description of problem:
I was using the "Styles and formatting" window I think...

Version-Release number of selected component:
libreoffice-core-5.2.3.3-6.fc25

Additional info:
reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer file:///home/ebousse/git/modelengineering2016/spec/lab4/lab4.odt --splash-pipe=5
crash_function: (anonymous namespace)::signalHandlerFunction(int)
executable:     /usr/lib64/libreoffice/program/soffice.bin
global_pid:     30927
kernel:         4.8.7-300.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (1 frames)
 #2 (anonymous namespace)::signalHandlerFunction(int) at /usr/src/debug/libreoffice-5.2.3.3/sal/osl/unx/signal.cxx:434

Comment 1 Gwendal 2016-11-23 15:46:22 UTC
Created attachment 1223302 [details]
File: backtrace

Comment 2 Gwendal 2016-11-23 15:46:24 UTC
Created attachment 1223303 [details]
File: cgroup

Comment 3 Gwendal 2016-11-23 15:46:25 UTC
Created attachment 1223304 [details]
File: core_backtrace

Comment 4 Gwendal 2016-11-23 15:46:27 UTC
Created attachment 1223305 [details]
File: dso_list

Comment 5 Gwendal 2016-11-23 15:46:29 UTC
Created attachment 1223306 [details]
File: environ

Comment 6 Gwendal 2016-11-23 15:46:30 UTC
Created attachment 1223307 [details]
File: limits

Comment 7 Gwendal 2016-11-23 15:46:33 UTC
Created attachment 1223308 [details]
File: maps

Comment 8 Gwendal 2016-11-23 15:46:35 UTC
Created attachment 1223309 [details]
File: mountinfo

Comment 9 Gwendal 2016-11-23 15:46:36 UTC
Created attachment 1223310 [details]
File: namespaces

Comment 10 Gwendal 2016-11-23 15:46:38 UTC
Created attachment 1223311 [details]
File: open_fds

Comment 11 Gwendal 2016-11-23 15:46:39 UTC
Created attachment 1223312 [details]
File: proc_pid_status

Comment 12 Gwendal 2016-11-23 15:46:41 UTC
Created attachment 1223313 [details]
File: var_log_messages

Comment 13 Gwendal 2016-11-23 16:00:45 UTC
Similar problem has been detected:

I tried to delete an empty line

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer --splash-pipe=5
crash_function: (anonymous namespace)::signalHandlerFunction(int)
executable:     /usr/lib64/libreoffice/program/soffice.bin
global_pid:     337
kernel:         4.8.7-300.fc25.x86_64
package:        libreoffice-core-5.2.3.3-6.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         soffice.bin killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 14 Davide Repetto 2016-12-08 20:33:11 UTC
Similar problem has been detected:

Impress Crashed while trying a few transitions on a very simple slide.

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer --splash-pipe=5
crash_function: (anonymous namespace)::signalHandlerFunction(int)
executable:     /usr/lib64/libreoffice/program/soffice.bin
global_pid:     427
kernel:         4.8.11-300.red.fc25.x86_64
package:        libreoffice-core-5.2.3.3-11.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         soffice.bin killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 15 Caolan McNamara 2016-12-09 11:11:09 UTC
backtrace suggests a null pSidebarController at this point

Comment 16 Francisco de la Peña 2016-12-16 02:49:08 UTC
Similar problem has been detected:

It crashes while trying to add a digital signature. I use p11-kit to replace libnssckbi.so.

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer --splash-pipe=5
crash_function: (anonymous namespace)::signalHandlerFunction(int)
executable:     /usr/lib64/libreoffice/program/soffice.bin
global_pid:     25088
kernel:         4.8.13-300.fc25.x86_64
package:        libreoffice-core-5.2.3.3-11.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         soffice.bin killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 17 Karel Volný 2017-01-12 14:48:35 UTC
Similar problem has been detected:

I've just rightclicked into a free space within a page in oodraw ...

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --draw --splash-pipe=5
crash_function: (anonymous namespace)::signalHandlerFunction(int)
executable:     /usr/lib64/libreoffice/program/soffice.bin
global_pid:     21181
kernel:         4.8.15-300.fc25.x86_64
package:        libreoffice-core-5.2.3.3-11.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         soffice.bin killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 18 ingo 2017-01-31 22:36:00 UTC
*** Bug 1418113 has been marked as a duplicate of this bug. ***

Comment 19 va7nt 2017-05-22 23:12:00 UTC
*** Bug 1454494 has been marked as a duplicate of this bug. ***

Comment 20 va7nt 2017-05-22 23:32:45 UTC
*** Bug 1454500 has been marked as a duplicate of this bug. ***

Comment 21 Bart Kessels 2017-05-23 08:51:37 UTC
Similar problem has been detected:

I copied and pasted a return character.

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer file:///home/bkessels/Downloads/High%20Level%20Architecture.docx --splash-pipe=5
crash_function: (anonymous namespace)::signalHandlerFunction(int)
executable:     /usr/lib64/libreoffice/program/soffice.bin
global_pid:     9906
kernel:         4.10.15-200.fc25.x86_64
package:        libreoffice-core-5.2.7.2-2.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         soffice.bin killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 22 Jeremy 2017-05-26 16:02:00 UTC
*** Bug 1456000 has been marked as a duplicate of this bug. ***

Comment 23 Christian Kirbach 2017-07-18 06:14:05 UTC
This crash happened when my laptop resumed from sleep. I believe Writer was still open but I do not remember what I did last with it before my laptop was put to sleep.

Comment 24 Davide Repetto 2017-07-26 18:26:21 UTC
Similar problem has been detected:

I tried using the "replacelinkswithimages-0.1.5.oxt"

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --calc --splash-pipe=5
crash_function: (anonymous namespace)::signalHandlerFunction(int)
executable:     /usr/lib64/libreoffice/program/soffice.bin
global_pid:     8562
kernel:         4.11.11-200.fc25.x86_64
package:        libreoffice-core-5.2.7.2-6.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         soffice.bin killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 25 INegueruela 2017-09-07 10:40:44 UTC
*** Bug 1489388 has been marked as a duplicate of this bug. ***

Comment 26 Dmitrtiy 2017-09-10 09:25:12 UTC
*** Bug 1490101 has been marked as a duplicate of this bug. ***

Comment 27 Christian Stadelmann 2017-10-31 10:29:28 UTC
I can still reproduce this bug by following these steps:
1. make sure you have the "gen" vcl plug installed (package: libreoffice-x11)
2. run `SAL_USE_VCLPLUGIN=gen soffice` in a GNOME/Wayland session

What happens:
Crash. libreport tells me that the backtrace matches this bug report.

Workaround:
Use a x11 session or run `GDK_BACKEND=x11 SAL_USE_VCLPLUGIN=gen soffice` instead.


Note You need to log in before you can comment on or make changes to this bug.