Bug 139803 - glibc limits usernames to 32 characters
Summary: glibc limits usernames to 32 characters
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: vsftpd   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Radek Vokal
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-18 05:42 UTC by Karl Latiss
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-28 01:16:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karl Latiss 2004-11-18 05:42:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.4.3)
Gecko/20040924 MultiZilla/1.6.4.0b

Description of problem:
usernames are limited to 32 characters. Usernames longer than 32
characters do not successfully authenticate.

Version-Release number of selected component (if applicable):
vsftpd-1.2.1-3

How reproducible:
Always

Steps to Reproduce:
1.Have username longer than 32 characters (ours is in LDAP)
2.Try to use that username to authenticate an ftp session
3.
    

Actual Results:  login fails with a "Login failed" error message.

Expected Results:  login is successful

Additional info:

The long username is supplied via LDAP - vsftpd is configured to use
PAM. The length of the username is due to it's email format, ie the
username is an email address.

Comment 1 Karl Latiss 2004-11-23 07:06:11 UTC
After further research I've changed the component (and title) to glibc
as I believe the problem lies at the system level.

I believe that this limit needs to be increased so as to provide a
consistant "single sign on" facility where the single username is
often an email address. 

Comment 2 Radek Vokal 2004-12-08 08:52:20 UTC
glibc supports usernames longer than 32 characters (may I have your
glibc version to confirm this) It seems like problem either in vsftpd
or somewhere in between. Anyway I didn't manage to configure vsftpd to
work with LDAP. Can you give me some configuration hints so I can
reproduce this bug?

Comment 3 Radek Vokal 2004-12-08 09:58:16 UTC
in addition, I've figure out that it vsftpd which trims usernames to
32chars. Still looking for some test case with LDAP.

Comment 5 Radek Vokal 2004-12-09 14:03:20 UTC
Fixed in vsftpd-1.2.1-3E.2


Note You need to log in before you can comment on or make changes to this bug.