Bug 1398040 - dnf calls weak dependencies "Skipping packages with broken dependencies"
Summary: dnf calls weak dependencies "Skipping packages with broken dependencies"
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 24
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Mracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: 1399615
TreeView+ depends on / blocked
 
Reported: 2016-11-23 23:43 UTC by Harald Reindl
Modified: 2017-06-09 19:05 UTC (History)
11 users (show)

Fixed In Version: dnf-2.5.0-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-09 19:05:50 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1399615 None None None Never

Description Harald Reindl 2016-11-23 23:43:06 UTC
"Skipping packages with broken dependencies" is plain nonsense for many months now and i see several threads on the devellist that this affects DNF2 - no it affects every DNF version ever out there and such a terrible wrong leading message should not happen

[root@srv-rhsoft:~]$ dnf upgrade
Last metadata expiration check: 0:00:35 ago on Thu Nov 24 00:40:40 2016.
Dependencies resolved.
===================================================================================================================================================================================================================
 Package                                                        Arch                                    Version                                             Repository                                        Size
===================================================================================================================================================================================================================
Skipping packages with broken dependencies:
 kf5-frameworkintegration                                       x86_64                                  5.27.0-1.fc24.2                                     updates-testing                                  1.5 M
 kf5-frameworkintegration-libs                                  x86_64                                  5.27.0-1.fc24.2                                     updates-testing                                   31 k
 kf5-kdeclarative                                               x86_64                                  5.27.0-1.fc24.2                                     updates-testing                                  258 k
 kf5-kwayland                                                   x86_64                                  5.27.0-1.fc24.2                                     updates-testing                                  311 k
 qt5-qtbase                                                     x86_64                                  5.6.2-1.fc24                                        updates-testing                                  3.0 M
 qt5-qtbase-common                                              noarch                                  5.6.2-1.fc24                                        updates-testing                                   29 k
 qt5-qtbase-gui                                                 x86_64                                  5.6.2-1.fc24                                        updates-testing                                  5.2 M
 qt5-qtdeclarative                                              x86_64                                  5.6.2-1.fc24                                        updates-testing                                  4.2 M
 qt5-qtgraphicaleffects                                         x86_64                                  5.6.2-1.fc24                                        updates-testing                                  470 k
 qt5-qtlocation                                                 x86_64                                  5.6.2-1.fc24                                        updates-testing                                  738 k
 qt5-qtmultimedia                                               x86_64                                  5.6.2-1.fc24                                        updates-testing                                  789 k
 qt5-qtquickcontrols                                            x86_64                                  5.6.2-1.fc24                                        updates-testing                                  928 k
 qt5-qtscript                                                   x86_64                                  5.6.2-1.fc24                                        updates-testing                                  1.0 M
 qt5-qtsensors                                                  x86_64                                  5.6.2-1.fc24                                        updates-testing                                  195 k
 qt5-qtserialport                                               x86_64                                  5.6.2-1.fc24                                        updates-testing                                   65 k
 qt5-qtsvg                                                      x86_64                                  5.6.2-1.fc24                                        updates-testing                                  157 k
 qt5-qttools                                                    x86_64                                  5.6.2-2.fc24                                        updates-testing                                   44 k
 qt5-qttools-common                                             noarch                                  5.6.2-2.fc24                                        updates-testing                                   24 k
 qt5-qttools-libs-designer                                      x86_64                                  5.6.2-2.fc24                                        updates-testing                                  2.7 M
 qt5-qtwebchannel                                               x86_64                                  5.6.2-1.fc24                                        updates-testing                                   84 k
 qt5-qtwebkit                                                   x86_64                                  5.6.2-1.fc24                                        updates-testing                                   10 M
 qt5-qtx11extras                                                x86_64                                  5.6.2-1.fc24                                        updates-testing                                   28 k
 qt5-qtxmlpatterns                                              x86_64                                  5.6.2-1.fc24                                        updates-testing                                  1.1 M

Transaction Summary
===================================================================================================================================================================================================================
Skip  23 Packages

Nothing to do.
Complete!

Comment 1 Harald Reindl 2016-11-24 11:43:50 UTC
OK, this case is indeed a dpendecy problem and after 10 years working with Fedora it makes it much more clear that you MUST NOT talk about errors in case of soft-dependecies because even advanced sysadmins are not able most of the time to distinct what DNF is talking about

FRANKLY DNF don't give any useful informations even with "dnf -v" and saying "broken dependencies" woth the list of some packages is NOT HELPFUL

the output of yum-deprecated IS HELPFUL as yum always was - so can you please stop deisgn DNF for fools where you pretend they would not understand the output anyways and after that when also working with local packages works proper DNF *may become* a replacement for YUM - currently it is not

Resolving Dependencies
--> Running transaction check
---> Package kf5-frameworkintegration.x86_64 0:5.27.0-1.fc24 will be updated
---> Package kf5-frameworkintegration.x86_64 0:5.27.0-1.fc24.2 will be an update
---> Package kf5-frameworkintegration-libs.x86_64 0:5.27.0-1.fc24 will be updated
---> Package kf5-frameworkintegration-libs.x86_64 0:5.27.0-1.fc24.2 will be an update
---> Package kf5-kdeclarative.x86_64 0:5.27.0-1.fc24 will be updated
---> Package kf5-kdeclarative.x86_64 0:5.27.0-1.fc24.2 will be an update
---> Package kf5-kwayland.x86_64 0:5.27.0-1.fc24 will be updated
---> Package kf5-kwayland.x86_64 0:5.27.0-1.fc24.2 will be an update
---> Package qt5-qtbase.x86_64 0:5.6.1-3.fc24 will be updated
--> Processing Dependency: qt5-qtbase(x86-64) = 5.6.1 for package: plasma-integration-5.8.3-1.fc24.x86_64
--> Processing Dependency: qt5-qtbase(x86-64) = 5.6.1 for package: kwin-5.8.3-1.fc24.x86_64
---> Package qt5-qtbase.x86_64 0:5.6.2-1.fc24 will be an update
---> Package qt5-qtbase-common.noarch 0:5.6.1-3.fc24 will be updated
---> Package qt5-qtbase-common.noarch 0:5.6.2-1.fc24 will be an update
---> Package qt5-qtbase-gui.x86_64 0:5.6.1-3.fc24 will be updated
---> Package qt5-qtbase-gui.x86_64 0:5.6.2-1.fc24 will be an update
---> Package qt5-qtdeclarative.x86_64 0:5.6.1-5.fc24 will be updated
---> Package qt5-qtdeclarative.x86_64 0:5.6.2-1.fc24 will be an update
---> Package qt5-qtgraphicaleffects.x86_64 0:5.6.1-1.fc24 will be updated
---> Package qt5-qtgraphicaleffects.x86_64 0:5.6.2-1.fc24 will be an update
---> Package qt5-qtlocation.x86_64 0:5.6.1-2.fc24 will be updated
---> Package qt5-qtlocation.x86_64 0:5.6.2-1.fc24 will be an update
---> Package qt5-qtmultimedia.x86_64 0:5.6.1-3.fc24 will be updated
---> Package qt5-qtmultimedia.x86_64 0:5.6.2-1.fc24 will be an update
---> Package qt5-qtquickcontrols.x86_64 0:5.6.1-1.fc24 will be updated
---> Package qt5-qtquickcontrols.x86_64 0:5.6.2-1.fc24 will be an update
---> Package qt5-qtscript.x86_64 0:5.6.1-1.fc24 will be updated
---> Package qt5-qtscript.x86_64 0:5.6.2-1.fc24 will be an update
---> Package qt5-qtsensors.x86_64 0:5.6.1-2.fc24 will be updated
---> Package qt5-qtsensors.x86_64 0:5.6.2-1.fc24 will be an update
---> Package qt5-qtserialport.x86_64 0:5.6.1-1.fc24 will be updated
---> Package qt5-qtserialport.x86_64 0:5.6.2-1.fc24 will be an update
---> Package qt5-qtsvg.x86_64 0:5.6.1-2.fc24 will be updated
---> Package qt5-qtsvg.x86_64 0:5.6.2-1.fc24 will be an update
---> Package qt5-qttools.x86_64 0:5.6.1-2.fc24 will be updated
---> Package qt5-qttools.x86_64 0:5.6.2-2.fc24 will be an update
---> Package qt5-qttools-common.noarch 0:5.6.1-2.fc24 will be updated
---> Package qt5-qttools-common.noarch 0:5.6.2-2.fc24 will be an update
---> Package qt5-qttools-libs-designer.x86_64 0:5.6.1-2.fc24 will be updated
---> Package qt5-qttools-libs-designer.x86_64 0:5.6.2-2.fc24 will be an update
---> Package qt5-qtwebchannel.x86_64 0:5.6.1-2.fc24 will be updated
---> Package qt5-qtwebchannel.x86_64 0:5.6.2-1.fc24 will be an update
---> Package qt5-qtwebkit.x86_64 0:5.6.1-3.b889f46git.fc24 will be updated
---> Package qt5-qtwebkit.x86_64 0:5.6.2-1.fc24 will be an update
---> Package qt5-qtx11extras.x86_64 0:5.6.1-2.fc24 will be updated
---> Package qt5-qtx11extras.x86_64 0:5.6.2-1.fc24 will be an update
---> Package qt5-qtxmlpatterns.x86_64 0:5.6.1-1.fc24 will be updated
---> Package qt5-qtxmlpatterns.x86_64 0:5.6.2-1.fc24 will be an update
--> Finished Dependency Resolution
--> Finding unneeded leftover dependencies
Found and removing 0 unneeded dependencies
Error: Package: plasma-integration-5.8.3-1.fc24.x86_64 (installed)
           Requires: qt5-qtbase(x86-64) = 5.6.1
           Removing: qt5-qtbase-5.6.1-3.fc24.x86_64 (installed)
               qt5-qtbase(x86-64) = 5.6.1-3.fc24
           Updated By: qt5-qtbase-5.6.2-1.fc24.x86_64 (updates-testing)
               qt5-qtbase(x86-64) = 5.6.2-1.fc24
           Available: qt5-qtbase-5.6.0-13.fc24.x86_64 (fedora)
               qt5-qtbase(x86-64) = 5.6.0-13.fc24
Error: Package: kwin-5.8.3-1.fc24.x86_64 (installed)
           Requires: qt5-qtbase(x86-64) = 5.6.1
           Removing: qt5-qtbase-5.6.1-3.fc24.x86_64 (installed)
               qt5-qtbase(x86-64) = 5.6.1-3.fc24
           Updated By: qt5-qtbase-5.6.2-1.fc24.x86_64 (updates-testing)
               qt5-qtbase(x86-64) = 5.6.2-1.fc24
           Available: qt5-qtbase-5.6.0-13.fc24.x86_64 (fedora)
               qt5-qtbase(x86-64) = 5.6.0-13.fc24
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 2 Rex Dieter 2016-11-24 12:52:43 UTC
The qt 5.6.2 update,
https://bodhi.fedoraproject.org/updates/FEDORA-2016-ee7faa4b02
indeed has broken deps (missing kwin and plasma-integration), I'll be fixing it today. (sorry)

Comment 3 Harald Reindl 2016-11-26 12:24:19 UTC
until now not fixed - besides that everytime when DNF tells me deps are broken but not what is the reason i get terrible angry, the good old yum gone so far that it even mentioned conflicting sonames so that you can write useful bugreports

i guess the excuse is that the ordinary user is overwheelmed with that informations he don't understand what is wrong for many reasons:

* the ordinary user don't use CLI and DNF/YUM
* he can't learn to understand because he don't get something useful

guys guess how i learend about the way pakcages acting together and what relies on waht packages - mostly by the output of YUM - without that i would still be that ordinary user with no clue - happily i started with Fedora in times where it talked to his users instead burry anything (except systemd which fllods logs all the time and does the otehr direction in the wrong way)

when i say "dnf -v" i MEAN "be verbose and talk to me"

Comment 4 Jaroslav Mracek 2016-11-28 19:14:02 UTC
Please can you provide transaction output from "yum update --skip-broken" and 'dnf upgrade'. Please before comperison clean cache for dnf and for yum. Thanks a lot, any additional information will speedup redesign of dnf code. Thanks a lot.

Comment 5 Harald Reindl 2016-11-28 19:32:48 UTC
too late now - update was fixed but i will bookmark this bugreport and add a comment when it happens the next time

in the meantime it shouldn't be too hard to build some intentional broken package and compare the non-helpful DNS output "Skipping packages with broken dependencies" versus what YUM said for years in case of dependency problems

Comment 6 Jakub Filak 2016-11-29 08:58:18 UTC
I've hit a different problem with the skipping packages with broken dependencies feature. I tried to install curl, libcurl and libcurl-devel and dnf replied with the following message:

Last metadata expiration check: 2:01:31 ago on Tue Nov 29 01:03:07 2016.
Package libcurl-7.50.3-1.fc25.x86_64 is already installed, skipping.
Package libcurl-devel-7.50.3-1.fc25.x86_64 is already installed, skipping.
Dependencies resolved.
==========================================================================================================================================================================
 Package                                     Arch                                 Version                                     Repository                             Size
==========================================================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 curl                                        x86_64                               7.51.0-3.fc25                               updates                               307 k
 libcurl                                     x86_64                               7.51.0-3.fc25                               updates                               266 k
 libcurl-devel                               x86_64                               7.51.0-3.fc25                               updates                               665 k
 
Transaction Summary
==========================================================================================================================================================================
Skip  3 Packages
 
Nothing to do.
Complete!


I didn't notice that dnf tried to tell me that the packages are already installed but I noticed that I should run dnf with '--best --allowerasing'. I went ahead and this time dnf replied with exactly the same message but it proceed with the installation. I call this utter confusing behavior. dnf should either print only the lines saying that the packages are already installed or install the updates.

Comment 7 Jaroslav Mracek 2017-04-10 13:18:23 UTC
I create huge refactor of problems report https://github.com/rpm-software-management/dnf/pull/782. Hope that it helps.

Comment 8 Fedora Update System 2017-05-22 12:40:21 UTC
dnf-plugins-extras-2.0.1-1.fc26 dnf-plugins-core-2.1.0-1.fc26 libdnf-0.9.0-1.fc26 dnf-2.5.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-92e5a01da8

Comment 9 Fedora Update System 2017-05-22 16:39:50 UTC
dnf-2.5.0-1.fc26, dnf-plugins-core-2.1.0-1.fc26, dnf-plugins-extras-2.0.1-1.fc26, libdnf-0.9.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-92e5a01da8

Comment 10 Fedora Update System 2017-05-24 08:31:28 UTC
dnf-2.5.0-1.fc26 dnf-plugins-core-2.1.0-1.fc26 dnf-plugins-extras-2.0.1-1.fc26 dnfdaemon-0.3.17-3.fc26 libdnf-0.9.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-92e5a01da8

Comment 11 Fedora Update System 2017-05-24 14:32:48 UTC
dnf-2.5.0-2.fc26 dnf-plugins-core-2.1.0-1.fc26 dnf-plugins-extras-2.0.1-1.fc26 dnfdaemon-0.3.18-1.fc26 libdnf-0.9.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-92e5a01da8

Comment 12 Fedora Update System 2017-05-25 19:17:20 UTC
dnf-2.5.0-2.fc26, dnf-plugins-core-2.1.0-1.fc26, dnf-plugins-extras-2.0.1-1.fc26, dnfdaemon-0.3.18-2.fc26, libdnf-0.9.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-92e5a01da8

Comment 13 Fedora Update System 2017-06-09 19:05:50 UTC
dnf-2.5.0-2.fc26, dnf-plugins-core-2.1.0-1.fc26, dnf-plugins-extras-2.0.1-1.fc26, dnfdaemon-0.3.18-2.fc26, libdnf-0.9.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.