Bug 139805 - Anaconda overwrites /etc/postfix/aliases
Anaconda overwrites /etc/postfix/aliases
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 01:05 EST by Joachim Backes
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-18 09:52:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2004-11-18 01:05:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
After the FC3 update install from FC2 to FC3, the file
/etc/postfix/aliases was made new, so that postfix could no more
started correctly. I had to move /etc/postfix/aliases.rpmsave into
/etc/postfix/aliases. I think, a file such as aliases should not be
overwritten by anaconda during an uppdate install.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install postfix in FCx (x<=2), make a new aliases
2.Update to FC3

    

Actual Results:  /etc/postfix/aliases is overwritten

Expected Results:  Untouched /etc/postfix/aliases

Additional info:
Comment 1 Jeremy Katz 2004-11-18 08:35:22 EST
Standard %config handling is used.  So if anything, this is a package bug.
Comment 2 Thomas Woerner 2004-11-18 09:52:57 EST
The postfix package in FC3 is not using /etc/postfix/aliases anymore.
Instead it is using /etc/aliases. The new postfix package is not
touching the old alias file at all.

Please use the new main.cf file an apply your changes except for the
aliases file.

Closing as "NOT A BUG".
Comment 3 Joachim Backes 2004-11-22 00:53:58 EST
Maybe /etc/postfix/aliases is no more used.

But without an valid aliases file, postfix did not start correctly.
But after copying or moving aliases.rpmsave to /etc/postfix/aliases,
postfix could be started and used.

Note You need to log in before you can comment on or make changes to this bug.