Bug 139809 - status window position not updated when using alt+tab
status window position not updated when using alt+tab
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: iiimf (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
: i18n
Depends On:
Blocks: IIIMF 157395
  Show dependency treegraph
 
Reported: 2004-11-18 01:23 EST by Lawrence Lim
Modified: 2014-03-25 20:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 23:58:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
status window in the previous position (174.00 KB, image/png)
2004-11-18 01:23 EST, Lawrence Lim
no flags Details

  None (edit)
Description Lawrence Lim 2004-11-18 01:23:23 EST
Description of problem:
Tested in the GNOME desktop envrionment, when the user move an application
around the desktop with LE activated, using alt+tab to switch to another
application and back to the original application of the LE activated, you will
notice that the status window is still at the old position where the application
used to be.

Please see attached screenshot. I dont think this is LE specific.

Version-Release number of selected component (if applicable):
im-sdk-12.1-8

How reproducible:
Always

Steps to Reproduce:
1.in gdm, log in as normal user with any CJK locale
2.start g-t
3.in g-t, gedit &
4.in gedit, ctrl-space to activate LE
5.move gedit using mouse to another corner of the screen
6.alt-tab to switch back to g-t
7.alt-tab to switch back to gedit
  
Actual results:
status window is at the previous position of gedit application

Expected results:
the position should be updated

Additional info:
Comment 1 Lawrence Lim 2004-11-18 01:23:23 EST
Created attachment 106934 [details]
status window in the previous position
Comment 2 Akira TAGOH 2005-04-14 07:07:11 EDT
Fixed in svn2483. will see the updated package soon.
Comment 3 Akira TAGOH 2005-04-14 07:37:20 EDT
committed a patch into CVS. will be available in next build.
Comment 4 Lawrence Lim 2005-05-10 03:29:13 EDT
Tested with iiimf-12.2-0.7.svn2578, the bug still exist. Please verify.
Comment 5 Lawrence Lim 2005-05-10 03:40:12 EDT
Happen in iiimf-12.2-3 as well.
Comment 6 Jens Petersen 2005-05-16 10:37:34 EDT
I see it too, with iiimf-12.2-3.
Comment 8 Lawrence Lim 2005-09-29 23:58:20 EDT
We strive to work with the upstream community of open source projects. This
allows us to reduce the likelihood of regressions between releases as well as to
benefit from features and fixes as development moves forward. Since this change
would require a divergence from the upstream project, please report this issue
to IIIMF developers by filing a bug report in the OpenI18N bugzilla located at
http://openi18n.org/bugzilla/ in the "IIIMF" component.

We urge you to bring the information upstream, so that it can be incorporated in
the next release. Once you've filed your bug report to OpenI18N, if you paste
the new bug URL here, we will continue to track the issue in the centralized
OpenI18N bug tracker, and will review any bug fixes that become available for
consideration in future updates.

Thanks. 

Note You need to log in before you can comment on or make changes to this bug.