Bug 139812 - keyboard acceleration doesn't work after inputting something with IM
keyboard acceleration doesn't work after inputting something with IM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 02:15 EST by Akira TAGOH
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.9.89-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-08 10:22:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2004-11-18 02:15:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922

Description of problem:
I just noticed this problem when I input something with IIIMF and
turned off the IM. after that, any keyboard accelerations like Ctrl-q
and Alt-f and whatever doesn't work until typing any without IM.


Version-Release number of selected component (if applicable):
1.1.2-11.7

How reproducible:
Always

Steps to Reproduce:
1.run oowriter with ja_JP.UTF-8 locale
2.press ctrl-space n i h o n g o enter ctrl-space
3.press alt-f or ctrl-q or whatever
    

Actual Results:  the keyboard accelerations doesn't work

Expected Results:  the keyboard accelerations should works

Additional info:

it seems to be not depending on any locales. I can reproduce this on
zh_TW.UTF-8 too say. also, it affects FC2 and FC3.
Comment 1 Lawrence Lim 2004-11-29 23:28:36 EST
Still happening with openoffice.org-1.1.2-14.6.EL4
Comment 2 Jens Petersen 2004-12-14 02:41:42 EST
I also noticed that this happens when iiim is left on: ie if one
omits the second Ctrl-Space in step (2) above.
Comment 3 Caolan McNamara 2005-04-08 10:22:53 EDT
Looks good to me in 1.9.89-5 with export GTK_IM_MODULE=iiim and langpack/locale
zh_TW.

Note You need to log in before you can comment on or make changes to this bug.