Bug 1398205 - The GUI only shows custom roles if they are in the default plan
Summary: The GUI only shows custom roles if they are in the default plan
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ga
: 10.0 (Newton)
Assignee: Jiri Tomasek
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks: 1398274
TreeView+ depends on / blocked
 
Reported: 2016-11-24 09:51 UTC by Udi
Modified: 2016-12-14 16:34 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-ui-1.0.5-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 16:34:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC
OpenStack gerrit 402355 None None None 2016-11-25 08:37:53 UTC
Launchpad 1644310 None None None 2016-11-24 09:55:57 UTC

Description Udi 2016-11-24 09:51:37 UTC
Description of problem:
I uploaded new templates with custom roles, and the GUI didn't display them. It turns out that custom roles are only displayed if they are in the default plan, and the current plan is ignored.

There is a fix for it upstream, and we need to make sure it is merged downstream for the GA: https://review.openstack.org/#/c/401351/


How reproducible:
100%


Steps to Reproduce:
1. Create custom roles and upload the templates
2. Switch to the new plan and make it the active plan
3. The deployment page still shows the same roles as always

Comment 1 Jiri Tomasek 2016-11-24 09:54:11 UTC
Upstream bug: https://bugs.launchpad.net/tripleo/+bug/1644310

Comment 6 Udi 2016-12-08 08:25:25 UTC
Verified in the RC puddle 2016-11-30.9

Comment 7 Anandeep Pannu 2016-12-09 21:05:48 UTC
Since this is verified - clearing needinfo

Comment 9 errata-xmlrpc 2016-12-14 16:34:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.