Bug 1398212 - Don't install vim.desktop file
Summary: Don't install vim.desktop file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: vim
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-24 10:03 UTC by Vít Ondruch
Modified: 2016-12-07 07:54 UTC (History)
3 users (show)

Fixed In Version: vim-8.0.118-1.fc25 vim-8.0.118-1.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-04 02:28:53 UTC


Attachments (Terms of Use)

Description Vít Ondruch 2016-11-24 10:03:05 UTC
Description of problem:
It seems that Vim 8.0 ships its own desktop file, so now I have installed:

```
$ ls /usr/share/applications/ | grep vim
gvim.desktop
vim.desktop
```

The downside of this is that I have actually "Vim" and "Vi IMproved" menu entries, but most importantly, Vim in new terminal window is opened whenever I want to open some text file. This is extremely annoying.

Please drop the duplicated desktop files and open gvim by default.


Version-Release number of selected component (if applicable):
$ rpm -q vim-X11
vim-X11-8.0.094-1.fc26.x86_64


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Duplicated menu entries, Vim in new terminal window is used to open files.


Expected results:
Only one VIM menu entry. GVim is used to open files.


Additional info:
This behavior is very annoying e.g. when you try to open some .c file from browser, but new terminal pops up instead of gvim.

Comment 1 Zdenek Dohnal 2016-11-24 11:01:02 UTC
Hi Víťa,

thanks for reporting, I removed that desktop file - you can check it on scratch build http://koji.fedoraproject.org/koji/taskinfo?taskID=16594891 .

Comment 2 Vít Ondruch 2016-11-25 16:43:45 UTC
Thx that works for me.

Nevertheless, I am not sure about the implementation ... Wouldn't be actually better to use the upstream .desktop file and just s/vim/gvim/ ?

1. The upstream desktop file appears to have more translations (but I have not checked the remaining differences) and you could drop the source file you ship ...
2. There are now some build artefacts such as:

```
cp: cannot stat '../runtime/vim.desktop': No such file or directory
```

Comment 3 Fedora Update System 2016-11-28 12:08:49 UTC
vim-8.0.104-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-79a059792b

Comment 4 Fedora Update System 2016-11-28 12:15:19 UTC
vim-8.0.104-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-823629d4a5

Comment 5 Fedora Update System 2016-11-28 12:43:18 UTC
vim-8.0.104-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0b8cbb7e4a

Comment 6 Fedora Update System 2016-11-30 06:52:14 UTC
vim-8.0.104-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-79a059792b

Comment 7 Fedora Update System 2016-12-02 06:26:35 UTC
vim-8.0.104-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-823629d4a5

Comment 8 Fedora Update System 2016-12-02 09:32:41 UTC
vim-8.0.118-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6064f86234

Comment 9 Fedora Update System 2016-12-02 09:52:17 UTC
vim-8.0.118-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5f066b9711

Comment 10 Fedora Update System 2016-12-02 18:53:48 UTC
vim-8.0.104-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0b8cbb7e4a

Comment 11 Fedora Update System 2016-12-03 04:29:58 UTC
vim-8.0.118-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6064f86234

Comment 12 Fedora Update System 2016-12-03 05:42:27 UTC
vim-8.0.118-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5f066b9711

Comment 13 Fedora Update System 2016-12-04 02:28:53 UTC
vim-8.0.118-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2016-12-07 07:54:58 UTC
vim-8.0.118-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.