Bug 139824 - Kickstart lacks the ability to force installation of 32-bit components
Summary: Kickstart lacks the ability to force installation of 32-bit components
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 3.0
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-18 10:12 UTC by Richard Freeman
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-18 14:28:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2005:191 normal SHIPPED_LIVE anaconda enhancement update 2005-05-18 04:00:00 UTC

Description Richard Freeman 2004-11-18 10:12:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3)
Gecko/20041001 Firefox/0.10.1

Description of problem:
During the kickstart file generation, you can specify certain packages
to install on the command line:

e.g.

ncurses

Would force install of the ncurses library. The problem is there are
often 32-bit versions of various items supplied by Redhat also, but it
impossible to force installation of these. If you install openoffice,
then it will install a lot of 32-bit dependicies though but that is a
bit of a hack.

What I'd like to suggest, is a format like what YUM uses. So if I do
this in the kickstart file:

ncurses
ncurses.i386

The first line install for the current architecture, the 2nd will
force install of the i386 version of the ncurses library. This is
provided & supported by RH, so it isn't install unsupported packages.

Is this possible?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install via kickstart.
2. Try to install 32-bit packages via kickstart.
3.
    

Additional info:

Comment 1 Suzanne Hillman 2004-11-18 19:35:40 UTC
Internal RFE bug #139918 entered; will be considered for future releases.

Comment 2 Paul Nasrat 2004-11-22 15:55:53 UTC
Re-assign to anaconda.

Comment 3 Paul Nasrat 2005-01-04 20:43:32 UTC
Backported on RHEL3 branch for U5

Comment 4 Richard Freeman 2005-01-05 09:33:19 UTC
Cool! Are there any documents on this procedure?

Comment 5 Jeremy Katz 2005-01-05 15:18:00 UTC
The syntax is name.arch in the %packages section (eg, glibc.i386)

Comment 7 Dennis Gregorovic 2005-05-18 14:28:54 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2005-191.html



Note You need to log in before you can comment on or make changes to this bug.