Bug 1398337 - dnsmasq lacks ra-param option
dnsmasq lacks ra-param option
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dnsmasq (Show other bugs)
7.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Petr Menšík
Jan Ščotka
Ioanna Gkioka
:
Depends On: 1375527
Blocks: 1393869
  Show dependency treegraph
 
Reported: 2016-11-24 08:30 EST by Neil Wilson
Modified: 2017-08-01 18:56 EDT (History)
3 users (show)

See Also:
Fixed In Version: dnsmasq-2.76-1.el7
Doc Type: Enhancement
Doc Text:
_Dnsmasq_ now supports the *ra-param* option With this update, *dnsmasq* can change the default values of IPv6 Router Advertisement. As a result, the "ra-param" option is used to change the default priorities and time intervals of routes advertised by *dnsmasq*. See the *dnsmasq(1)* man page for more information.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 18:56:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2117 normal SHIPPED_LIVE dnsmasq bug fix and enhancement update 2017-08-01 15:38:28 EDT

  None (edit)
Description Neil Wilson 2016-11-24 08:30:27 EST
Description of problem:

dnsmasq lacks the ra-param option


Version-Release number of selected component (if applicable):

Name        : dnsmasq
Arch        : x86_64
Version     : 2.66
Release     : 14.el7_2.1


Additional info:

The version of dnsmasq in RHEL7 lacks the ra-param option available in version 2.67 and above - which means that dnsmasq can't be used as a full replacement for radvd.

The particular use case here is when routers switch over and you want to lower the route priority/lifetime of one vs. the other.
Comment 10 errata-xmlrpc 2017-08-01 18:56:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2117

Note You need to log in before you can comment on or make changes to this bug.