Bug 1398393 - Rebase systemtap to 3.x
Summary: Rebase systemtap to 3.x
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemtap   
(Show other bugs)
Version: 7.4
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: alpha
: ---
Assignee: Frank Ch. Eigler
QA Contact: qe-baseos-tools
Vladimír Slávik
URL:
Whiteboard:
Keywords: Rebase
Depends On:
Blocks: 1390370 1465627 1386120 1411714
TreeView+ depends on / blocked
 
Reported: 2016-11-24 16:44 UTC by mbenitez
Modified: 2017-08-01 09:34 UTC (History)
9 users (show)

Fixed In Version: systemtap-3.1-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
_systemtap_ rebased to version 3.1 The _systemtap_ package has been upgraded to upstream version 3.1, which provides a number of bug fixes and enhancements over the previous version. Notable changes include: * The probes for system calls no longer default to being based on *debuginfo* information. * Support for probing *Python* functions has been added. * Access to *Java* function parameters has been made more uniform. * The performance of statistical aggregate variables has been improved. * A new statistics operator "@variance" has been added. * More options for fetching and setting user-space values have been added. * NFS monitoring has been improved with sample scripts and tapset compatibility fixes.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 09:34:40 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2301 normal SHIPPED_LIVE systemtap bug fix and enhancement update 2017-08-01 12:41:08 UTC

Description mbenitez 2016-11-24 16:44:06 UTC

Comment 6 Martin Cermak 2017-06-21 13:25:45 UTC
Rebase testing systemtap-3.1-3.el7 finished.

Comment 8 Frank Ch. Eigler 2017-07-13 15:15:22 UTC
lgtm, thanks

Comment 9 errata-xmlrpc 2017-08-01 09:34:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2301


Note You need to log in before you can comment on or make changes to this bug.