Bug 1398424 - *ERROR* [CRTC:26:pipe A] flip_done timed out
Summary: *ERROR* [CRTC:26:pipe A] flip_done timed out
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-24 19:40 UTC by Kaloyan Petrov
Modified: 2019-01-09 12:54 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-27 17:39:15 UTC


Attachments (Terms of Use)
dmesg output (97.52 KB, text/plain)
2016-11-24 19:40 UTC, Kaloyan Petrov
no flags Details
dmesg with drm debug of 4.9.10-200.fc25 (134.08 KB, text/plain)
2017-02-26 21:53 UTC, Kaloyan Petrov
no flags Details
dmesg with bug on 4.10.9-200.fc25 (123.08 KB, text/plain)
2017-04-17 09:36 UTC, Kaloyan Petrov
kaloyan_petrov: review? (jforbes)
Details

Description Kaloyan Petrov 2016-11-24 19:40:57 UTC
Created attachment 1224002 [details]
dmesg output

Description of problem: Switching to tty2 with Ctrl-Alt-F2, causes the laptop to freeze. After 10-15 seconds the 'flip_done timed out' message appears. tty2 can't be used, but i can switch back to GUI. Going back to any tty, repeats the timeout.


Version-Release number of selected component (if applicable):
4.8.8-200.fc24.x86_64

How reproducible:
It happens every time.

Steps to Reproduce:
1. Playing icytower, using Firefox and Chrome(with flashplayer)
2. Stop icytower, close chrome
3. Switch to tty2

Actual results:
Can't write in tty2

Expected results:
Be able to write in tty2.

Additional info:
This started with kernel 4.8. If laptop power management turns the screen off, laptop becomes unresponsive, and only fix is to power off. Fix is to reboot.

[74973.542826] WARNING: CPU: 1 PID: 831 at drivers/gpu/drm/i915/intel_display.c:13688 intel_atomic_commit_tail+0x1043/0x1050 [i915]
[74973.542829] pipe A vblank wait timed out
[74973.542903] Modules linked in: snd_seq_dummy ccm bluetooth nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack intel_rapl x86_pkg_temp_thermal coretemp kvm_intel uvcvideo videobuf2_vmalloc videobuf2_memops kvm videobuf2_v4l2 videobuf2_core videodev media irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulni_intel arc4 intel_cstate intel_uncore snd_hda_codec_hdmi snd_hda_codec_conexant iwldvm mac80211 snd_hda_codec_generic intel_rapl_perf iwlwifi snd_hda_intel snd_hda_codec snd_hda_core snd_hwdep snd_seq iTCO_wdt iTCO_vendor_support cfg80211 snd_seq_device mei_wdt snd_pcm thinkpad_acpi joydev wmi rfkill lpc_ich i2c_i801 snd_timer i2c_smbus snd mei_me mei tpm_tis tpm_tis_core soundcore shpchp tpm binfmt_misc i915 i2c_algo_bit drm_kms_helper e1000e crc32c_intel drm sdhci_pci serio_raw sdhci mmc_core
[74973.542908]  ptp pps_core fjes video
[74973.542915] CPU: 1 PID: 831 Comm: Xorg Tainted: G     U          4.8.8-200.fc24.x86_64 #1
[74973.542917] Hardware name: LENOVO 4239CTO/4239CTO, BIOS 8AET65WW (1.45 ) 05/14/2015
[74973.542928]  0000000000000286 000000008a56d607 ffff8dd1074ef7a8 ffffffffaa3e5dbd
[74973.542933]  ffff8dd1074ef7f8 0000000000000000 ffff8dd1074ef7e8 ffffffffaa0a0e8b
[74973.542938]  0000357863452600 0000000000000000 0000000000000000 ffff8dd106ef0000
[74973.542939] Call Trace:
[74973.542953]  [<ffffffffaa3e5dbd>] dump_stack+0x63/0x86
[74973.542962]  [<ffffffffaa0a0e8b>] __warn+0xcb/0xf0
[74973.542969]  [<ffffffffaa0a0f0f>] warn_slowpath_fmt+0x5f/0x80
[74973.542977]  [<ffffffffaa0e4b13>] ? finish_wait+0x53/0x70
[74973.543052]  [<ffffffffc044ad23>] intel_atomic_commit_tail+0x1043/0x1050 [i915]
[74973.543059]  [<ffffffffaa0e4d70>] ? prepare_to_wait_event+0xf0/0xf0
[74973.543129]  [<ffffffffc044b16e>] intel_atomic_commit+0x43e/0x550 [i915]
[74973.543176]  [<ffffffffc03030d7>] ? drm_atomic_check_only+0x187/0x610 [drm]
[74973.543214]  [<ffffffffc0303597>] drm_atomic_commit+0x37/0x60 [drm]
[74973.543237]  [<ffffffffc03a3c7c>] restore_fbdev_mode+0x14c/0x270 [drm_kms_helper]
[74973.543257]  [<ffffffffc03a58c4>] drm_fb_helper_restore_fbdev_mode_unlocked+0x34/0x80 [drm_kms_helper]
[74973.543273]  [<ffffffffc03a593d>] drm_fb_helper_set_par+0x2d/0x50 [drm_kms_helper]
[74973.543346]  [<ffffffffc046599a>] intel_fbdev_set_par+0x1a/0x60 [i915]
[74973.543354]  [<ffffffffaa467985>] ? fb_set_var+0x2f5/0x460
[74973.543358]  [<ffffffffaa4678c6>] fb_set_var+0x236/0x460
[74973.543366]  [<ffffffffaa0d5ca6>] ? update_curr+0x66/0x170
[74973.543371]  [<ffffffffaa0d2b5c>] ? __enqueue_entity+0x6c/0x70
[74973.543377]  [<ffffffffaa0da208>] ? enqueue_entity+0x2e8/0x8e0
[74973.543384]  [<ffffffffaa45d6ef>] fbcon_blank+0x30f/0x350
[74973.543390]  [<ffffffffaa0df146>] ? pick_next_task_fair+0x486/0x4c0
[74973.543397]  [<ffffffffaa4e6402>] do_unblank_screen+0xd2/0x1a0
[74973.543403]  [<ffffffffaa4dbb79>] complete_change_console+0x59/0xe0
[74973.543407]  [<ffffffffaa4dc309>] vt_ioctl+0x709/0x12a0
[74973.543438]  [<ffffffffc02e8fd6>] ? drm_ioctl+0x236/0x4f0 [drm]
[74973.543444]  [<ffffffffaa4d057a>] tty_ioctl+0x35a/0xc50
[74973.543451]  [<ffffffffaa264cd3>] do_vfs_ioctl+0xa3/0x5f0
[74973.543456]  [<ffffffffaa265299>] SyS_ioctl+0x79/0x90
[74973.543465]  [<ffffffffaa8027b2>] entry_SYSCALL_64_fastpath+0x1a/0xa4
[74973.543470] ---[ end trace b4c244db12f84559 ]---
[74983.850259] [drm:drm_atomic_helper_commit_cleanup_done [drm_kms_helper]] *ERROR* [CRTC:26:pipe A] flip_done timed out

Comment 1 Kaloyan Petrov 2016-11-25 08:09:45 UTC
Correction on the steps to reproduce.
Steps to Reproduce:
1. Put laptop to sleep.
2. Resume.
3. Switch to tty2

Comment 2 Kaloyan Petrov 2016-12-14 19:29:46 UTC
I have upgraded to Fedora 25, using kernel 4.8.13 and the bug is gone.

Comment 3 Kaloyan Petrov 2017-02-26 21:53:54 UTC
Created attachment 1257858 [details]
dmesg with drm debug of 4.9.10-200.fc25

The bug is still present. Every kernel after 4.7.4-200.fc24 has it.

Comment 4 Justin M. Forbes 2017-04-11 14:40:07 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 25 kernel bugs.

Fedora 25 has now been rebased to 4.10.9-200.fc25.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.

If you experience different issues, please open a new bug report for those.

Comment 5 Kaloyan Petrov 2017-04-17 09:36:17 UTC
Created attachment 1272013 [details]
dmesg with bug on 4.10.9-200.fc25

Bug is still present on latest Fedora 25 kernel. dmesg output was produced from the following steps:
1)Boot laptop to kernel.
2)At login screen in XFCE, switch to tty2(Ctrl-Alt-F2)
3)Black screen freezes, and after some waiting the flip_done message appears.

Comment 6 Greg Trounson 2017-04-28 01:15:27 UTC
I can confirm this bug was present in Fedora 24 as well as Fedora 25 with Kernels 4.10.10-200 and 4.10.11-200 on an HP Compaq 6710b laptop with Intel 965GM graphics.

Switching to any different TTY, text or graphical, was very slow (about 20-30 seconds) and would result in several ABRT error messages.  This includes logging out of a desktop session.  During those times the picture would be visible but nothing, not even the mouse pointer, would respond.

The suggestion at the following link fixed it for me:
https://bbs.archlinux.org/viewtopic.php?pid=1689914#p1689914

Specifically, this is a workaround to disable the S-VIDEO interface, by adding the following kernel boot parameter:

video=SVIDEO-1:d

After applying this, the system boots up much faster, there are no ABRT messages, and TTY changes are instant.

So the problem appears to be caused somewhere near the code for the S-VIDEO port.

Comment 7 Kaloyan Petrov 2017-05-08 04:35:50 UTC
S-VIDEO fix didn't work out for me. I have tried it on 4.10.12-200.fc25.x86_64 and 4.10.13-200.fc25.x86_64 on my ThinkPad T520i.

One more thing. After the bug happens, and you go back to desktop. If you try to start/switch to/from Firefox, from another window, you get another freeze.

Comment 8 Kaloyan Petrov 2017-07-27 17:39:15 UTC
I have upgraded to Fedora 26, a week ago, and haven't seen the bug.

Comment 9 pawan kumar v 2018-03-20 16:00:09 UTC
The bug is still there on my dell d630 having intel gm965.

adding video=SVIDEO-1:d  as suggested by Greg to my /etc/default/grub has fixed the issue

#[  404.548250] vblank wait timed out on crtc 1
[  404.548403] WARNING: CPU: 1 PID: 1429 at drivers/gpu/drm/drm_vblank.c:1071 drm_wait_one_vblank+0x16e/0x180 [drm]
[  404.548407] Modules linked in: rfcomm ccm xt_CHECKSUM ipt_MASQUERADE nf_nat_masquerade_ipv4 tun ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ip_set nfnetlink ebtable_nat ebtable_broute bridge stp llc ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_raw ip6table_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack libcrc32c iptable_mangle iptable_raw iptable_security ebtable_filter ebtables ip6table_filter ip6_tables bnep sunrpc coretemp kvm_intel dell_rbtn kvm irqbypass dell_wmi sparse_keymap iTCO_wdt dell_smbios_wmi dell_laptop wmi_bmof dell_wmi_descriptor dell_smbios_smm gpio_ich iTCO_vendor_support dell_smbios acpi_cpufreq dcdbas dell_smm_hwmon btusb btrtl btbcm btintel bluetooth snd_hda_codec_hdmi snd_hda_codec_idt ecdh_generic
[  404.548527]  joydev snd_hda_codec_generic wmi i2c_i801 arc4 snd_hda_intel lpc_ich iwl3945 iwlegacy snd_hda_codec mac80211 snd_hda_core cfg80211 snd_hwdep rfkill snd_seq snd_seq_device snd_pcm snd_timer shpchp snd soundcore i915 tg3 firewire_ohci serio_raw firewire_core i2c_algo_bit drm_kms_helper ata_generic pata_acpi yenta_socket crc_itu_t drm ptp pps_core video
[  404.548598] CPU: 1 PID: 1429 Comm: Xorg Tainted: G        W        4.15.6-200.fc26.x86_64 #1
[  404.548602] Hardware name: Dell Inc. Latitude D630                   /0KU184, BIOS A19 06/04/2013
[  404.548638] RIP: 0010:drm_wait_one_vblank+0x16e/0x180 [drm]
[  404.548642] RSP: 0018:ffffa28cc0eb79c0 EFLAGS: 00010282
[  404.548648] RAX: 0000000000000000 RBX: ffff8ffcd33d8000 RCX: 0000000000000006
[  404.548652] RDX: 0000000000000007 RSI: 0000000000000082 RDI: ffff8ffcdfd168f0
[  404.548655] RBP: 0000000000000001 R08: 00000000000005ab R09: 0000000000000004
[  404.548659] R10: ffffa28cc0eb7870 R11: 0000000000000001 R12: 0000000000000000
[  404.548662] R13: 000000000f000798 R14: ffff8ffcd88d4d68 R15: ffff8ffc8002fc00
[  404.548668] FS:  00007f8b86ef2f00(0000) GS:ffff8ffcdfd00000(0000) knlGS:0000000000000000
[  404.548672] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  404.548676] CR2: 00007ff5b0683ba0 CR3: 0000000116d4e000 CR4: 00000000000006e0
[  404.548679] Call Trace:
[  404.548698]  ? finish_wait+0x80/0x80
[  404.548806]  intel_get_load_detect_pipe+0x554/0x5c0 [i915]
[  404.548896]  intel_tv_detect+0x147/0x500 [i915]
[  404.548928]  ? drm_helper_probe_single_connector_modes+0xd8/0x6e0 [drm_kms_helper]
[  404.549013]  ? intel_tv_get_modes+0x1f0/0x1f0 [i915]
[  404.549033]  drm_helper_probe_single_connector_modes+0xd8/0x6e0 [drm_kms_helper]
[  404.549043]  ? __ext4_journal_stop+0x36/0xa0
[  404.549086]  drm_mode_getconnector+0x156/0x320 [drm]
[  404.549096]  ? _cond_resched+0x15/0x40
[  404.549135]  ? drm_mode_connector_property_set_ioctl+0x60/0x60 [drm]
[  404.549160]  drm_ioctl_kernel+0x5b/0xb0 [drm]
[  404.549160]  drm_ioctl+0x2d5/0x370 [drm]
[  404.549160]  ? drm_mode_connector_property_set_ioctl+0x60/0x60 [drm]
[  404.549160]  do_vfs_ioctl+0xa4/0x620
[  404.549160]  SyS_ioctl+0x74/0x80
[  404.549160]  do_syscall_64+0x74/0x180
[  404.549160]  entry_SYSCALL_64_after_hwframe+0x3d/0xa2
[  404.549160] RIP: 0033:0x7f8b84760577
[  404.549160] RSP: 002b:00007ffdd7d475d8 EFLAGS: 00003246 ORIG_RAX: 0000000000000010
[  404.549160] RAX: ffffffffffffffda RBX: 00000000018229a0 RCX: 00007f8b84760577
[  404.549160] RDX: 00007ffdd7d47610 RSI: 00000000c05064a7 RDI: 000000000000000e
[  404.549160] RBP: 00007ffdd7d47610 R08: 0000000001822a50 R09: 0000000000000000
[  404.549160] R10: 0000000000000000 R11: 0000000000003246 R12: 00000000c05064a7
[  404.549160] R13: 000000000000000e R14: 000000000000000e R15: 00007ffdd7d47610
[  404.549160] Code: 2d ff ff ff e8 94 3c c9 c8 48 89 e6 4c 89 f7 e8 59 75 cd c8 45 85 e4 0f 85 0a ff ff ff 89 ee 48 c7 c7 40 1e 43 c0 e8 e2 39 c9 c8 &lt;0f&gt; 0b e9 f5 fe ff ff 90 66 2e 0f 1f 84 00 00 00 00 00 66 66 66 
[  404.549160] ---[ end trace 72e9a906a2432003 ]---
[  414.687273] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[  424.927280] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out


Note You need to log in before you can comment on or make changes to this bug.