Bug 139849 - Cut and paste fails, crashes xterm
Cut and paste fails, crashes xterm
Status: CLOSED DUPLICATE of bug 139846
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 09:22 EST by Per Steinar Iversen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Per Steinar Iversen 2004-11-18 09:22:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
Open a remote xterm through ssh like this:

$ ssh -X -f <server> xterm

Then a cut and paste from the remote window to a local one crashes the
remote xterm.
Pasting from a local to a remote xterm does not seem to work.
Cut and paste works well between different remote xterms on the same
screen.

A typical error message received:

# xterm:  warning, error event received:
X Error of failed request:  BadAtom (invalid Atom parameter)
  Major opcode of failed request:  18 (X_ChangeProperty)
  Atom id in failed request:  0x181
  Serial number of failed request:  174
  Current serial number in output stream:  176



Version-Release number of selected component (if applicable):
metacity-2.8.6-2

How reproducible:
Always

Steps to Reproduce:
1. Open remote xterm with: ssh -X -f <server> xterm
2. Attempts to cut and paste ends with remote xterm crash
3.
    

Actual Results:  Xterm dies.

Expected Results:  The cut and paste operations should have worked.

Additional info:

This fails when the remote machines are FC3 and also AS3. I am not
really sure if this is a metacity bug or a gnome bug.
Comment 1 Havoc Pennington 2004-11-18 13:03:15 EST

*** This bug has been marked as a duplicate of 139846 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.