Bug 139852 - /dev/nvidia# nodes deleted on reboot.
Summary: /dev/nvidia# nodes deleted on reboot.
Status: CLOSED DUPLICATE of bug 130746
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-18 14:33 UTC by Kelly Black
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:07:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kelly Black 2004-11-18 14:33:10 UTC
Description of problem:

Everytime that I reboot the /dev/nvidia# character nodes are deleted.
I have an nvidia quadro graphics card and use the driver from nvidia. 


Version-Release number of selected component (if applicable):

Fedora Version: FC3

Kernel (from uname -a):
Linux blackk.union.edu 2.6.9-1.678_FC3 #1 Mon Nov 15 18:28:07 EST 2004
i686 i686 i386 GNU/Linux

nvidia driver:
 NVIDIA-Linux-x86-1.0-6629-pkg1.run
Running the script installs the driver as:
/lib/modules/2.6.9-1.678_FC3/kernel/drivers/video/nvidia.ko

How reproducible:

Every time

Steps to Reproduce:
1. reboot machine
2.
3.
  
Actual results:

The following files are deleted:

crw-rw-rw-  1 root root 195,   0 Nov 18 08:06 /dev/nvidia0
crw-rw-rw-  1 root root 195,   1 Nov 18 08:06 /dev/nvidia1
crw-rw-rw-  1 root root 195,   2 Nov 18 08:06 /dev/nvidia2
crw-rw-rw-  1 root root 195,   3 Nov 18 08:06 /dev/nvidia3
crw-rw-rw-  1 root root 195,   4 Nov 18 08:06 /dev/nvidia4
crw-rw-rw-  1 root root 195,   5 Nov 18 08:06 /dev/nvidia5
crw-rw-rw-  1 root root 195,   6 Nov 18 08:06 /dev/nvidia6
crw-rw-rw-  1 root root 195,   7 Nov 18 08:06 /dev/nvidia7
crw-rw-rw-  1 root root 195, 255 Nov 18 08:06 /dev/nvidiactl


Expected results:

Files should not be deleted.

Additional info:

I can use mknod to recreate the nodes after reboot and everything is fine.

I have put the output from various system commands at the following URL's:

http://blackk.union.edu/~black/fc3/dmesg.txt
http://blackk.union.edu/~black/fc3/lsmod.txt
http://blackk.union.edu/~black/fc3/lspci.txt
http://blackk.union.edu/~black/fc3/lsusb.txt
http://blackk.union.edu/~black/fc3/modprobe.conf.txt


PS: On a personal note, I have been using redhat since 6.2. This is
the first time that I have had a problem upgrading my machine. When I
upgraded from FC2 my machine would not boot. When it tried to enable
the swap partitions the machine got a kernel panic and hung. I had to
wipe the system partitions clean and make a clean install. It was very
frustrating.

Comment 1 Mike A. Harris 2004-11-18 15:55:28 UTC

*** This bug has been marked as a duplicate of 130746 ***

Comment 2 Harald Hoyer 2004-11-18 17:24:01 UTC
see also: http://fedora.redhat.com/docs/udev/

Comment 3 Kelly Black 2004-11-18 18:54:52 UTC
Thank you all for the very quick responses. Reading the original bug
report helped to identify the issue, and the last link given
(http://fedora.redhat.com/docs/udev/) was extremely useful in finding
a fix for the problem. I was ready to put a bunch of mknod commands in
my rc.local! :-)



Comment 4 Red Hat Bugzilla 2006-02-21 19:07:07 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.