Bug 1398591 - upgrade to Fedora25 cannot proceed due to file rpm/macros conflict
Summary: upgrade to Fedora25 cannot proceed due to file rpm/macros conflict
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 25
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Igor Gnatenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1398742 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-25 11:17 UTC by Kamil Konieczny
Modified: 2016-12-07 10:02 UTC (History)
14 users (show)

Fixed In Version: rpm-4.13.0-5.fc25 rpm-4.13.0-6.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-05 21:44:36 UTC


Attachments (Terms of Use)
debugdata (8.89 MB, application/octet-stream)
2016-11-25 11:57 UTC, Kamil Konieczny
no flags Details
Fix arch-dependent requires in subpackages (RHBZ #1398591) (2.24 KB, patch)
2016-11-25 12:21 UTC, Igor Gnatenko
no flags Details | Diff
DNF Debug data (9.07 MB, application/x-tar)
2016-11-30 21:03 UTC, James Tomlinson
no flags Details

Description Kamil Konieczny 2016-11-25 11:17:54 UTC
Description of problem:

Fedora 24, x86_64, erasing option set due to libkface, not related to bug

dnf system-upgrade download --releasever=25 --allowerasing

cannot complete job due to error,

file /usr/lib/rpm/macros is in conflict with rpm-4.13.0-4.fc25.i686 and rpm-4.13.0-4.fc25.x86_64

is it due to both i686 and x86_64 rpm packets 
are present in upgrade x86_64 image ?

Exact error message (contains Polish words) from dnf.log:

Nov 24 22:20:50 CRITICAL Błąd: Transaction check error:
  plik /usr/lib/rpm/macros jest w konflikcie między instalowanymi rpm-4.13.0-4.fc25.i686 i rpm-4.13.0-4.fc25.x86_64

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. enter console, su to root
2. dnf system-upgrade download --releasever=25 --allowerasing
3.

Actual results:


Expected results:


Additional info:

Comment 1 Panu Matilainen 2016-11-25 11:40:05 UTC
Main rpm package is NOT supposed to be available in arch flavors, that is a distro compose bug. OTOH I dont know why dnf would try to pull in the i686 version anyway.

Not a bug in rpm though, its only doing its job by detecting the conflict.

Comment 2 Igor Gnatenko 2016-11-25 11:41:37 UTC
dnf system-upgrade download --releasever=25 --allowerasing --debugsolver

and attach "debugdata" directory

Comment 3 Kamil Konieczny 2016-11-25 11:57:45 UTC
Created attachment 1224229 [details]
debugdata

Comment 4 Igor Gnatenko 2016-11-25 12:08:51 UTC
* rpm-libs-4.13.0-1.fc24.i686@system has Req: rpm = 4.13.0-1.fc24
* rpm-libs-4.13.0-4.fc25.i686@updates has Req: rpm(x86-32) = 4.13.0-4.fc25

Comment 5 Panu Matilainen 2016-11-25 12:16:09 UTC
Oh. That also explains why rpm.i686 package got pulled into the x86_64 distro compose and everything. Ugh.

Comment 6 Igor Gnatenko 2016-11-25 12:21:13 UTC
Created attachment 1224248 [details]
Fix arch-dependent requires in subpackages (RHBZ #1398591)

Signed-off-by: Igor Gnatenko <ignatenko@redhat.com>

Comment 7 Panu Matilainen 2016-11-25 12:33:17 UTC
Looks ok to me, feel free fix for rawhide + f25 (including pushing an update).

Comment 8 Fedora Update System 2016-11-25 12:55:01 UTC
rpm-4.13.0-5.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-da15ae43d0

Comment 9 Igor Gnatenko 2016-11-25 18:30:36 UTC
*** Bug 1398742 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2016-11-27 22:59:12 UTC
rpm-4.13.0-5.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-da15ae43d0

Comment 11 Fedora Update System 2016-11-30 05:29:44 UTC
rpm-4.13.0-5.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 James Tomlinson 2016-11-30 21:02:26 UTC
The problem remains for me with exactly the same command as OP.

Error Summary
-------------

Nov 30 20:54:12 CRITICAL Error: Transaction check error:
  file /usr/lib/rpm/macros conflicts between attempted installs of rpm-4.13.0-5.fc25.i686 and rpm-4.13.0-5.fc25.x86_64

Comment 13 James Tomlinson 2016-11-30 21:03:44 UTC
Created attachment 1226508 [details]
DNF Debug data

Comment 14 Loïc GRENON 2016-12-03 10:55:40 UTC
I had the same problem, even with rpm-4.13.0-5.fc25
However, removing all installed rpm-*-i686 packages solves the problem.

Hope this might help.

Comment 15 Fedora Update System 2016-12-03 12:42:29 UTC
rpm-4.13.0-6.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-b7a95f6a89

Comment 16 Fedora Update System 2016-12-04 08:08:03 UTC
rpm-4.13.0-6.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b7a95f6a89

Comment 17 Fedora Update System 2016-12-05 21:44:36 UTC
rpm-4.13.0-6.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Kamil Konieczny 2016-12-07 10:02:25 UTC
Thank you, upgrade worked.

Can you describe what you corrected ?

There are some more 32-bit packets mixed into 64-bit intel platform,
so your notes can help others to improve.

Regards,
Kamil


Note You need to log in before you can comment on or make changes to this bug.