Bug 1398657 - [RFE] Re-enable node cleaning in undercloud
Summary: [RFE] Re-enable node cleaning in undercloud
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: Upstream M3
: 11.0 (Ocata)
Assignee: Dmitry Tantsur
QA Contact: mlammon
URL:
Whiteboard:
: 1244056 (view as bug list)
Depends On:
Blocks: 1421830
TreeView+ depends on / blocked
 
Reported: 2016-11-25 13:47 UTC by Dmitry Tantsur
Modified: 2017-05-17 19:47 UTC (History)
11 users (show)

Fixed In Version: instack-undercloud-6.0.0-0.20170220135156.d695df8.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:47:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Dmitry Tantsur 2016-11-25 13:47:22 UTC
We've disabled cleaning because it takes time and may be surprising for users. However, we need to at least provide a way to enable it back, as not wiping disks causes problems like https://bugzilla.redhat.com/show_bug.cgi?id=1244056 (and a few more).

Upstream blueprint: https://blueprints.launchpad.net/tripleo/+spec/re-enable-cleaning

Comment 1 Dmitry Tantsur 2016-11-25 13:50:15 UTC
*** Bug 1244056 has been marked as a duplicate of this bug. ***

Comment 2 Dmitry Tantsur 2017-01-06 16:23:51 UTC
This landed with a slightly modified scope: cleaning now works out-of-box, if enabled by setting "clean_nodes = True" in undercloud.conf. We need a separate RFE if we want it by default.

Comment 8 errata-xmlrpc 2017-05-17 19:47:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.