Bug 139892 - Building kernel also without "_enable_debug_packages"?
Building kernel also without "_enable_debug_packages"?
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 12:30 EST by Helmut Schlattl
Modified: 2015-01-04 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: kernel-2.6.12-1.1372_FC3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-22 10:20:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to enable kernel-built without "debuginfo" subpackage (860 bytes, patch)
2004-11-18 12:32 EST, Helmut Schlattl
no flags Details | Diff

  None (edit)
Description Helmut Schlattl 2004-11-18 12:30:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001
Firefox/0.10.1

Description of problem:
The standard Fedora kernel does not build, when the
"_enable_debug_packages" has been disabled manually in
/usr/lib/rpm/redhat/macros. 

May I suggest to use the attached patch to kernel-2.6.spec
in future kernel versions?
(The patch works with the current 2.6.9-1.667 - kernel.)
It would allow also those users to build a kernel, which
have disabled the building of the "debuginfo"-subpackages.

Greetings,

  Helmut

Version-Release number of selected component (if applicable):
2.6.9-1.667

How reproducible:
Always

Steps to Reproduce:
1.Comment "%_enable_debug_packages 1" in "/usr/lib/rpm/redhat/macros"
2.rpmbuild --rebuild kernel-2.6.9-1.667.src.rpm
3.
    

Actual Results:  Error message of unpackaged files (all in /usr/lib/debug)

Additional info:
Comment 1 Helmut Schlattl 2004-11-18 12:32:03 EST
Created attachment 106969 [details]
Patch to enable kernel-built without "debuginfo" subpackage
Comment 2 John Summerfield 2005-06-14 08:02:07 EDT
This problem (or one very like it) also exists in RHEL. I've not changed the rpm
files, instead I do it "properly" with this:
_topdir /var/local/el/rpms
%_builddir  %(mkdir /tmp/BUILD 2>/dev/null;echo /tmp/BUILD)
%_enable_debug_packages     0
%_build_arch        i686
%debug_package
%global __debug_package 0
%_target    i686-linux
%_target_cpu i686
%_host      i686-dingo-linux-gnu
%_arch      i686
#%_smp_mflags -j4
#%auxarches none
%_sourcedir %{_topdir}/SOURCES/%{name}-%{version}
%_sourcedir %{_topdir}/SOURCES/%{name}
%_rpmfilename   %%{NAME}-%%{VERSION}-%%{RELEASE}-dl3.90.%%{ARCH}.rpm
[summer@Bandicoot ~]$     
It's actually this line that produces the failure:
%debug_package
Comment 3 Dave Jones 2005-07-15 15:47:13 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 4 Helmut Schlattl 2005-08-22 10:20:22 EDT
I do not want to judge what the proper way is, but I personally prefer Dave's
solution.
From my point of view the issue is solved.

Note You need to log in before you can comment on or make changes to this bug.