Bug 139903 - RHEL4_BETA2 system-config-lvm shows incorrect size values
RHEL4_BETA2 system-config-lvm shows incorrect size values
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-lvm (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Jim Parsons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 13:32 EST by Uwe Beck
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.9.27
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-06 10:55:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Uwe Beck 2004-11-18 13:32:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4.3)
Gecko/20040924

Description of problem:
There is only a 9 GB scsi hdd in the system.

# fdisk -l /dev/sda

Platte /dev/sda: 9100 MByte, 9100369920 Byte
255 Koepfe, 63 Sektoren/Spuren, 1106 Zylinder
Einheiten = Zylinder von 16065 * 512 = 8225280 Bytes

    Geraet Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          10       80293+  83  Linux
/dev/sda2              11        1106     8803620   8e  Linux LVM

- one volumegroup
# vgdisplay
  --- Volume group ---
  VG Name               rootvg
  System ID
  Format                lvm2
  Metadata Areas        1
  Metadata Sequence No  3
  VG Access             read/write
  VG Status             resizable
  MAX LV                0
  Cur LV                2
  Open LV               2
  Max PV                0
  Cur PV                1
  Act PV                1
  VG Size               8,38 GB
  PE Size               32,00 MB
  Total PE              268
  Alloc PE / Size       267 / 8,34 GB
  Free  PE / Size       1 / 32,00 MB
  VG UUID               yzll1S-XxRa-fB15-O5De-txep-Wcnl-JIIrJR

# lvscan
  ACTIVE            '/dev/rootvg/LogVol00' [7,34 GB] inherit
  ACTIVE            '/dev/rootvg/swaplv' [1,00 GB] inherit

system-config-lvm means I have a 38 GB hdd.

One messages from system-config-lvm:
Traceback (most recent call last):
  File "/usr/share/system-config-lvm/Volume_Tab_View.py", line 292, in
on_tree_selection_changed
    self.vr.render_single_volume(pv, type)
  File "/usr/share/system-config-lvm/renderer.py", line 376, in
render_single_volume
    self.divide_single_volume(self.viewable_volume)
  File "/usr/share/system-config-lvm/renderer.py", line 1219, in
divide_single_volume
    extent_multiplier = operator.div(float(span), float(total))
ZeroDivisionError: float division
...


Version-Release number of selected component (if applicable):
system-config-lvm-0.9.3-1.0 on RHEL4_BETA2

How reproducible:
Always

Steps to Reproduce:
1. use system-config-lvm-0.9.3-1.0
2.
3.
    

Actual Results:  shows the 4 x real sizes for hdd/vg/lv

Expected Results:  show the correct hdd/vg/lv size

Additional info:

At this time it is not possible in bugzilla select the
system-config-lvm component for RHEL4_BETA2.
Comment 1 Stanko Kupcevic 2005-05-16 16:34:27 EDT
Fixed in 0.9.27
Comment 2 David Lawrence 2006-07-17 22:56:53 EDT
QA_READY has been deprecated in favor of ON_QA. Please use ON_QA in the future.
Moving to ON_QA.
Comment 3 Matthew Miller 2007-04-06 10:55:38 EDT
This bug is filed against "Fedora Test 2". Looks like it was meant to be against
RHEL4 Beta 2.

Given comment #1 and that the current package is way past that version, I'm
going to mark this fixed.

Note You need to log in before you can comment on or make changes to this bug.