Bug 139909 - updatedb segmentation fault on vfat partitions
updatedb segmentation fault on vfat partitions
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: slocate (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 13:48 EST by nowayout
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-17 04:35:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nowayout 2004-11-18 13:48:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Hello,

I am using Fedora Core 3. It a fresh installation. I have mount -t
vfat my windows fat drive o /mnt/windows. Then i wanted to search for
a file using locate and told me to type: updatedb. I did that. Then i
got segmentation fault. Tried again the command updatedb but stayed
there for 10 minutes, then i close it. 

[root@localhost ~]# mount
/dev/hda7 on / type ext3 (rw)
none on /proc type proc (rw)
none on /sys type sysfs (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/hda5 on /boot type ext3 (rw)
none on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
nfsd on /proc/fs/nfsd type nfsd (rw)
/dev/hda1 on /mnt/windows type vfat (rw)
------

As i see, it have problem with vfat so i tried updatedb -f vfat and it
worked succesfully.

[root@localhost ~]# updatedb -f vfat
[root@localhost ~]#



Version-Release number of selected component (if applicable):
[root@localhost ~]# updatedb --version
Secure Locate 2.7

How reproducible:
Always

Steps to Reproduce:
run updatedb with a vfat partition mounted

    

Actual Results:  updatedb -f vfat works succesfully

Additional info:
Comment 1 Miloslav Trmač 2005-02-16 17:33:43 EST
Hello,
using updatedb over vfat works fine in the limited testing I'm able to do now;
if this is still reproducible, could you please get a stack trace of the
segfault?

http://fedoraproject.org/wiki/StackTraces describes how to obtain a stack trace;
if you are using the FC3 slocate-2.7-12, you will need the debuginfo package
available e.g. at
http://download.fedora.redhat.com/pub/fedora/linux/core/3/i386/debug/slocate-debuginfo-2.7-12.i386.rpm

After you get the stack trace, please attach it to this report and we will
hopefully be able to find the bug and fix it.
Thanks.
Comment 2 Miloslav Trmač 2005-04-17 04:35:53 EDT
Please reopen this report if you can provide the requested data.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.