Bug 1399091 - Should update description for "keymap" in virt-install manual since it's available for both vnc and spice graphics
Summary: Should update description for "keymap" in virt-install manual since it's avai...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.4
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-28 09:35 UTC by zhoujunqin
Modified: 2017-08-01 21:02 UTC (History)
6 users (show)

Fixed In Version: virt-manager-1.4.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 21:02:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2072 0 normal SHIPPED_LIVE virt-manager bug fix and enhancement update 2017-08-01 18:36:34 UTC

Description zhoujunqin 2016-11-28 09:35:08 UTC
Description of problem:
Should update description for "keymap" in virt-install manual since it's available for both vnc and spice graphics

Version-Release number of selected component (if applicable):
virt-install-1.4.0-2.el7.noarch
virt-manager-1.4.0-2.el7.noarch
libvirt-2.0.0-10.el7.x86_64


How reproducible:
100%

Steps to Reproduce:
1. Check virt-install manual page for "keymap".
# man virt-install
...
           keymap
               Request that the virtual VNC console be configured to run with
               a specific keyboard layout. If the special value 'local' is
               specified, virt-install will attempt to configure to use the
               same keymap as the local system. A value of 'none' specifically
               defers to the hypervisor. Default behavior is hypervisor
               specific, but typically is the same as 'local'. This is used by
               'vnc'
...

Actual results:
As above, it says "This is used by 'vnc'", but in facts it's also available for "spice" graphics.

Expected results:
Update manual page.

Additional info:

Comment 2 Pavel Hrdina 2017-01-13 12:29:16 UTC
Upstream commit:

commit 45a3d506683164b8326fcafbbd498d7471a0daad
Author: Pavel Hrdina <phrdina>
Date:   Fri Jan 13 13:20:47 2017 +0100

    man: virt-install: keymap is valid for spice graphics as well

Comment 4 zhoujunqin 2017-03-14 09:47:52 UTC
I can reproduce this bug with package:
virt-install-1.4.0-2.el7.noarch
virt-manager-1.4.0-2.el7.noarch

Then try to verify this bug with new build:
virt-manager-1.4.1-1.el7.noarch
virt-install-1.4.1-1.el7.noarch
virt-manager-common-1.4.1-1.el7.noarch
libvirt-3.1.0-2.el7.x86_64

Steps:
# man virt-install
...
           keymap
               Request that the virtual VNC console be configured to run with a specific keyboard layout. If the special value
               'local' is specified, virt-install will attempt to configure to use the same keymap as the local system. A value of
               'none' specifically defers to the hypervisor. Default behavior is hypervisor specific, but typically is the same as
               'local'. This is used by 'vnc' and 'spice'.

Result:
1. Add support for spice guest "This is used by 'vnc' and 'spice'."
2. One question for description "Request that the virtual VNC console...", should it be updated to both virtual VNC console and SPICE console together.
@Pavel, please help me have a look of it, thanks.

Comment 5 Pavel Hrdina 2017-03-21 15:21:31 UTC
Sure, that should be updated as well, however It's minor issue and it's not worth fixing in RHEL-7.4 by backporting some patch from upstream.  The original bug that we should list vnc and spice is fixed.  I'll update the man page in upstream.

Comment 6 zhoujunqin 2017-03-22 03:18:02 UTC
(In reply to Pavel Hrdina from comment #5)
> Sure, that should be updated as well, however It's minor issue and it's not
> worth fixing in RHEL-7.4 by backporting some patch from upstream.  The
> original bug that we should list vnc and spice is fixed.  I'll update the
> man page in upstream.

Thanks for your reply, Pavel.
Based on your comment, i move this bug from ON_QA to VERIFIED.

Comment 7 errata-xmlrpc 2017-08-01 21:02:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2072


Note You need to log in before you can comment on or make changes to this bug.