Bug 139915 - RPM executing /emul/ia32-Linux/bin/sh (caps L)
RPM executing /emul/ia32-Linux/bin/sh (caps L)
Status: CLOSED DUPLICATE of bug 137452
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpm (Show other bugs)
4.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 14:25 EST by Srinivasa Suvvari
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Srinivasa Suvvari 2004-11-18 14:25:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
When installing package I got scriptlet errors. When I use --vv 
option, got the following. 

D:   install: %pre(package-3.2.532-0.i686) asynchronous scriptlet 
start
D:   install: %pre(package-3.2.532-0.i686)    
execv(/emul/ia32-Linux/bin/sh) pid 13057
D:   install: waitpid(13057) rc 13057 status ff00 secs 0.001
error: %pre(package-3.2.532-0.i686) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping package-3.2.532-
0

We don't have execv(/emul/ia32-Linux/bin/sh) pid 13057 in any of our 
package scripts, somehow RPM is picking it up. actual path is 
(/emul/ia32-linux/bin/sh (small l)

I made a symlink from /emul/ia32-linux to /emul-ia32-Linux to see if 
this is the only problem ... it is ... The package installed fine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install ia32 execution layer
2. Try to install 32-bit package on ia64
3. Will give scriptlet error

    

Additional info:
Comment 1 Jakub Jelinek 2004-11-18 14:53:21 EST
This has nothing to do with ia32el.
rpm sets the relocate path to /emul/%{ARCH}-%{OS}
so I guess for some reason you ended up with %OS being Linux, not linux.
Anyway, this definitely sounds like rpm issue.
Comment 2 Jeff Johnson 2004-11-18 23:59:43 EST

*** This bug has been marked as a duplicate of 137452 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.