Bug 1399176 - [RFE] Link Aggregation on bare metal
Summary: [RFE] Link Aggregation on bare metal
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Dmitry Tantsur
QA Contact: Dan Yasny
URL:
Whiteboard:
Depends On:
Blocks: 1391116 1399441
TreeView+ depends on / blocked
 
Reported: 2016-11-28 13:44 UTC by Keith Basil
Modified: 2017-05-17 19:48 UTC (History)
12 users (show)

Fixed In Version: openstack-ironic-7.0.1-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:48:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
Launchpad 1618754 None None None 2016-11-28 13:45:06 UTC

Description Keith Basil 2016-11-28 13:44:10 UTC
Description of problem:

Ironic currently supports only single nic deployments. Single nic architecture doesn't allow to have good fault tolerance and aggregate link speed capabilities. We need to have a support of bonded interfaces to reach good fault tolerance and allow aggregate link speeds.

The spec was approved: http://specs.openstack.org/openstack/ironic-specs/specs/approved/ironic-ml2-integration.html

Comment 1 Keith Basil 2016-11-28 13:47:04 UTC
Related:
[BP] [Nova] Ironic virt driver portgroups support:
https://blueprints.launchpad.net/nova/+spec/ironic-portgroups-support

Comment 2 Ramon Acedo 2017-01-20 14:57:10 UTC

*** This bug has been marked as a duplicate of bug 1399441 ***

Comment 3 Ramon Acedo 2017-01-20 15:04:51 UTC
Reopening as the duplicate (bz#1399441) is a private BZ

Comment 6 Dmitry Tantsur 2017-01-20 16:06:17 UTC
Ironic changes all landed, Nova changes were approved today and are moving through the CI: https://review.openstack.org/#/q/topic:bp/ironic-portgroups-support,n,z as well.

Comment 9 Ramon Acedo 2017-02-07 10:48:53 UTC
Do we have API test coverage (tempest) for this feature?

Comment 16 errata-xmlrpc 2017-05-17 19:48:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.