Bug 1399241 - unknown permission error when editing roles
Summary: unknown permission error when editing roles
Keywords:
Status: CLOSED DUPLICATE of bug 1389795
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Users & Roles
Version: 6.2.4
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: Unspecified
Assignee: Daniel Lobato Garcia
QA Contact: Marek Hulan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-28 15:50 UTC by Chris Duryee
Modified: 2017-08-02 12:29 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-02 12:29:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 16204 0 None None None 2016-12-05 21:03:14 UTC

Description Chris Duryee 2016-11-28 15:50:59 UTC
Description of problem:

from redmine ticket:

"""
If I browse to Administer > Roles, click "Filters" (on any role) > and click either "New Filter" or "Edit" an existing filter, I get the following error in the GUI

Oops, we're sorry but something went wrong ERF42-5434 [Foreman::Exception]: unknown permission view_taxonomies
"""

note: the redmine ticket mentions that roles cannot be edited. However, this error appears to be benign. I was able to repro it with 6.2.4.

Version-Release number of selected component (if applicable): 6.2.4

Comment 1 Bryan Kearney 2016-11-28 17:18:04 UTC
Upstream bug assigned to jsherril@redhat.com

Comment 2 Bryan Kearney 2016-11-28 17:18:07 UTC
Upstream bug assigned to jsherril@redhat.com

Comment 6 Bryan Kearney 2016-12-05 21:03:11 UTC
Connecting redmine issue http://projects.theforeman.org/issues/16204 from this bug

Comment 7 Satellite Program 2017-02-21 13:16:56 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/16204 has been resolved.


Note You need to log in before you can comment on or make changes to this bug.