Bug 139925 - (IT#54264) segfault in engine_init_default strcmp causes apache server to stop
segfault in engine_init_default strcmp causes apache server to stop
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: openssl (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 14:53 EST by Steve Conklin
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 11:48:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Conklin 2004-11-18 14:53:27 EST
User-Agent:       
Build Identifier: 

From IT#54264:

When sending a SIGHUP or SIGUSR1 to the apache parent process to restart it
after logrotation has completed the apache parent (and thus all children) will
exit with a Segmentation Fault on the second time that it recieves a SIGHUP or
SIGUSR1, the first HUP/USR1 will work fine, the second though will consistently
fail. This means that everyother day the customer has to manually start apache
back up after two cycles of logrotation has completed. I was able to gather
sysreport, core files with gdb bt output and strace data from both customers and
the system I had that was doing this issue. On reviewing the strace data from
both customers and my test system the apache failed when it was parsing the
/usr/share/ssl/openssl.cnf file and the gdb outputs all indicae that the last
thing that apache was doing was the strcmp function.
[snip, see issue for more info]
I cannot reproduce this here.

Reproducible: Couldn't Reproduce
Steps to Reproduce:
1. Send SIGHUP or SIGUSR1 to the apache parent process
2. Observe that the second time, the process segfaults.
3.

Actual Results:  
Sometimes segfaults

Expected Results:  
Should reinit apache

This is happening with openssl-engine-0.9.6b. In the CHANGES for the latest
version (openssl-0.9.7e), we find this under the changes from 0.9.6h->0.9.7:

  *) Make sure any ENGINE control commands make local copies of string
    pointers passed to them whenever necessary. Otherwise it is possible
    the caller may have overwritten (or deallocated) the original string
    data when a later ENGINE operation tries to use the stored values.
    [Götz Babin-Ebell <babinebell@trustcenter.de>]

Is it possible for us to bring RHEL2.1 up to the version we're using for RHEL3
(openssl-0.9.7a-33.12)? If not then fixing this will involve a non-trivial patch.
Comment 1 Tomas Mraz 2005-03-17 15:33:06 EST
> Is it possible for us to bring RHEL2.1 up to the version we're using for RHEL3
> (openssl-0.9.7a-33.12)?

This is not possible at all. So only backporting the patch remains. I'll try to
investigate how big the backported patch would be.
Comment 3 Tomas Mraz 2005-09-08 11:48:19 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.

Note You need to log in before you can comment on or make changes to this bug.