Bug 139945 - Error loading addressbook.
Error loading addressbook.
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: evolution-connector (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 16:16 EST by Brendon Colby
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 23:38:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brendon Colby 2004-11-18 16:16:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
My system is a FC2->FC3 upgrade. I had been running evolution 2 from
http://petrix.se/evolution2. The packages were successfully upgraded
with the FC3 packages. After upgrade, when I select Contacts, then my
Global Address List under my Exchange account, I get the following error:

Error loading addressbook.

We were unable to open this addressbook.  This either means you have
entered an incorrect URI, or the server is unreachable.


This worked fine before upgrade. I can't figure out what excactly is
causing this error.

Version-Release number of selected component (if applicable):
evolution-connector-2.0.2-1

How reproducible:
Always

Steps to Reproduce:
1. Go into Contacts area.
2. Select Global Address List under Exchange account.
    

Actual Results:  Unable to open addressbook

Error loading addressbook.

We were unable to open this addressbook.  This either means you have
entered an incorrect URI, or the server is unreachable.

Expected Results:  I should get the addressbook search screen.

Additional info:
Comment 1 Frank Pineau 2004-11-29 10:50:19 EST
Having the same problem, but mine was a clean install of FC3.  FC2
worked fine.  Having several issues with evolution-connector,
including inability to open calendars.

Note that a packet trace shows zero packets when clicking on the
address book button, so it's clearly not a network issue.
Comment 2 Frank Pineau 2004-11-29 11:23:07 EST
BTW:  Seeing a lot of this sort of thing in the stack trace:

(evolution:4779): libebook-WARNING **: Can't find installed
BookFactory that handles protocol 'exchange'.

(evolution:4779): evolution-mail-WARNING **: couldn't get service
exchange://fpineau@**MASKED**/;pf_server=**MASKED**;owa_path=/exchange;mailbox=fpineau;ad_limit=500;ad_server=**MASKED**:
No provider available for protocol `exchange'
Comment 3 Frank Pineau 2004-11-29 15:25:10 EST
Another data point:  Just looked at a co-worker's identical laptop
with a fully-patched FC3 and his contacts work fine.  The only thing I
could think to look at was /usr/lib/libebook.so.8.0.5 and his was a
different file size. I tried copying his over to mine, but it didn't
make a difference.  Not sure what else to look at.
Comment 4 Matthew Miller 2006-07-10 16:14:06 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 5 John Thacker 2006-10-30 23:38:20 EST
Closing per lack of response to previous request for information.
This bug was originally filed against a much earlier version of Fedora
Core, and significant changes have taken place since the last version
for which this bug is confirmed.

Note that FC3 and FC4 are supported by Fedora Legacy for security
fixes only.  Please install a still supported version and retest.  If
it still occurs on FC5 or FC6, please reopen and assign to the correct
version.  Otherwise, if this a security issue, please change the
product to Fedora Legacy.  Thanks, and we are sorry that we did not
get to this bug earlier.

Note You need to log in before you can comment on or make changes to this bug.