Bug 139951 - Cannot open remote file over FTP
Cannot open remote file over FTP
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 16:47 EST by Matthew Mott
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 15:53:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Mott 2004-11-18 16:47:23 EST
Description of problem:
The ability to connect to a remote FTP server with Nautilus and view it like a
local folder is very useful, however it is not possible to open a remote file
with its associated application (e.g. RPM files with system-install-package).
Instead an error message is displayed - "Cannot display ftp://path/file".

Version-Release number of selected component (if applicable):
nautilus-2.8.1-4

How reproducible:
Always (at least with RPM files)

Steps to Reproduce:
1. Connect to a remote FTP server, e.g. download.fedora.redhat.com
2. Navigate to a folder containing some RPM files
3. Double-click on an RPM file to open it.
  
Actual results:
Error message - "Cannot open
ftp://anonymous@download.fedora.redhat.com/path/file.rpm"

Expected results:
The file should be copied to a temporary directory and then opened
automatically, as if it were a local file.

Additional info:
Comment 1 Matthew Mott 2004-11-18 16:50:02 EST
Additional note - the file can be copied to a local directory and opened, so
this is not an access issue, it is an issue of Nautilus' behaviour.
Comment 2 Alexander Larsson 2004-11-19 03:11:58 EST
This is an app bug. If the app handles gnome-vfs uris and says so in
the desktop file (%u instead of %f) then it'll work.
Comment 3 Matthew Mott 2004-11-20 14:21:58 EST
Checked that out - opening a .txt file does indeed work.

RPMS are strange, though. Right-clicking on a local RPM gives "Install Packages"
and "Archive Manager" as the associated program options, but a remote RPM only
has "Other application", even though if you select this it correctly identifies
the file as type "RPM Package".
Comment 4 Jeremy Katz 2005-09-21 15:53:11 EDT
This is because system-config-packages doesn't have support for using gnome-vfs.
 We will consider adding thsi for a future generation of the tool

Note You need to log in before you can comment on or make changes to this bug.