Bug 139952 - ls -l fails on nfs shares with RPC: buffer allocation failed for task
ls -l fails on nfs shares with RPC: buffer allocation failed for task
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 16:50 EST by jason andrade
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 15:56:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jason andrade 2004-11-18 16:50:10 EST
Description of problem:

ls -l fails with RPC: buffer allocation failed for task in dmesg and
hangs.  

Version-Release number of selected component (if applicable):

redhat enterprise linux 3 qu3 with 2.4.21-20ELsmp kernel


How reproducible:

very

Steps to Reproduce:
1. reboot
2. apply high(er) nfs load
3. system hangs
  
Actual results:
ls -l hangs in a directory

Expected results:

ls -l completes and returns output

Additional info:

extremely annoying - requires (so far) a reboot of the machine
to clear (nfs client).
Comment 1 Suzanne Hillman 2004-11-19 14:41:34 EST
Is this reproducable on more than one machine?

What version is the nfs client?

Are you root or a non-root user when you try the 'ls -l'?
Comment 2 Leroy van Logchem 2004-11-30 07:32:49 EST
This bug has already been discused in length:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=118839

I don't understand why RedHat's up2date doesnt give there paying users
a properly fixed kernel. We experience downtime due this bug every few
weeks.

(The up2date tool gave us kernel 2.4.21-20.ELsmp #1 SMP up till now.)
Comment 3 Suzanne Hillman 2004-11-30 13:05:00 EST

*** This bug has been marked as a duplicate of 118839 ***
Comment 5 John Flanagan 2004-12-20 15:56:58 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html

Note You need to log in before you can comment on or make changes to this bug.