Bug 1399592 - Memory leak when self healing daemon queue is full
Summary: Memory leak when self healing daemon queue is full
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: selfheal
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Mateusz Slupny
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1400926 1400927
TreeView+ depends on / blocked
 
Reported: 2016-11-29 10:58 UTC by Mateusz Slupny
Modified: 2017-03-06 17:37 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1400926 1400927 (view as bug list)
Environment:
Last Closed: 2017-03-06 17:37:12 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mateusz Slupny 2016-11-29 10:58:09 UTC
Description of problem:

Applications using libgfapi are leaking under high load in when self healing daemon queue is full.

How reproducible:

Setting cluster.heal-wait-queue-length makes the issue easier to reproduce.

Comment 1 Worker Ant 2016-11-29 11:19:26 UTC
REVIEW: http://review.gluster.org/15968 (selfheal: fix memory leak on full shd queue) posted (#1) for review on master by Anonymous Coward (mateusz.slupny@appeartv.com)

Comment 2 Worker Ant 2016-11-30 11:51:18 UTC
REVIEW: http://review.gluster.org/15968 (selfheal: fix memory leak on full shd queue) posted (#2) for review on master by Mateusz Slupny (mateusz.slupny@appeartv.com)

Comment 3 Worker Ant 2016-12-01 04:55:28 UTC
REVIEW: http://review.gluster.org/15968 (selfheal: fix memory leak on client side healing queue) posted (#3) for review on master by Mateusz Slupny (mateusz.slupny@appeartv.com)

Comment 4 Worker Ant 2016-12-01 08:48:25 UTC
REVIEW: http://review.gluster.org/15968 (selfheal: fix memory leak on full shd queue) posted (#4) for review on master by Mateusz Slupny (mateusz.slupny@appeartv.com)

Comment 5 Worker Ant 2016-12-02 08:37:46 UTC
REVIEW: http://review.gluster.org/15968 (selfheal: fix memory leak on client side healing queue) posted (#5) for review on master by Mateusz Slupny (mateusz.slupny@appeartv.com)

Comment 6 Worker Ant 2016-12-02 10:05:52 UTC
COMMIT: http://review.gluster.org/15968 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit fb95eb4da6f4fc0b9c69e3b159a2214fe47e6d1d
Author: Mateusz Slupny <mateusz.slupny@appeartv.com>
Date:   Tue Nov 29 12:01:48 2016 +0100

    selfheal: fix memory leak on client side healing queue
    
    Change-Id: I2beaba829710565a3246f7449a5cd21755cf5f7d
    BUG: 1399592
    Signed-off-by: Mateusz Slupny <mateusz.slupny@appeartv.com>
    Reviewed-on: http://review.gluster.org/15968
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>

Comment 7 Shyamsundar 2017-03-06 17:37:12 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.