Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1399594 - Segfault when logging out of SSH session: Inconsistency detected by ld.so when unloading /usr/lib64/gssntlmssp/gssntlmssp.so
Segfault when logging out of SSH session: Inconsistency detected by ld.so whe...
Status: CLOSED DUPLICATE of bug 1398370
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Jelen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-11-29 06:15 EST by Adrien Bustany
Modified: 2016-11-29 06:39 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-29 06:18:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GDB session with SSH connecting and logging out of a server (18.51 KB, text/plain)
2016-11-29 06:15 EST, Adrien Bustany
no flags Details

  None (edit)
Description Adrien Bustany 2016-11-29 06:15:39 EST
Created attachment 1225788 [details]
GDB session with SSH connecting and logging out of a server

Description of problem:
On a Fedora 25 machine (upgraded from Fedora 24 via the DNF system upgrade plugin), when logging out of an SSH machine, I get an error message coming from ld.so followed by a segfault:

Connection to myshinyserver closed.
Inconsistency detected by ld.so: dl-close.c: 811: _dl_close: Assertion `map->l_init_called' failed!
[abustany@alu ~]$echo $?
127


Attached is a GDB session that shows where the assert happens. I'm happy to provide more information if needed. Some information in the log has ben stripped (server name/ip) by myself.

Version-Release number of selected component (if applicable):
openssh-clients-7.3p1-6.fc25.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Log in to an SSH server (via password or key)
2. Log out
3. Observe error
Comment 1 Jakub Jelen 2016-11-29 06:18:22 EST

*** This bug has been marked as a duplicate of bug 1398370 ***

Note You need to log in before you can comment on or make changes to this bug.