Bug 1399609 - [RFE] optimization in choice of target host for migration
Summary: [RFE] optimization in choice of target host for migration
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.HostedEngine
Version: 4.0.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.2.0
: 4.2.0
Assignee: Phillip Bailey
QA Contact: Artyom
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-29 12:16 UTC by Gianluca Cecchi
Modified: 2019-04-28 14:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
When migrating virtual machines, the host selection drop-down list filters the results to display only appropriate destination hosts.
Clone Of:
Environment:
Last Closed: 2017-12-20 10:55:01 UTC
oVirt Team: SLA
rule-engine: ovirt-4.2+
alukiano: testing_plan_complete+
mgoldboi: planning_ack+
dfediuck: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 72726 0 master MERGED webadmin: Filter destination hosts list 2020-06-29 04:10:57 UTC
oVirt gerrit 83439 0 master MERGED scheduler: Return list of valid hosts from canSchedule 2020-06-29 04:10:57 UTC

Description Gianluca Cecchi 2016-11-29 12:16:05 UTC
Description of problem:
Scenario: you want to migrate Hosted Engine VM from within the webadmin gui.
It would be nice to pre-filter the proposed drop down box when you have to choose the target host where migrate the hosted engine...
So that if there are no hosts available you will be given a related message without choice at all and if there is a subset of eligible hosts inside the cluster (because not all are configured as Hosted Engine enabled in general), you will be proposed only to choose one of them and not all the hosts inside the cluster.

Version-Release number of selected component (if applicable):
4.0.5

How reproducible:
always

Steps to Reproduce:
1. 3 hosts with only host1 and host2 configured as Hosted Engine.
Hosted engine running on host1.
2. from the gui select HE and "migrate"; don't choose the default option "select host automatically", but choose "select destination host" option: you are proposed host2 and host3. 
3. Choose host3, that is NOT configured as hosted engine

Actual results:
You get this error
https://drive.google.com/file/d/0BwoPbcrMv8mvY3pURVRkX0p4OW8/view?usp=sharing

Expected results:
The drop down list could be pre-filtered so that one cannot choose a host that is already known would give an error message.

Additional info:
In case of no further hosts enabled for Hosted Engine, apart where is already running, the user will get a window telling that he/she cannot migrate the HE VM and that it is advisable to add more hosts configured as Hosted Engine to guarantee HA

Comment 1 Doron Fediuck 2016-11-30 09:24:57 UTC
Thanks for reporting.
We will filter out all non-HE hosts.

Please note that regardless there may be cases where migration may fail
for various reasons. However this will make sure only relevant hosts will
be displayed.

Comment 2 Gianluca Cecchi 2017-02-21 11:40:24 UTC
It seems fine to me. Thanks

Comment 5 Gianluca Cecchi 2017-11-09 15:43:24 UTC
Great!

Comment 6 Artyom 2017-12-13 09:16:21 UTC
Verified on rhvm-4.2.0.2-0.1.el7.noarch accordingly to the test plan.

Comment 7 Sandro Bonazzola 2017-12-20 10:55:01 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.