Bug 139969 - Crashes after install of updated kernel
Crashes after install of updated kernel
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
bzcl34nup
:
Depends On:
Blocks: 87718
  Show dependency treegraph
 
Reported: 2004-11-18 18:01 EST by Alexander Hayman
Modified: 2008-05-06 20:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 20:04:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Hayman 2004-11-18 18:01:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
After I upgraded from kernel version 2.6.9-1.667 to 2.6.9-1.678_FC3,
system-network-config will not run.  The root password prompt comes
up, I type in the password, and after about 3 seconds, my memory and
CPU become completely used.  There must be a very bad memory leak.

I think this is similar to bug 122223.  The problem has something to
do with /usr/share/system-config-network/netconfpkg/NC_functions.py
near line 51, and the fact that the kernel version has an underscore,
where before it didn't.  I attempted to edit the code myself so it
could handle the underscore, but I am not very familiar with Python.

Version-Release number of selected component (if applicable):
system-config-network-1.3.22-1

How reproducible:
Always

Steps to Reproduce:
1.Upgrade to kernel-2.6.9-1.678_FC3
2.In Gnome, go to Hat->System Settings->Network
3.Type in root password and hit Ok.
    

Actual Results:  System CPU and memory resources become fully occupied
and system-config-network does not open.  Memory fully used about 3
seconds after execution.

Expected Results:  system-config-network opens

Additional info:
Comment 1 Alexander Hayman 2004-11-24 01:30:28 EST
After booting the older version of the kernel, I found that the
problem persisted.  Apparently, the kernel version isn't causing the
problem as I had thought.  I will keep trying to work backwards until
I figure this out.
Comment 2 Harald Hoyer 2004-11-24 04:17:47 EST
could you tray to start system-config-network from a root shell?? 
Comment 3 Alexander Hayman 2004-11-24 09:24:30 EST
I found the problem.  I had, at on point, tried to get 3d support for
my graphics card working.  So, I placed the line:

install radeon /sbin/modprobe radeon

into /etc/modprobe.conf.
So, when I run system-config-network, and I do a top, modprobe's
memory and cpu usage filled to 100%.  After removing this line,
system-config-network starts normally.  Interesting....
Comment 4 Harald Hoyer 2004-11-24 10:25:43 EST
strange, but thx for finding this! :)
Comment 5 Jeff Stern 2005-01-29 16:58:40 EST
after experiencing the exact same problems for the last month or so. i
read this bug report and alexander's last comment. following his lead
i looked in my /etc/modprobe.conf and found lo and behold that i too
had added something here in the last month for a flash memory device i
have:

#this is for the jumpdrive flash. --12/16/2004
install usb-uhci /sbin/modprobe usb-uhci
install usb-storage /sbin/modprobe usb-storage

..so i commented out the last two lines, rebooted, and now my
system-config-network does not lock up the system and crash my
X-windows. it now comes up fine and i can configure my network.
Comment 6 Harald Hoyer 2005-01-31 05:11:46 EST
jeff: s-c-network crashed your X-windows??
Comment 7 Alexander Hayman 2005-01-31 18:04:08 EST
S-c-network causes the memory to be fully consumed in a matter of
seconds.  I don't think it necessarily crashes X-windows, but the
system is pretty much crippled.
Comment 8 Matthew Miller 2006-07-10 18:07:59 EDT
Fedora Core 3 is now maintained by the Fedora Legacy project for security
updates only. If this problem is a security issue, please reopen and
reassign to the Fedora Legacy product. If it is not a security issue and
hasn't been resolved in the current FC5 updates or in the FC6 test
release, reopen and change the version to match.

Thank you!
Comment 9 Bug Zapper 2008-04-03 11:47:05 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 10 Bug Zapper 2008-05-06 20:04:07 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

Note You need to log in before you can comment on or make changes to this bug.