Bug 139970 - mc crashes when run in ssh session with ForwardX11 enabled
mc crashes when run in ssh session with ForwardX11 enabled
Status: CLOSED DUPLICATE of bug 125698
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-18 18:05 EST by Florin Andrei
Modified: 2013-07-02 19:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florin Andrei 2004-11-18 18:05:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I'm ssh'ing from my FC3 box to FC2 and FC3 boxes. My ssh client has
ForwardX11 enabled in /etc/ssh/ssh_config
If i run mc on the target system and i navigate a little bit, it
crashes. Messages i could gather in the terminal window:

X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 38 (X_QueryPointer)
Resource id in failed request: 0x60
Serial number of failed request: 6
Current serial number in output stream: 6


Version-Release number of selected component (if applicable):
both FC2 and FC3 mc crash

How reproducible:
Always

Steps to Reproduce:
1.enable ForwardX11
2.ssh to another system
3.run mc
    

Actual Results:  mc crashes

Expected Results:  mc should work properly

Additional info:
Comment 1 Jindrich Novy 2004-11-19 03:20:10 EST
Hello Florin,

please see bug 125838 and also bug 125698.
Comment 2 Jindrich Novy 2004-11-19 03:21:30 EST

*** This bug has been marked as a duplicate of 125698 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.