Bug 140004 - Update to 2.6.9-1.3 breaks APM Suspend to RAM
Update to 2.6.9-1.3 breaks APM Suspend to RAM
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-19 03:53 EST by Frank Schmitt
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.10-1.766_FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-20 17:20:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Schmitt 2004-11-19 03:53:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
I'm using APM on my Thinkpad R40. Suspend to Disk and Suspend to RAM
always worked perfectly but since the latest kernel update Suspend is
broken. The computer seems to go to sleep ok but after some minutes it
wakes up again and hangs forcing a hard reset. kernel-2.6.8-1.521 works.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.3_FC2

How reproducible:
Always

Steps to Reproduce:
1. Boot with kernel parameter acpi=off apm=on
2. Initiate APM Suspend to RAM
3. Wait some minutes
    

Actual Results:  It goes to sleep, wakes up after some minutes and hangs

Expected Results:  It should go to sleep and stay there until I wake
it and wakeup should work as it has always done

Additional info:
Comment 1 Frank Schmitt 2004-12-16 13:41:56 EST
Described behaviour is still present in Core 3 with kernel-2.6.9-1.681_FC3
Comment 2 Frank Schmitt 2004-12-16 16:22:24 EST
Updating to kernel-2.6.9-1.715_FC3 also doesn't help.
Comment 3 Frank Schmitt 2004-12-18 04:32:40 EST
I just tried Koppix 3.7 which also ships 2.6.9. I booted with
knoppix26 apm=on acpi=off and here APM Suspend to RAM worked. So
either Knoppix/Debian has a patch or the problem is Fedora specific.
Trying to build a stock 2.6.9 from kernel.org with Fedoras config now.
Comment 4 Frank Schmitt 2004-12-18 07:10:17 EST
Ok. I just did the followiing:
tar xjf linux-2.6.9 && cd linux-2.6.9
cp /boot/config-2.6.9-1.681_FC3 .
make oldconfig (accepted default in all questions)
disabled "kernel debugging"
make && make modules_install && make install
booted into new homebrewed kernel
and hody, APM suspend works.

So the problem seems to be caused by a patch in Fedoras RPM which was
introduced between the transition from 2.6.8 and 2.6.9 in the Core 2
cycle.

I'm perfectly willing to dig deeper into the issue but am running out
of ideas right now. Any tip on what to do next would be greatly
appreciated...
Comment 5 Frank Schmitt 2004-12-18 08:33:20 EST
Ok, I found it. As you see in my last post, I did an error:
cp /boot/config-2.6.9-1.681_FC3 .
should have been
cp /boot/config-2.6.9-1.681_FC3 ./.config

Because of this error, make oldconfig took the settings from the
currently running kernel, 2.6.8. Tried make oldconfig again with the
settings from Fedoras 2.6.9 (on the stock kernel sources) and it was
broken again.

I worked through the diffs between the configs and finally found the
cause of the problem: In the Fedora 2.6.9 kernels there's
"CONFIG_USB_SUSPEND=y". If I disable this, everything works again.

So the problem is *not* Fedora specific but an upstream bug caused by
the USB-Suspending-Code introduced in 2.6.9. I'm building 2.6.10rc3
right now to see if it's already fixed upstream.
Comment 6 Frank Schmitt 2004-12-18 14:11:07 EST
The guys from the Linux-USB devel list say, that the code is
unfinished and not suited for production systems. They therefor
strongly discourage distributions enabling it by default. See
http://article.gmane.org/gmane.linux.usb.devel/30190
Comment 7 Frank Schmitt 2005-02-20 17:20:21 EST
The problem is fixed for me in kernel-2.6.10-1.766_FC3, so I'll close the bug.

Note You need to log in before you can comment on or make changes to this bug.