Bug 1400230 - [7.4 FEAT] Update criu technology preview to latest upstream version on 7.4
Summary: [7.4 FEAT] Update criu technology preview to latest upstream version on 7.4
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: criu   
(Show other bugs)
Version: 7.4
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Adrian Reber
QA Contact: Chao Ye
Jaroslav Klech
URL:
Whiteboard:
Keywords: FutureFeature
Depends On: 1406471 1406475 1411734
Blocks: 1394638 1404314
TreeView+ depends on / blocked
 
Reported: 2016-11-30 17:30 UTC by Adrian Reber
Modified: 2019-04-21 07:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Technology Preview
Doc Text:
.`criu` rebased to version 3.5 Red Hat Enterprise Linux 7.2 introduced the `criu` tool as a Technology Preview. This tool implements *Checkpoint/Restore in User-space (CRIU)*, which can be used to freeze a running application and store it as a collection of files. Later, the application can be restored from its frozen state. Note that the `criu` tool depends on `Protocol Buffers`, a language-neutral, platform-neutral extensible mechanism for serializing structured data. The `protobuf` and `protobuf-c` packages, which provide this dependency, were also introduced in Red Hat Enterprise Linux 7.2 as a Technology Preview. In Red Hat Enterprise Linux 7.6, the `criu` packages were upgraded to upstream version 3.9, which provides a number of bug fixes and optimization for the *runC* container runtime. In addition, support for the 64-bit ARM architectures and the little-endian variant of IBM Power Systems CPU architectures has been fixed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 12:23:13 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2063 normal SHIPPED_LIVE criu enhancement update 2017-08-01 16:05:32 UTC

Description Adrian Reber 2016-11-30 17:30:45 UTC
As long as criu is a technology preview we should try to follow upstream. Upstream is still fast moving and is still implementing important features.

Comment 8 Adrian Reber 2017-05-03 11:35:41 UTC
Hi Marie,

sorry for forgetting about this.

criu has been upgrade from 2.3 in RHEL 7.3  to 2.12 RHEL 7.4. As long as it is still a technology preview we are taking whatever version upstream releases.

Most important changes, hmm, a lot has changed. One thing is that additional states of TCP sockets are supported. Not only listening and established sockets can be restored, but also half-closed sockets. mac-vlan devices are supported. Memory changes tracking for anonymous shared memory.

There is also another documentation effort ongoing for another criu related feature:

https://bugzilla.redhat.com/show_bug.cgi?id=1428351

Although it is not yet totally clear what will be part of RHEL 7.4

Comment 10 Adrian Reber 2017-05-15 09:23:16 UTC
Doc Text looks good.

Comment 12 errata-xmlrpc 2017-08-01 12:23:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2063


Note You need to log in before you can comment on or make changes to this bug.