Bug 1400262 - Cache size configured for memcached is 95% of total RAM
Summary: Cache size configured for memcached is 95% of total RAM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Alex Schultz
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-11-30 18:25 UTC by Vagner Farias
Modified: 2017-05-17 19:49 UTC (History)
4 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-0.20170225002532.0rc1.el7ost
Doc Type: Bug Fix
Doc Text:
The default memory configuration for Memcached was 95 per cent of total available RAM, which could lead to resource contention. This fix lowers the default value to 50 per cent of total available RAM. You also can now configure this value using the 'MemcachedMaxMemory' setting. This helps reduce possible resource conflicts.
Clone Of:
Environment:
Last Closed: 2017-05-17 19:49:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 431042 None None None 2017-02-08 16:41:56 UTC
OpenStack gerrit 431045 None None None 2017-02-08 16:41:05 UTC
Launchpad 1662941 None None None 2017-02-08 16:27:03 UTC

Description Vagner Farias 2016-11-30 18:25:46 UTC
Description of problem:
Currently OSP-d is configuring cache size for memcached to be 95% of total RAM as this is the default for openstack-puppet-modules. Although I'm unsure this could cause trouble as memcached is usually running together with other services (at least up to RHOSP 9), I'm raising this so it can be evaluated.

A similar bug was opened against Fuel at https://bugs.launchpad.net/fuel/+bug/1439882 

If this is not the right component for opening this bz, please change to the right one.

[root@dc01-controller-0 sysconfig]# facter memorysize
5.67 GB
[root@dc01-controller-0 sysconfig]# grep CACHESIZE /etc/sysconfig/memcached 
CACHESIZE="5515"

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-2.0.0-33.el7ost.noarch

How reproducible:
Always

Comment 1 Red Hat Bugzilla Rules Engine 2017-02-08 16:49:40 UTC
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.

Comment 4 Gurenko Alex 2017-03-28 08:29:19 UTC
Tested on puddle 2017-03-24.2

[stack@undercloud-0 ~]$ ssh heat-admin@192.168.24.17 "hostname; facter memorysize; grep CACHESIZE /etc/sysconfig/memcached"
controller-0.localdomain
7.64 GB
CACHESIZE="3911"

Comment 6 errata-xmlrpc 2017-05-17 19:49:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.