Bug 1400386 - openstack overcloud image upload doesn't work with --image-path option
Summary: openstack overcloud image upload doesn't work with --image-path option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Julie Pichon
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-01 03:46 UTC by Sai Sindhur Malleni
Modified: 2017-05-17 19:49 UTC (History)
12 users (show)

Fixed In Version: python-tripleoclient-6.1.0-1.el7ost
Doc Type: Bug Fix
Doc Text:
The 'openstack overcloud image upload' ignored the '--image-path' argument when uploading or updating overcloud images. Consequently, only images in the working directory could be used. The support for the '--image-path' argument has been added. Now images from different directories, specified by the argument, can be uploaded flawlessly.
Clone Of:
Environment:
Last Closed: 2017-05-17 19:49:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 434975 None None None 2017-02-27 10:24:12 UTC
Launchpad 1647519 None None None 2016-12-07 23:17:07 UTC

Description Sai Sindhur Malleni 2016-12-01 03:46:09 UTC
Description of problem: When using openstack overcloud image upload --update-existing with  the --image-path option see an error The given file overcloud-full.vmlinuz is not a regular file. Running the command from images directory without --image-path works


Version-Release number of selected component (if applicable):
RHOP 10 puddle from 2016-11-23.3


How reproducible:

100%

Steps to Reproduce:
1. Try to update over cloud images using openstack overcloud image upload --update-existing --image-path images/

2. 
3.

Actual results:
Required file "images/ironic-python-agent.initramfs" does not exist.

Expected results:
Images should be update based on image path


Additional info:

Comment 1 Nathan Morell 2017-01-02 19:02:50 UTC
I can confirm as I ran into this myself, running from the ~/images directory is fine but trying to pass in --image-path results in similar error messages as previous comments.

[stack@osp-tripleo ~]$ openstack overcloud image upload --update-existing --image-path ~/images/.
The given file overcloud-full.vmlinuz is not a regular file

Comment 3 Julie Pichon 2017-02-06 16:17:44 UTC
Marking as ON_DEV as there is currently a patch upstream. TripleO client has already branched for Ocata so the patch will get in Pike/12 first, will keep status up-to-date wrt backport.

Comment 4 Julie Pichon 2017-02-27 10:24:13 UTC
Ocata backport proposed upstream - https://review.openstack.org/#/c/434975/

Comment 8 errata-xmlrpc 2017-05-17 19:49:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.